Unity Applications Lens

Software Center - a Zeitgeist event should be loged when a app is un-pinned from the Launcher so that the app appears at the front of the list of recently used apps in the Dash

Reported by Ngassam Nkwenga on 2011-05-08
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Ubuntu Software Center
Undecided
Marco Trevisan (Treviño)
Unity
Medium
Marco Trevisan (Treviño)
unity-lens-applications
Medium
Unassigned
software-center (Ubuntu)
Undecided
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

I notice something which could be improve for Oneric .

Once we have installed an application and choosed not to create an entry to the launcher, it would be better for us , users, to have an entry for most recently installed applications. We need it beacause we always don't remember good about the difficult name of the app we installed. An entry forthe recently installed app will be a welcome.

------------------------------------------------------
Desired Solution:

As soon as an application gets completely installed, the software center should log a Zeitgeist event for that application so that it will be moved on top of 'Recently Used' category. That category header excludes applications that are currently in the Launcher, so recently installed applications *should not* show up underneath this category header by default (And this won't happen because applications are now automatically pinned to the Launcher after install).

It's still to define whether a zeitgeist event should be fired also when a user unpins the app from the Launcher.

Related branches

lp:~3v1n0/unity/appicon-log-zeitgeist-events
Merged into lp:unity at revision 3502
PS Jenkins bot: Approve (continuous-integration) on 2013-09-12
Andrea Azzarone: Approve on 2013-09-11
Ngassam Nkwenga (cyrildz) wrote :
tags: added: needs-design
Changed in unity-2d:
status: New → Incomplete
Changed in unity-place-applications:
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Changed in unity-place-applications (Ubuntu):
status: New → Incomplete
David Pitkin (dpitkin) wrote :

I added this to the buying-software bug queue as well, this will happen increasingly in the future and its at the very last step of installing an application, you will want to find it and run it "most likely"

tags: added: buying-software
John Lea (johnlea) on 2012-04-12
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity-2d:
status: Incomplete → Confirmed
Changed in unity-place-applications (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Changed in unity-lens-applications:
status: Incomplete → Confirmed
Changed in unity:
milestone: none → backlog
John Lea (johnlea) on 2012-04-16
tags: removed: needs-design
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Wishlist
Changed in unity-place-applications (Ubuntu):
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity-lens-applications (Ubuntu):
status: New → Triaged
Changed in unity-place-applications (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Omer Akram (om26er) on 2012-07-22
no longer affects: unity-place-applications (Ubuntu)
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-10-09
summary: - Applications lens should print the recently installed application
+ Launcher, Dash - a Zeitgeist event should be loged when a app is un-
+ pinned from the Launcher so that the app appears at the front of the
+ list of recently used apps in the Dash
Changed in unity:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity-lens-applications:
status: Confirmed → Triaged
importance: Undecided → Medium
no longer affects: unity-2d (Ubuntu)
Changed in unity (Ubuntu):
importance: Wishlist → Medium
Changed in unity-lens-applications (Ubuntu):
importance: Wishlist → Medium
John Lea (johnlea) on 2012-10-15
no longer affects: unity-2d (Ubuntu)
Stephen M. Webb (bregma) on 2013-04-25
no longer affects: unity-2d (Ubuntu)
no longer affects: unity-2d
Changed in unity:
milestone: none → 7.1.0
Stephen M. Webb (bregma) on 2013-06-20
Changed in unity:
milestone: 7.1.0 → 7.1.1
Changed in software-center:
status: New → Confirmed
summary: - Launcher, Dash - a Zeitgeist event should be loged when a app is un-
+ Software Center - a Zeitgeist event should be loged when a app is un-
pinned from the Launcher so that the app appears at the front of the
list of recently used apps in the Dash
description: updated
Changed in unity-lens-applications:
status: Triaged → Won't Fix
Changed in unity-lens-applications (Ubuntu):
status: Triaged → Invalid
Changed in unity:
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
Changed in software-center (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → In Progress
Changed in software-center:
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Dave Morley (davmor2) wrote :

I've added a u1-notrack tag to knock this bug off our tracker.

tags: added: u1-notrack
Changed in software-center:
status: In Progress → Invalid
Changed in software-center (Ubuntu):
status: In Progress → Invalid
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

It seems this bug is still relevant for the software center, since in case that the "Add to Launcher" option is disabled, then it's the only client that will be able to log a zeitgeist event about the new installed item.

Changed in software-center:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
status: Invalid → Confirmed
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in software-center (Ubuntu):
status: Invalid → Confirmed
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in software-center:
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Rodney Dawes (dobey) on 2013-09-11
Changed in software-center:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
Rodney Dawes (dobey) on 2013-11-25
Changed in software-center:
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints