The search engine should not be accent sensitive

Bug #773197 reported by François Tissandier on 2011-04-29
242
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Medium
Unassigned
dee
Medium
Mikkel Kamstrup Erlandsen
unity-lens-applications
Medium
Michal Hruby
dee (Ubuntu)
Medium
Unassigned

Bug Description

When searching for an application or file, Unity won't find anything if I don't put the right accents :
"economiseur" will not find "économiseur".

It should find it even if I don't put the right accent.

Related branches

Changed in unity:
status: New → Triaged
status: Triaged → Confirmed
importance: Undecided → High
Omer Akram (om26er) on 2011-05-02
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Omer Akram (om26er) on 2011-05-02
Changed in unity (Ubuntu):
status: Triaged → Confirmed
Eduardo Rivas (jerivasmelgar) wrote :

Remember to tolerate circumflexes (^), cedillas (ç), tremas (ü) and tildes (ñ).

TomasHnyk (sup) wrote :

And also carons: (ˇ) and rings (like in ů) http://en.wikipedia.org/wiki/Ů http://en.wikipedia.org/wiki/Hacek - well, there is a list of all the diacritical marks in those articles.

Robert Carr (robertcarr) on 2011-09-05
Changed in unity:
assignee: nobody → Robert Carr (robertcarr)

Just for note: this is not just about diacritics. Many would expect 'ø' to be matched by 'o' (and Danish people would also expect 'oe' to match). To fully resolve this bug we need a full featured transliteration framework. There are options out there, but it's not trivial to add in our current setup. It's my hope that we can tackle this for Ubuntu 12.04.

Omer Akram (om26er) on 2011-12-01
Changed in unity (Ubuntu):
importance: Medium → High
Changed in dee:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 1.0.2
status: New → In Progress
Changed in unity:
assignee: Robert Carr (robertcarr) → nobody
Changed in unity-lens-applications:
importance: Undecided → High
milestone: none → 5.2
status: New → Triaged
Changed in unity-lens-files:
importance: Undecided → High
status: New → Triaged
Omer Akram (om26er) on 2012-01-27
Changed in dee:
status: In Progress → Fix Committed

To clear up potential confusion: The current state is that the DeeIndex/Analyzer frametwork can do transliteration of diacritics (and everything else for that matter (ICU FTW!). There is still work to be done in the lenses and other consumers to "connect the wires" before we can close this bug on all projects.

Didier Roche (didrocks) on 2012-02-01
Changed in unity-lens-applications (Ubuntu):
status: New → Triaged
Changed in unity-lens-files (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2012-02-01
Changed in dee (Ubuntu):
status: New → Fix Committed
Michal Hruby (mhr3) on 2012-02-03
Changed in unity-lens-applications:
milestone: 5.2.0 → none
Omer Akram (om26er) on 2012-02-13
Changed in unity-lens-files:
importance: High → Medium
Changed in unity:
importance: High → Medium
no longer affects: unity-lens-files (Ubuntu)
Changed in dee (Ubuntu):
importance: Undecided → Medium
no longer affects: unity-lens-applications (Ubuntu)
no longer affects: unity (Ubuntu)
no longer affects: unity-lens-files
no longer affects: unity-lens-applications
Changed in unity:
status: Confirmed → Fix Committed
status: Fix Committed → Invalid
Michal Hruby (mhr3) wrote :

This actually still affects apps lens, since it's building the index itself.

Michal Hruby (mhr3) on 2012-02-15
Changed in unity-lens-applications:
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Michal Hruby (mhr3)
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Changed in dee:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers