Dash: only returns first 5–6 "available to download" results; misleading because many more are in the Software Centre

Bug #754424 reported by Jane Silber on 2011-04-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Ubuntu Translations
Undecided
Unassigned
Unity
Won't Fix
Medium
Mikkel Kamstrup Erlandsen
Unity Foundations
Medium
Mikkel Kamstrup Erlandsen
unity-lens-applications
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned

Bug Description

1. From the dash, select "media apps" (this some bug applies to "internet applications" well
2. A panel with 3 sections is returned - frequently used, installed, and available for download. If you have many installed, the installed section appropriately give you a way to see the other ones (e.g, a link which says "see 5 more results". However, in the "available for download" section, there is no indication that there are more apps than are shown, and there is no way to get to them. This is wrong because it doesn't accurately reflect the amazing selection of apps that exist, nor can the user get to any other than the 5-6 that are shown.

What should happen?

3. In the "apps available for download" section, there should be an indication of "see 152 more" (or whatever the correct number is) and that should link to an appropriate invocation of the software centre so that you can install them.

Tags: udt Edit Tag help

Related branches

Paul Sladen (sladen) on 2011-04-08
summary: - dash search results present misleading results and available apps
+ Dash: only returns first 5–6 "available to download" results; misleading
+ because many more are in the Software Centre
Changed in unity-place-applications:
status: New → Confirmed

I agree that this is a problem. Unfortunately it's not as simple as "just appending more apps" to that section.

Some observations:

 - Loading a lot of items into the dash can possible degrade the responsiveness of the UI. Especially on low end hardware. For reference there are about 2,4k apps all in all in the software-center index which we use for this

 - Users have responded very positively to the purely random selection of apps we present now. It incites serendipity (which would actually slightly degrade would we select semi-random apps sorted by popularity, but I digress).

 - Since the apps are random picks there is no way to meaningfully expand that section - as all apps sorted randomly would probably give an even worse impression.

Attaching a mockup of a possible solution.

The idea is to let the first item in the sample apps be a place holder, that when clicked repopulates the list with all avail apps for the particular category sorted alphabetically.

The reason why we need to go about it like this is that there is currently no way in the communication between the lens/place daemons and Unity/Unities to signal that the expander has been clicked and that the data daemon should take some action (repopulating the section in this case).

So; the proposed solution can be done without breaking API or anything. It does require a non-trivial amount of code, but is doable if the release team looks very favourable on this :-)

Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-08
Changed in unity-place-applications (Ubuntu):
status: New → Confirmed

Mikkel, thanks for the creative suggestion. However, I think we need a
more predictable solution. From a design perspective:

 * if this is a random selection, it should say so
 * if there are in fact more available (even if we don't know how many)
that should be clear
 * the expansion mechanism should be consistent

So, I think this will require an API change, and we should defer it to
Oneiric.

Mark

Attached a branch implementing the mockup. In doing that i discovered that Unity doesn't respect the return values in the Activation API as specified https://wiki.ubuntu.com/Unity/Lenses#com.canonical.Unity.Activation

Changed in unity:
milestone: none → 3.8.6
Changed in unity-place-applications:
milestone: none → 0.2.48
Changed in unity-foundations:
milestone: none → unity-3.8.6

Attaching a screencast demonstrating the attached branches in practice (lag is due to screen recording)

Right Mark; I agree that my proposed solution is not super smooth, not too bad practice though. A middle ground would be to simply make the section header "Sample Apps Available for Download" when showing the random selection.

Mark Shuttleworth (sabdfl) wrote :

On 08/04/11 15:20, Mikkel Kamstrup Erlandsen wrote:
> Right Mark; I agree that my proposed solution is not super smooth, not
> too bad practice though. A middle ground would be to simply make the
> section header "Sample Apps Available for Download" when showing the
> random selection.

If that's the best we can do in Natyt, +1

We *definitely* need to clean this up in Oneiric. Thanks Mikkel,
sterling work as always.

Mark

Apps available to download should be NOT displayed in Dash in firs place. It's BS.
They should be available exclusively only in Software Center.. Wake Up already :)

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
David Barth (dbarth) wrote :

I'm considering that Mark's +1 is constitutes a formal handover to engineering for delivery.

Changed in unity-foundations:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
Changed in unity-foundations:
importance: Undecided → Medium
status: New → In Progress
Changed in unity:
status: Confirmed → In Progress
tags: added: udt
Changed in ayatana-design:
status: New → Fix Released
Didier Roche (didrocks) on 2011-04-13
Changed in unity-place-applications:
status: Confirmed → In Progress
Changed in unity-place-applications (Ubuntu):
status: Confirmed → In Progress
Dylan McCall (dylanmccall) wrote :

It's an impressive bit of work, Mikkel, but are we still solving the original problem? What is the rationale for showing all of the available apps in the lense, instead of having the “Show more” button launch Software Centre directly? To me, Software Centre seems better tuned for actually browsing available software (as opposed to installed software). It presents ratings, it offers more levels of searching and filtering, it's clear what category is being explored (and what others there are), and it allows you to install multiple applications from a single set of results.

A quick note on the rationale would be appreciated. Thanks :)

Feature- and String Freeze Exception Request:

The branch lp:~kamstrup/unity-place-applications/sample-apps attached to this bug adds a new string to the unity-place-applications package.

Changed in unity-place-applications (Ubuntu):
status: In Progress → New
Didier Roche (didrocks) on 2011-04-14
Changed in unity-place-applications (Ubuntu):
status: New → In Progress
Martin Pitt (pitti) wrote :

Once you type some letters, the category already shows "Apps for download ... See 44 more results >", which seems correct to me.

It doesn't seem very useful to me to show the category at all if you didn't yet start searching for anything. That's what the software-center is for, so an alternative proposal which avoids the string (and thus translation) break:

 * Do not show the download category at all initially
 * Only show the software-center launcher in the category initially

@Martin: That was how it was in the beginning of the cycle :-) only showing downloads when searching (and in 10.10 as well). And as noted earlier I've really gotten a lot of nice feedback on the random apps. People seem to dig it, so it would be a shame to lose it because of this.

Just showing the S-C as a sole member of the downloadable apps groups seems a bit inelegant to me...

 - or to make it clear - in stead of Martin's proposals I'd prefer status quo; not only do we keep the random apps, but I also believe the feature is more discoverable with it (which is of course 110% subjective).

Martin Pitt (pitti) wrote :

But what's the purpose of showing 6 random applications out of 30.000 packages? It's almost never going to be one which you need right now, or are even interested in, so it feels like a pretty unhelpful billboard. Perhaps we can hide that category altogether then when no search has been started yet?

We only show apps, so it's about 2,4k. Still a lot, but enough to add a grain of serendipity to the mix, and once you browse into a category you restrict the random choices to that category. The place where they make the least sense is definitely the All Applications category where the selection is truly random - so we could possibly remove the group just when category==AllApps.... I still think I prefer status quo though.

Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
Mark Shuttleworth (sabdfl) wrote :

I agree with Martin that "6 random results" is a very weak user
experience. If we had the means to do a real "recommended for you" then
we could put that there, but it would need to be based on something
credible, not /dev/random :-)

Mark

@Mark: What do you base "'6 random results' is a very weak user experience" on? At my previous work we did some user testing on a similar setup and the users where really happy about it. Sure we could present it better, but freezes prevent that right now.

The problem with a recommendation system is that it destroys the moment of serendipity, or at least it skews the field so you are most like to stumble upon the "popular stuff". So maybe it really boils down to whether one wants a system that entices serendipitous discovery or if one wants a "user guidance system". Personally I prefer the former which is probably why the apps place is like it is :-)

So the question we need an answer for is "what do we want to use the Apps Available for Download" group in the dash for? Since browsing 2,4k apps alphabetically was not very appealing both aesthetically or performance wise I think a good answer is "entice serendipitous discovery". This also fits well with the idea the dash is quick and nimble. It's not a good place to browse recommendations in, that requires immersion. You just want it quickly out of your way.

With random apps you *know* that what's there is unimportant. Just like we have ephemeral notifications to not distract you too much. But it does open the opportunity for you on a lazy day to stop and say "wow, what's that..?".

Enough of my rambling :-)

John Lea (johnlea) wrote :

Marked as invalid because this bug has been superseded by the new Dash design targeted for Oneiric.

Changed in ayatana-design:
status: Fix Released → Invalid
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
David Barth (dbarth) on 2011-04-22
Changed in unity-foundations:
milestone: unity-3.8.6 → none
Changed in unity:
milestone: 3.8.12 → backlog
Changed in unity-place-applications:
milestone: 0.2.48 → none
milestone: none → 0.2.48
Changed in unity:
milestone: backlog → none
status: In Progress → Invalid
Changed in unity-foundations:
status: In Progress → Invalid
Didier Roche (didrocks) on 2011-04-26
Changed in unity:
status: Invalid → In Progress
Didier Roche (didrocks) on 2011-04-26
Changed in unity:
status: In Progress → Incomplete
Changed in unity-place-applications:
status: In Progress → Incomplete
Changed in unity-place-applications (Ubuntu):
status: In Progress → Incomplete
Didier Roche (didrocks) on 2011-04-28
Changed in unity (Ubuntu):
status: New → Incomplete

Marked as Won't Fix for source modules since there will be no resolution for this in Natty. New designs in Oneiric will rethink the structure here.

Changed in ubuntu-translations:
status: New → Invalid
Changed in unity:
status: Incomplete → Won't Fix
Changed in unity-place-applications:
status: Incomplete → Won't Fix
Changed in unity (Ubuntu):
status: Incomplete → Won't Fix
Changed in unity-place-applications (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers