Unity Applications Lens

Dash - Add sub-string matching to Dash search

Reported by seanlano on 2011-04-06
178
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
unity-lens-applications
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

Not a bug specifically, but...

It would be really nice if, when you hit Super and start typing the name of an application you wish to open, Unity behaved more like GNOME-Do. What I mean is that in Unity's current form, you have to type the proper name of the application. Whereas in GNOME-Do, you can just hit a few characters from it and it will find it for you. For example, "Synaptic Package Manager". In Unity you have to start typing S Y N, but in GNOME-Do you could type S M or S P or S P M, etc and it knows what you mean. The letters don't have to be adjacent to each other in the name of the application for GNOME-Do, but they must be in Unity. This would be a nice little feature to have, and would make Unity that little bit more unifying.

-------------------
Second description of same issue from dupe bug:

This could be seen as a wishlist, but in my opinion the current behavior is unexpected.

When using dash and starting writing the name of the application/file, I expected the match being done with *all* the name of the application, not just the *start*. I mean, if I type "dict", I expect to see both "Dictionary" and "StarDict". I notices this several time; you often remember part of the name of the application and sometime it is not the start of it.

Bilal Akhtar (bilalakhtar) wrote :

Needs design discussion. Marking incomplete in the meantime.

tags: added: needs-design
Changed in unity:
status: New → Incomplete
Omer Akram (om26er) on 2011-04-06
Changed in unity (Ubuntu):
status: New → Incomplete
Sebastock (sebastock) wrote :

I fully agree with you. In gnome-do, I just have to type "f" and press "enter" to open firefox. With unity, I have to type "f" "i" "r" "e" then press tab twice and finally press enter to open firefox. It would be much more efficient if there was an auto-completion or suggestion 'à la' gnome-do.

Bilal Shahid (s9iper1) wrote :

ur report is incomplete so complete it use this code in terminal
apport-collect 752259

apport information

tags: added: apport-collected natty running-unity ubuntu
description: updated

apport information

OK, done. But I'm not sure that it will be that helpful for this issue, as it isn't a problem with the operation of the software. It's a design issue.

Sebastock (sebastock) wrote :

Btw, there is also an entry on this topic in the ubuntu brainstorm (idea 27530).

Eduardo Rivas (jerivasmelgar) wrote :

Well, it'll be even better if we could get many of the features that made Do more than a launcher, like executing actions over items and integrating with web services and stuff. It's quite terrific because a regular user can keep using it as a launcher, but a power user could work wonders with it by knowing the key bindings and advanced features.

John Lea (johnlea) on 2011-06-20
tags: added: udo
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Fix Committed
importance: Undecided → Wishlist
Neil J. Patel (njpatel) on 2011-06-30
Changed in unity:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
seanlano (seanlano) wrote :

Just out of interest, what is the "Fix Released" referring to? Has Unity been modified to have the above functionality? Awesome!

Matthew Paul Thomas (mpt) wrote :

seanlano, no, Ayatana Design uses statuses differently from every other Launchpad project. Fix Released means that the design is finalized. To see whether it's implemented, check the status in the project where the bug actually exists (in this case, Unity).

@mpt: ehm, but what's the design decision here? I can't find any implementation details...

Let me chime in here, as apps lens maintainer who did this original behavior, although I don't make calls for design.

The current behavior is very much intentional for many reasons.

 1) I am quite sure that 99.9% of the non-geeks in my social circles would be utterly confused about the perceived random matching (which I admit, i was myself for several months with Do)

 2) I believe it is important that we have the same matching for installed apps as we do for those we find in the Software Center catalog (in Apps Availabale for Download). And in fact, also the same mathcing criteria for files. Doing sub-pattern matching like described on massive corpora like the S-C catalog or the entire files index is not feasible, nor would it provide sensible results.

 3) I don't buy the argument that it is easier to type "sp" than it is to type "syn". That's a matter of muscle memory. And isn't it even easier to hit <super>-N where N is the offset of the launcher item?

 4) Experts can easily uninstall the default apps lens an install a custom apps lens that has the desired behavior (given that some writes it first of course ;-))

Paul Sladen (sladen) wrote :

My suspicion is that an element of the "random results" is because the result is evaluated at the point '[enter]' it hit, rather than computing the result for the whole line of input, then selecting the top result. (eg. typing slowly, or typing fast produces different == non-predictable results).

Matthew Paul Thomas (mpt) wrote :

Marco, I have no idea, sorry. The Dash specification doesn't mention how applications (or items in general) should be chosen as results.

John Lea (johnlea) on 2011-10-14
description: updated
summary: - Make typing shortcuts more like GNOME-Do
+ Dash - Add sub-string matching to Dash search
Changed in ayatana-design:
importance: Wishlist → High
Omer Akram (om26er) on 2011-10-14
Changed in unity:
importance: Wishlist → Medium
Changed in unity (Ubuntu):
importance: Wishlist → Medium
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
Mirco Müller (macslow) on 2011-11-01
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
John Lea (johnlea) on 2011-11-01
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: text-analysis

As a note - I hacked together a "playground" we can use more easily to play around with different matching semantics in lp:unity-lens-bliss. See also http://www.grillbar.org/wordpress/?p=568

John Lea (johnlea) on 2012-04-14
description: updated
bruce (bruce-oy) wrote :

i hope that the camel-case match in the dash will comes with the next unity release.

John Lea (johnlea) on 2012-07-05
tags: added: substring
Omer Akram (om26er) on 2012-07-17
Changed in unity:
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → nobody
Changed in unity-lens-applications:
importance: Undecided → Medium
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-12
Changed in unity:
status: Confirmed → Triaged
Changed in unity-lens-applications:
status: Confirmed → Triaged
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in ayatana-design:
importance: High → Medium
Adam Wojtowicz (astenu) wrote :

In 12.04 I've noticed that dash returns searches for substring (partial words) for files and folders but not for applications. E.g.:
 - searching for "hrom" returns "Chromatic Fantasy" file but NOT "Chromium Browser"
 - searching for "chrom" returns both file and application
It would be very helpful to return the partial word matches for applications also.

markba (mark-baaijens) wrote :

I 've tested in 13.04 the scenario, and there it is working as Adam described. So we have already partial searching, but only (or at least) for files and not for apps.

Pawel Stolowski (stolowski) wrote :

With the introduction of libcolumbus and fuzzy matching it now (13.10) works as described in this bug report (one can argue it's too tolerant and fuzzy).

Changed in unity-lens-applications:
status: Triaged → Fix Committed
no longer affects: unity
Changed in unity-lens-applications (Ubuntu):
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers