Unity Applications Lens

Alt-F2 in Unity can not open URLs

Reported by ChrisLees on 2011-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Low
Bilal Akhtar
Unity Foundations
Low
Bilal Akhtar
unity-lens-applications
Low
Bilal Akhtar
unity-place-applications (Ubuntu)
Undecided
Bilal Akhtar

Bug Description

When you press Alt-F2 in the classic Ubuntu desktop, you can type 'apt:packagename' and Ubuntu Software Center will open and offer to install the package.

This no longer happens in Unity's Alt-F2 function. I'd rather like this functionality back, to speed up package installs. Now that I try, the Alt-F2 in Unity doesn't open ANY sort of URLs. But I really just want apturls to work again inside the Alt-F2 thingy.

Running latest Natty on AMD64, with Unity 3D.

description: updated
tags: added: natty unity
Bilal Akhtar (bilalakhtar) wrote :

This probably needs a confirmation from the Design team as well.

affects: unity → unity-place-applications
Changed in unity-place-applications:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: New → Confirmed
tags: added: needs-design
Didier Roche (didrocks) on 2011-04-05
Changed in unity:
status: New → Confirmed
Changed in unity-place-applications (Ubuntu):
status: New → Confirmed
Changed in unity-place-applications:
status: Confirmed → In Progress
Changed in unity-place-applications (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Confirmed → In Progress
Bilal Akhtar (bilalakhtar) wrote :

Doesn't need design discussion, this is the intended behavior from any run dialog box.

Changed in ayatana-design:
status: New → Invalid
tags: removed: needs-design
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Confirmed → In Progress

I committed Bilal's branch and added the more generic ability to open any kind of URL from the alt-f2 dialog

Changed in unity:
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Undecided → Low
milestone: none → 3.8.4
status: In Progress → Fix Committed
Changed in unity-place-applications:
importance: Undecided → Low
milestone: none → 0.2.46
status: In Progress → Fix Committed
Changed in unity-foundations:
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Undecided → Low
milestone: none → unity-3.8.4
status: New → Fix Committed
summary: - Alt-F2 in Unity won't open apturls
+ Alt-F2 in Unity can not open URLs
Changed in unity-foundations:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.46-0ubuntu1

---------------
unity-place-applications (0.2.46-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Alt-F2 in Unity can not open URLs (LP: #750262)
  * bump libunity dep for soname bump
 -- Didier Roche <email address hidden> Thu, 07 Apr 2011 13:06:38 +0200

Changed in unity-place-applications (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers