Unity Applications Lens

Safe search ranking

Reported by Mikkel Kamstrup Erlandsen on 2011-03-30
28
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity-2d
Undecided
Unassigned
unity-lens-applications
Undecided
Mikkel Kamstrup Erlandsen
software-center (Ubuntu)
Medium
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

As discussed in bug #739469 "Dash search unavoidably returns offensive results" the Apps Available for Downloads section can contain apps that may offend different demographics. Apps can be offensive because they are explicit such as PornView or because of religious reasons or other.

It's probably an impossible task to come up with something that is 100% safe all of the time, but we should at least reduce the risk of embarrassing moments to an absolute minimum.

One solution could be to have the popcon ranking from the Software center index influence the weight of the document.

Alex Launi (alexlauni) on 2011-04-05
Changed in unity:
status: New → Confirmed
Changed in unity-place-applications:
status: New → Confirmed
Changed in unity-place-applications (Ubuntu):
status: New → Confirmed
Changed in unity-place-applications:
status: Confirmed → Won't Fix
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Didier Roche (didrocks) on 2011-04-07
Changed in unity-place-applications:
status: Won't Fix → Confirmed
yman (s-y-schwarz) wrote :

I think anything that would get a rating higher than PG-13 should be hidden like the technical items, with separate links each for showing the mature content and technical items.

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Omer Akram (om26er) on 2012-08-19
no longer affects: unity-place-applications (Ubuntu)

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 745534
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity-lens-applications:
status: Confirmed → Incomplete
Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Changed in unity-2d:
status: Confirmed → Incomplete
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Changed in unity:
status: Incomplete → Confirmed
Changed in unity-lens-applications:
status: Incomplete → Confirmed
Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Changed in unity-lens-applications (Ubuntu):
status: Incomplete → Confirmed
Changed in unity-2d:
status: Incomplete → Confirmed
Changed in unity-lens-applications (Ubuntu):
importance: Medium → Undecided
tags: added: precise quantal raring
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Rodney Dawes (dobey) on 2013-11-25
Changed in software-center (Ubuntu):
status: Triaged → Incomplete

Although the proposed fix is based on a feature of software-center, it has to be developed in unity-lens-application. So this bug is invalid for software-center.

Rodney; since bug status changes shall be understood by anyone, not only the person making them and also the average user (https://wiki.ubuntu.com/One%20Hundred%20Papercuts/Average%20users), please briefly explain why you're doing so.

Changed in software-center (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers