[FFe] Recently installed applications should be easy to run

Bug #670403 reported by James Westby on 2010-11-03
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity-2d
Critical
Ugo Riboni
unity-lens-applications
Undecided
Unassigned
software-center (Ubuntu)
High
Gary Lasker
unity (Ubuntu)
Undecided
Unassigned

Bug Description

  1. open up the applications place
  2. search for "getting things"
  3. Select "Getting things GNOME" from the "available" list
  4. Click "install" in software-center
  5. Wait for software-center to install it
  6. software-center doesn't let me run it, but tells me where in the "Menu" I can find it. (Fixed separately as bug 639701.)
  7. Open up the applications place again and navigate to it.

I think that because running something you just installed will be so common
this should be made a little easier in the last couple of steps.

<https://wiki.ubuntu.com/SoftwareCenter#launching>

Related branches

Thank you, yes we agree on the principle!

My preferred interaction is that USC detect newly installed .desktop
files and (during installation) open a pane, displaying them as icons
together with an invitation to drag them to the launcher.

Mark

Thanks James and Mark. This problem was also highlighted by Charline in her UDS session on usability issues in Unity. Addressing this is a priority for Natty:

    https://blueprints.launchpad.net/ubuntu/+spec/appdevs-desktop-n-software-center-ui-enhancements

Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Matthew Paul Thomas (mpt)
description: updated
Changed in software-center (Ubuntu):
status: In Progress → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in unity:
status: New → Invalid
Changed in unity-place-applications:
status: New → Invalid
Changed in unity:
status: Invalid → Confirmed

MPT, I don't think it's appropriate to presumptively insert apps in the
Launcher. If we want to do this, we should popup a quicklist giving the
user the option to confirm that or decline, but I don't like that
because it would either have to be a sticky quicklist, which creates new
problems (how do you dismiss it?) or it would be fragile to an
accidental click elsewhere. We might solve those problems later, but for
now, I'd rather we opened a pane in USC where we present the launchers
that COULD be installed, inviting the user to do so manually.

Mark

In user testing of Ubuntu Software Center 2.0 and 3.0, consistently the biggest problem has been that people could not figure out how to launch newly-installed applications.

Having a separate pane in USC for draggable launchers was one of the options I evaluated (#6 in <https://wiki.ubuntu.com/SoftwareCenter/LaunchingApplications>). The biggest of its disadvantages turned out to be that it wouldn't actually solve the problem. (1) Realizing that the "recently installed" pane existed, (2) navigating to it, and (3) dragging the application to the launcher would be three non-obvious steps that, combined, would make people unlikely to benefit from it. And anything we could do to make the steps obvious enough would be more annoying (e.g. opening the pane automatically) and/or stodgy (e.g. displaying text telling people to drag and drop) than just hoisting the application to the launcher. That the hoisting solution adds zero extra elements to the interface doesn't by itself mean that it's the perfect solution, but it sure is a hint.

As I mentioned in the spec, we could have a “View” > “Newly Installed Applications in Launcher” menu item, on by default -- so that people who frequently install applications, and have become familiar with where else to find them, can "graduate" from the automatic behavior.

> Having a separate pane in USC for draggable launchers was one of the
> options I evaluated (#6 in
> <https://wiki.ubuntu.com/SoftwareCenter/LaunchingApplications>). The
> biggest of its disadvantages turned out to be that it wouldn't actually
> solve the problem.

Did you evaluate it with user testing, or just thought experiment?
Either is valid, I'd just like to know. Also, if it was through user
testing, I'd be interested in the experience that was presented in the test.

> (1) Realizing that the "recently installed" pane
> existed, (2) navigating to it, and (3) dragging the application to the
> launcher would be three non-obvious steps that, combined, would make
> people unlikely to benefit from it.

Ah, I think I explained what I was asking for poorly.

I would expect the pane to open *automatically* when software is being
installed, and to have it stay there until either (a) the user dismisses
it, or (b) USC is closed.

The example I have in mind is the pane which both Chrome and Firefox add
to the browser window after you enter a password. It doesn't need to be
discovered - the browser presents it when its appropriate. You can
consciously dismiss it.

For folks who miss the opportunity, we'll put these apps in the Dash
Apps lens home page.

> And anything we could do to make the
> steps obvious enough would be more annoying (e.g. opening the pane
> automatically) and/or stodgy (e.g. displaying text telling people to
> drag and drop) than just hoisting the application to the launcher. That
> the hoisting solution adds zero extra elements to the interface doesn't
> by itself mean that it's the perfect solution, but it sure is a hint.

It breaks the sense of personal control of the launcher that is really
important to the relationship we want users to have with it.

> As I mentioned in the spec, we could have a “View” > “Newly Installed
> Applications in Launcher” menu item, on by default -- so that people who
> frequently install applications, and have become familiar with where
> else to find them, can "graduate" from the automatic behavior.

I don't understand why that entry makes sense in the "View" menu? It
feels more like a preference - "[ ] Add newly installed applications to
the launcher automatically". And in any event, for clarity, I'm asking
that we not have any auto-install process in 11.04.

Mark

USC doesn't have enough engineers to implement multiple solutions before user-testing them, and this particular function is a bit too interactive for paper-prototyping. The design exercise was to find a solution that would be both elegant and likely to work, before implementing it and testing it. A slide-in pane will necessarily be both less elegant (since it involves an extra interface element) and at least a bit less likely to work (since it will disappear if you minimize or close USC), but it will preserve obviousness of what does and does not add an item to the launcher.

Gary told me yesterday that the solution I had settled on has now been used by Apple in their Mac App Store. USC's equivalent will take one more step for 11.04, but at least we'll have the mechanism in place for if you change your mind later.

Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.19

---------------
software-center (3.1.19) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/enums.py,
    softwarecenter/utils.py,
    softwarecenter/backend/channel.py,
    softwarecenter/models/viewswitcherlist.py,
    softwarecenter/view/pendingview.py:
    - another icon crash fix (LP: #719662)
  * softwarecenter/backend/aptd.py,
    softwarecenter/models/appstore.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py,
    softwarecenter/enums.py:
    - include additional details about the transaction when
      firing a transaction-started signal, wire to handlers
  * softwarecenter/view/widgets/actionbar.py:
    - tweak spacings for action bar
  * softwarecenter/db/application.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/channelpane.py,
    softwarecenter/view/installedpane.py,
    softwarecenter/view/softwarepane.py,
    softwarecenter/enums.py:
    - implement the software-center side of unity launcher
      integration per the specification (LP: #670403)
    - temporarily hide the launcher integration feature pending
      implementation on the Unity side
  * test/test_downloader.py:
    - update unit test for SimpleFileDownloader changes

  [ Aaron Peachey ]
  * utils/submit_review.py,
    softwarecenter/db/reviews.py,
    softwarecenter/view/appdetailsview_gtk.py:
    - provide user feedback when submitting review usefulness
    - handle case where usefulness submission fails
  * softwarecenter/view/appdetailsview_gtk.py:
    - display own reviews according to the spec
  * utils/submit_review.py:
    - fix bug that showed gwibber success message when gwibber
      checkbox was not selected

  [ Michael Vogt ]
  * softwarecenter/view/appdetailsview_gtk.py:
    - add transparent-bg-hint gdata theme engine hint to the
      progress bar
  * softwarecenter/db/reviews.py,
    softwarecenter/view/appdetailsview_gtk.py:
    - cleanup by unifing Review objects from rnrclient and
      the detailsview
  * softwarecenter/view/appdetailsview_gtk.py:
    - show "none yet", "loading" in the review details
  * softwarecenter/db/reviews.py, softwarecenter/view/appdetailsview_gtk.py:
    - log into the right logger with the right priority
  * softwarecenter/view/catview_gtk.py:
    - remove debug output
  * softwarecenter/db/reviews.py, test/test_reviews.py:
    - sort reviews by version/usefulness/date

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/lobby-tweaks:
    - better layout of the welcome lobby screen
  * lp:~mmcg069/software-center/catviewgtk-code-reorg:
    - move widgets out into softwarecenter/view/widgets

  [ Kiwinote ]
  * softwarecenter/view/widgets/buttons.py:
    - make CategoryButton accessible
  * softwarecenter/view/widgets/carousel.py:
    - minor accessibility tweaks
  * softwarecenter/view/widgets/mkit.py:
    - make Button emit 'clicked' on pressing enter key
 -- Michael Vogt <email address hidden> Fri, 18 Feb 2011 11:53:19 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
milestone: none → 3.8
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → Critical
Florian Boucault (fboucault) wrote :

Specification for integration of USC and Unity's launcher is at:
https://wiki.ubuntu.com/SoftwareCenter#Learning%20how%20to%20launch%20an%20application

tags: added: delta-with-3d
Didier Roche (didrocks) wrote :

So, after some discussion with the unity 2D team and Gary, we scoped down the spec for Natty.

Meaning that the dbus call is still the final one, but we don't introduce the "install" effect and flying icon for it. We need for oneiric putting a service common to unity2D and unity3D for that and avoid unexpected crashers, aptdeamon hang and such.

So, for natty, what we have is:
- software-center showing the "do you want to add that application to the unity launcher"
- one the installation is finished, the signal is emitted by USC
- the signal is received by unity which then add and pin the new launcher icon.

summary: - Recently installed applications should be easy to run
+ [FFe] Recently installed applications should be easy to run
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
milestone: none → 3.6.6
Martin Pitt (pitti) wrote :

Do we already have "software-center showing the "do you want to add that application to the unity launcher"? Or is that part of the FFE?

Adding a new D-BUS signal and pick that up in unity is fine FFE-wise.

I'm just not entirely sure how that'll help with education? we shouldn't encourage the user to put dozens of apps into the launcher, as this will make it a lot less convenient to use. The dash search is soo fast now :) Perhaps we should show newly installed applications in the dash during the current session?

Anyway, I don't want to disrupt already existing and discussed designs, so if that's the agreed plan, pleae go ahead.

Gary Lasker (gary-lasker) wrote :

Hi Martin,

We do already have the "Add to Launcher?" panel and the dbus signal pieces implemented in software-center. The only change needed in software-center for the reduced-scope approach is to delay when we send the signal until after the application install has completed.

I agree that adding too many apps to the launcher would not be good; hopefully the user would only choose to add apps that he/she expects to be using often. We should check with mpt about the dash idea.

Gary Lasker (gary-lasker) wrote :

Linked branch lp:~gary-lasker/software-center/launcher-integration-plan-b implements the revised plan in Software Center.

Didier Roche (didrocks) on 2011-03-16
Changed in unity:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Alin Andrei (nilarimogard) wrote :

Hmmm this says "Fix Released" but I didn't see the improvements in the latest updates.

Changed in software-center (Ubuntu):
status: Fix Released → Fix Committed
Gary Lasker (gary-lasker) wrote :

> Hmmm this says "Fix Released" but I didn't see the improvements in the latest updates.

Hi Alin, thanks for pointing this out. This feature is currently disabled in the released version of Software Center pending release of implementations on the Unity and Unity 2D sides. In addition, some rework of the Software Center implementation was necessary per the revised plan (see comment #9).

I expect that all of the pieces will be in place by very early next week and we will enable the feature in Software Center at that time.

Meanwhile, I changed the status of the software-center task back to Fix Committed to reflect this.

Thanks!

Alin Andrei (nilarimogard) wrote :

Thanks for the info, Gary!

Ugo Riboni (uriboni) on 2011-03-18
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.24

---------------
software-center (3.1.24) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/thumbnail.py:
    - add missing logger definition to fix name error on
      a thumbnail download error
  * softwarecenter/utils.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/softwarepane.py:
    - update Unity launcher integration implementation per
      revised approach (see LP: #670403)
  * test/test_unity_launcher_integration.py,
    test/data/<many>:
    - update unit tests per the revised approach

  [ Michael Vogt ]
  * merged lp:~mmcg069/software-center/rtl-work, many thanks
    to Matthew McGowan
  * merged lp:~mmcg069/software-center/desc-tweaks
  * merged lp:~weblive-dev/software-center/weblive-by-default, thanks
    to Stephane Graber (LP: #736227)
  * softwarecenter/view/widgets/thumbnail.py:
    - fix show/hide issue in download_and_display()
  * softwarecenter/db/reviews.py, softwarecenter/models/appstore.py:
    - deal with empty appname in the review-stats to follow the
      latest server changes
  * merged lp:~mmcg069/software-center/reviews-msg-tweaks, many thanks
    to to Matthew McGowan
  * show launcher like location for commandline only apps, thanks
    to Matthew McGowan
  * when scanning for commandline binaries take alterantives into
    account as well

  [ Kiwinote ]
  * data/new.menu.in,
    softwarecenter/view/appview.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/catview_gtk.py:
    - only display available items in what's new (LP: #739276)
    - don't display installed items in what's new (LP: #627114)
  * softwarecenter/db/database.py:
    - don't crash when we have no axi values (LP: #737870)
  * softwarecenter/gwibber_helper.py:
    - don't crash on startup due to anything sqlite related (LP: #737220)
  * softwarecenter/log.py:
    - don't crash on startup when logfile is not writeable (LP: #688682)
  * softwarecenter/view/appdetailsview_gtk.py:
    - correctly update statusbar after cancelling a dependency dialog
  * softwarecenter/view/catview_gtk:
    - don't crash when we have no what's new carousel (LP: #736046)
  * softwarecenter/view/softwarepane.py:
    - connect 'transaction-stopped' to on_transaction_stopped rather than o_t_f
  * softwarecenter/view/widgets/reviews.py:
    - fallback to package_name if review_data contains no app_name
 -- Michael Vogt <email address hidden> Tue, 22 Mar 2011 16:03:58 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Martin Pool (mbp) wrote :

I have software-center 3.1.26.7.

Is the fix for this the addition of the "do you want to add this to the Launcher?" If so there are two problems
* bug 765389, you may get only a couple of seconds in which to click the button
* people may think "well, I want to just try it before I semi-permanently add it to my Launcher" (at least I did), and then they're left at a dead end with no obvious way to start it

Gary Lasker (gary-lasker) wrote :

Hi Martin, I just wanted to mention that the first issue that you highlighted in comment #18 is fixed now (bug 765389). Thanks very much for your report as this was a needed improvement. As for the second issue, if you read through this bug you'll see that the implementation of this feature has morphed quite a bit over the course of the Natty cycle and it currently differs quite a bit from mpt's initial design at https://wiki.ubuntu.com/SoftwareCenter#launching . So, it's pretty clear that we will need to continue to refine this in Oneiric as we gather user feedback for what we have now and figure out how close we got (or didn't get) to solving the problem.

Thanks again!

Doug McMahon (mc3man) wrote :

Putting aside what happens in sc, I thought this bug was to somewhat address finding and opening a newly installed app that wasn't added to the launcher
(or has this been judged not practicable
bug #708976

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers