The look of price on 'Buy' button in the preview is inconsistent with other lenses

Bug #1061630 reported by Paweł Stołowski on 2012-10-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-lens-applications
Medium
Paweł Stołowski
6.0
Medium
Paweł Stołowski
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Test Case]
1. Spot some commercial non-free apps as some free open-source apps in the app lens earch results.
2. Right-click an app to activate its preview (repeat for commercial and free apps).
   -> Verify that:
      - Open-source free applications display 'Free' string in ribbons in the search results. Their previews should have 'Developer site' and 'Free Download' buttons.
      - Commercial apps should have the price displayed in ribbons (e.g. 'US$ 8.40'). Their previews should have 'Developer site' and 'Buy US$ ...' buttons.

[Regression Potential]
No price displayed.

Original description:

Application Lens doesn't use Action.extra_text to pass price to Unity, instead the price is just appended to the Buy button text in the preview. This gives it different look than e.g. music lens u1ms preview.

Related branches

summary: - The look of price on 'Buy' button in the preview is insonsistent with
+ The look of price on 'Buy' button in the preview is inconsistent with
other lenses
Changed in unity-lens-applications:
assignee: nobody → Pawel Stolowski (stolowski)
description: updated
description: updated
Changed in unity-lens-applications:
milestone: none → 7.0.0
status: Confirmed → Fix Committed
description: updated
description: updated

Hello Pawel, or anyone else affected,

Accepted unity-lens-applications into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-applications/6.10.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-lens-applications (Ubuntu Quantal):
status: New → Fix Committed
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Seems to work now as intended with the upgraded application lens from -proposed, in practice the price became bolded in the button similar to music lens.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.10.0-0ubuntu1

---------------
unity-lens-applications (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Dash - 'More suggestions' icons in App Lens are too large (LP: #1052513)
    - The look of price on 'Buy' button in the preview is inconsistent with
      other lenses (LP: #1061630)
    - Lots of IO during startup (LP: #1066816)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 16 Oct 2012 13:47:18 +0200

Changed in unity-lens-applications (Ubuntu):
status: New → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.10.0-0ubuntu1

---------------
unity-lens-applications (6.10.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Dash - 'More suggestions' icons in App Lens are too large (LP: #1052513)
    - The look of price on 'Buy' button in the preview is inconsistent with
      other lenses (LP: #1061630)
    - Lots of IO during startup (LP: #1066816)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 16 Oct 2012 13:47:18 +0200

Changed in unity-lens-applications (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers