[UIFE] Dash - All applications which are a dependency of Ubuntu Desktop should not have an uninstall button in their preview

Bug #1047315 reported by John Lea on 2012-09-07
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Ubuntu Software Center
Invalid
Undecided
Unassigned
Unity
Invalid
High
Unassigned
unity-lens-applications
High
Paweł Stołowski
software-center (Ubuntu)
Medium
Unassigned
unity-lens-applications (Ubuntu)
High
Unassigned

Bug Description

All applications which are a dependency of Ubuntu Desktop should not have an uninstall button in their Dash preview .

This is to stop users deleting critical parts of Ubuntu (like Nautilus) by mistake.

Related branches

John Lea (johnlea) on 2012-09-07
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in ayatana-design:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → backlog
tags: added: dashm udp
Changed in ayatana-design:
status: Triaged → Fix Committed
Michael Vogt (mvo) on 2012-09-10
tags: added: ca-escalated
Paweł Stołowski (stolowski) wrote :

unity-lens-applications needs to know if application can be safely uninstalled or not (i.e. is a dependency of ubuntu-desktop); this information should be provided by software-center-dbus.

Michael Vogt (mvo) wrote :

We agreed to name the property "is_desktop_dependency" in the dataprovider.

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
Changed in software-center:
status: New → Invalid
Michael Vogt (mvo) on 2012-09-17
Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Omer Akram (om26er) on 2012-09-17
no longer affects: unity (Ubuntu)
Changed in unity-lens-applications:
importance: Undecided → High
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → High
Changed in unity-lens-applications:
status: New → In Progress
Changed in unity-lens-applications (Ubuntu):
status: New → In Progress
Changed in unity-lens-applications:
assignee: nobody → Pawel Stolowski (stolowski)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.3.14

---------------
software-center (5.3.14) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/trivial-renaming,
    lp:~mvo/software-center/trivial-rename2:
    - drop the Gtk suffix from two more classes and rename
      catview_gtk.py to catview and split out lobbyview
  * lp:~mvo/software-center/pep8-again:
    - add the software-center top level to the pep8 check
      and fix its pep8 errors
  * lp:~mvo/software-center/make-currency-part-of-the-db:
    - move the currency field into the database itself
  * lp:~mvo/software-center/merge-prev-purchases-lp969273:
    - change the way reinstall previous purchases is done,
      fixes double entries in the db, and items already
      purchased will display properly and will no longer
      display a price (LP: #969273)
  * lp:~mvo/software-center/login-cleanup:
    - refactor and cleanup the login backend code, remove
      the unused interfaces for launchpad ppas
  * lp:~mvo/software-center/lp1034894-again:
    - fix the navigation buttons to be displayed as a
      single button style (LP: #1034894)
  * lp:~mvo/software-center/extra-unity-categories:
    - provide an ascii-only stable alias name for use
      by Unity for "Top Rated" and "What's New"
  * lp:~mvo/software-center/dataprovider-desktop-dependency-property:
    - add "is_desktop_dependency" property for the unity people
      (LP: #1047315)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/handle-trans-cancel-lp1027209:
    - don't add an application to the Unity launcher for the case
      where an installation is cancelled (LP: #1027209)
 -- Michael Vogt <email address hidden> Tue, 18 Sep 2012 10:37:32 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released

UIFE ok'ed by design

summary: - Dash - All applications which are a dependency of Ubuntu Desktop should
- not have an uninstall button in their preview
+ [UIFE}Dash - All applications which are a dependency of Ubuntu Desktop
+ should not have an uninstall button in their preview
summary: - [UIFE}Dash - All applications which are a dependency of Ubuntu Desktop
+ [UIFE] Dash - All applications which are a dependency of Ubuntu Desktop
should not have an uninstall button in their preview
John Lea (johnlea) on 2012-09-18
Changed in ayatana-design:
status: Fix Committed → Invalid
Changed in unity-lens-applications:
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Triaged → Invalid
Changed in unity-lens-applications (Ubuntu):
status: In Progress → Invalid
Changed in software-center (Ubuntu):
status: Fix Released → Invalid
Michael Vogt (mvo) on 2012-09-18
Changed in software-center (Ubuntu):
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 6.6.0-0ubuntu1

---------------
unity-lens-applications (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Home Lens requires binary names to be provided with results
      (LP: #1043775)
    - Dash - App Lens ratings are not working (LP: #1039789)
    - Dash - When an application is installed direct from a Dash Preview, the
      Software Centre should not be launched and the Software Centre window
      should not be opened (LP: #1045330)
    - [FFE][UIFE]Dash - Finesse the placement, movement and behaviour of the
      12.10 Dash (LP: #1049593)
    - Icons are missing in the previews for apps available for download
      (LP: #1050344)
    - Don't show 'Uninstall' button for critical apps (i.e. the ones that
      depend on ubuntu-desktop). (LP: #1047315)
    - List 10 'What's new' apps and the 12 'Top Rated' apps from Software
      Center in 'Apps Available for Download' before user performs any search
      if no filters are active. List 100 top rated apps according to active
      filters if search string is empty. (LP: #1045762)
    - Implemented price ribbons for Application Lens search results.
      (LP: #1049593)

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest libunity
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 16:17:10 +0200

Changed in unity-lens-applications (Ubuntu):
status: Invalid → Fix Released
Adolfo Jayme (fitojb) on 2013-03-03
no longer affects: unity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers