Need an option to select module version with "unity-js-scopes-tool install"

Bug #1552661 reported by Marcus Tomlinson on 2016-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-js-scopes
Undecided
Marcus Tomlinson

Bug Description

An option for "unity-js-scopes-tool install" to select the module version would be very useful. Occasionally a module can be in "beta" state or may contain breaking changes between major versions. In these cases, the developer may require an older, stable version to be installed.

Related branches

Oops, turns out we inadvertently do support this :P

Example of how to install the "sleep" module at version 1.0.2:

    unity-js-scopes-tool install ./node_modules/ sleep@1.0.2

Changed in unity-js-scopes:
status: New → Invalid
Changed in unity-js-scopes:
status: Invalid → In Progress
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in unity-js-scopes:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions