Top-Panel Menus Won't Drop Down for Dbeaver

Bug #1218687 reported by Lonnie Lee Best on 2013-08-30
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
Undecided
Unassigned
Eclipse
New
Undecided
Unassigned
Kepler
New
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
Unity GTK+ module
In Progress
Medium
Charles Kerr
linux (Ubuntu)
Medium
Unassigned

Bug Description

I initially installed Dbeaver in 13.04 and then upgraded to Ubuntu 13.10.

In 13.04, I was able to drop-down menus located in Unity's top-panel when Dbeaver had focus. However, now these menus won't drop down. I'm not sure that this is Dbeaver specific, or if this bug should be forwarded to the platform that Dbeaver runs on.

Video of the issue:
http://neartalk.com/ss/dbeaver.mp4

Also see:
http://dbeaver.jkiss.org/forum/viewtopic.php?f=2&t=1100&p=2388#p2388

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-4-generic 3.11.0-4.9
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lonnie 2077 F.... pulseaudio
 /dev/snd/controlC1: lonnie 2077 F.... pulseaudio
 /dev/snd/pcmC1D0p: lonnie 2077 F...m pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
Date: Thu Aug 29 20:06:25 2013
HibernationDevice: RESUME=UUID=22488e01-19fd-4a14-a063-f03cf6e74e20
InstallationDate: Installed on 2013-08-03 (26 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Dell Inc. Studio 1737
MarkForUpload: True
ProcFB:
 0 inteldrmfb
 1 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-4-generic root=UUID=09eefca9-6a0b-4c3b-93c6-e4aff4bf1dc7 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-4-generic N/A
 linux-backports-modules-3.11.0-4-generic N/A
 linux-firmware 1.113
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-08-28 (1 days ago)
dmi.bios.date: 04/14/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0P792H
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd04/14/2011:svnDellInc.:pnStudio1737:pvrA09:rvnDellInc.:rn0P792H:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Studio 1737
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.

Related branches

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Does the bug go away if you boot back into the 13.04 kernel?

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

I held down the shift key while booting, an selected to boot from the old 13.04 kernel:
3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The problem doesn't seem to be related to the new kernel in 13.10.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
john ferrier (john-j-ferrier) wrote :

I got similar problem yesterday after I upgarde from Ubuntu 13.04 X86_64 to 13.10 X86_64.

I was using Eclipse-CDT (Kepler) for some development and it works well on Ubuntu 13.04. However, after upgrade to Ubuntu 13.10 (beta 1) yesterday I found I could not have Eclipse menus (located in Unity's top-panel ) droped down. I also tried to download a new copy of Eclipse but it was the same.

It seems for me something wrong in 13.10.

I got Eclipse version 4.3 running on latest 13.10. If I run it as root, the menus display correctly.

Ubuntu 13.10 was released today. I'm still having this issue after installing Dbeaver 64bit package, located here:
http://dbeaver.jkiss.org/download/

Again, you can see the bug behavior here (as posted originally):
http://neartalk.com/ss/dbeaver.mp4

Stephen M. Webb (bregma) wrote :

I strongly suspect this is a duplicate of bug #1208019.

@Lonnie Lee Best please try the solution given there in comment 16 [1] to fix the Eclipse (Kepler) configuration and see if it foxes your problem, too.

[1] https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1208019/comments/16

Some people have gotten this to work by creating a desktop launcher with a particular configuration:
http://dbeaver.jkiss.org/forum/viewtopic.php?f=2&t=1100

It appears to be a permissions issue preventing these menus from displaying.

Here's a work around. If you launch dbeaver from the command line using sudo, the menus do work:

sudo /usr/share/dbeaver/dbeaver

Apparently, something changed in Ubuntu 13.10 to where now this exact same dbeaver deb installer installs in a manner in which dbeaver cannot access all of its prerequisites when launched as a regular non-sudo user.

Unfortunately, this work-around isn't perfect; any previous dbeaver settings, that were saved in your user account's home folder won't be accessed when launching dbeaver this way. You'll have to set all settings from scratch or some how copy your local user settings to the correct root location that gets queried during this sudo-launch of the application.

Skeewiff (marcelo-pm) wrote :

A workaround:

sudo gedit /usr/share/applications/dbeaver.desktop

Replace:
Exec=/usr/share/dbeaver/dbeaver

By:
Exec=env UBUNTU_MENUPROXY=0 /usr/share/dbeaver/dbeaver

That's the most concise work-around I've seen. It works for me.

Maybe we can get Dbeaver's developers to put some code in their installer that automates this step?

Wtwine (rcrd) wrote :

The above desktop file fix does not work for me in Uuntu 13.10. I also tried creating the desktop file in ./local/share/applications, but still no luck. Can only get DBeaver working with sudo /usr/share/dbeaver/dbeaver.

Very frustrating!

Charles Kerr (charlesk) on 2014-03-15
Changed in indicator-appmenu:
status: New → Invalid
Changed in unity:
status: New → Invalid
Changed in unity-gtk-module:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) wrote :

(bregma: you're correct, this is the same kind of issue, but dbeaver returns a different string via g_get_prgname() so it has to be handled separately in the blacklist.)

Josef Andersson (northar) wrote :

The mentioned fix in comment #12 worked for me.

Tim Banchi (tim-banchi) wrote :

Thank you Skeewiff,

your fix in comment #12 worked for me (Linux 3.11.0-19-generic i686 ubuntu 13.10) aswell - globalmenu is gone but menu is accessible again

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers