unable to log in - hangs on 'logging in' msg

Reported by Ansible on 2012-04-22
206
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Unity Greeter
High
Unassigned
unity-greeter (Ubuntu)
High
muhd izudin
Precise
High
Unassigned

Bug Description

On my laptop I upgraded from 11.10 to 12.04, 3 or 4 weeks ago.

Recently I had trouble logging in - I'd type in my password but it would hang on the 'logging in...' message you get after pressing enter. After rebooting a few times I was able to log in.

Now, rebooting isn't helping, I'm unable to log in at all. I stay at the 'logging in...' message until I shut down.

jbuthmann (jbuthmann) wrote :

Hi,

I think You're wrong here, but don't worry, I'll put this report to where it seems to fit better (the ubuntu lightdm project) ;)

Greets,

jbuthmann

affects: cassiopeia → lightdm
Ansible (bburdette) wrote :

Heh, wups! sorry for the misfiling.

I guess it could be flagged as resolved as of now - I was able to log in with xmonad and do an apt-get upgrade. Now I can log in with unity again.

J-Paul BERARD (arverne) wrote :

Hi !
Same problem here : I get LightDM screen. I type the password and a few seconds later, lightDM ask again for the password.
After this second time, the screen stay frozen with the "login in" message.

With ctrl+alt+F1, I can get a terminal, log and enter commands.
When I try startx, I get an answer : X already running. I removed .X0-lock file without effect.

If in Grub, I use a recovery mode, and choose failsafeX, it fails with an error "no screen found"
If, I use a previous Kernel : same problem

So unable to start at all !

J-Paul BERARD (arverne) wrote :

SOLVED !

I removed the .Xauthority file in my directory (sudo rm .Xauthority in a terminal) and I was able to start Ubuntu 12.04 normally.
BUT, next time, same problem. I had to remove again this file to start Ubuntu next time.

It seems to be solved by an update of the Kernel today.

Ansible (bburdette) wrote :

Shoot, well I spoke too soon. Now I can't log in with either unity or xmonad. I'll try J-Paul's solution next.

Ansible (bburdette) wrote :

I've been able to log in successfully a few times, but I'm not able to discern a pattern. Deleting .Xauthority and then rebooting to log into unity is not reliable. Occasionally some combination of deleting .Xauthority, /var/lib/.Xauthority, logging in with XMonad and logging in to unity will work. Once I was able to log into unity twice in a row, and then it stopped working again.

I'm going to throw a fresh install on there since I have my home folder on a separate partition anyway. Hopefully that will take care of the issue.

Sebastien Bacher (seb128) wrote :

That bug seems to mix several issues, I'm not sure the .Xauthority has to do with the bug and is not just a red herring or a different bug, I can confirm the "hang after validating the password on "logging in..." though, it happens after a log out trying to log in a second time here

Changed in lightdm:
importance: Undecided → High
Changed in lightdm (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Could people having the issue add their /var/log/lightdm/ logs to the bug?

The Bright Side (me-knowingme) wrote :

Hey guys, I had the issue a couple days ago and then fixed it by reinstalling. Before that, I took screenies of my lightdm logs though, and attached them to the thread here: ubuntuforums.org/showthread.php?t=1967945

ZIP attached here as well. Hope it helps.

Michael Terry (mterry) wrote :

Here are Jason Warner's logs. Looks like everything gets authenticated, and unity-greeter loses the ball (i.e. forget to exit) between authentication_complete_cb() and start_session().

Robert Ancell (robert-ancell) wrote :

The logs show that the greeter did authenticate but didn't start a session. So the daemon is saying "you're good to go" and the greeter hasn't actually responded with "start the session now".

Robert Ancell (robert-ancell) wrote :

The code is:

    private void authentication_complete_cb ()
    {
        bool is_authenticated;
        if (test_mode)
            is_authenticated = test_is_authenticated;
        else
            is_authenticated = greeter.is_authenticated;

        if (is_authenticated)
        {
            /* Login immediately if prompted */
            if (prompted)
            {
                user_list.login_complete ();
                if (!test_mode)
                {
                    if (user_list.background.alpha == 1.0)
                        start_session ();
                    else
                        user_list.background.notify["alpha"].connect (background_loaded_cb);
                }

I wonder if the background is not completely loaded at this point and there's a problem there?

Michael Terry (mterry) wrote :

Yeah, agreed. I have a build of unity-greeter with more debugging info about the background alpha to see what's wrong, now that I have a machine near me that can reproduce. I'll update as I find out more info!

Presumably the alpha is never hitting 1.0 exactly, and the greeter never gets back to lightdm.

Changed in lightdm (Ubuntu):
assignee: nobody → Michael Terry (mterry)

Hey,

I have this problem too.

I found out that when I have this problem, in auth.log stands this:

    lightdm: pam_unix(lightdm:session): session opened for user lightdm by (uid=0)
    lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
    lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "johannes"
    dbus[1054]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.50" (uid=104 pid=3135 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1527 comm="/usr/sbin/console-kit-daemon --no-daemon ")

When I can log in normally, auth.log says:

    lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "johannes"
    lightdm: pam_unix(lightdm:session): session closed for user lightdm
    lightdm: pam_unix(lightdm:session): session opened for user johannes by (uid=0)
    lightdm: pam_ck_connector(lightdm:session): nox11 mode, ignoring PAM_TTY :0
    polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.47 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)
    dbus[1060]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.63" (uid=1000 pid=2631 comm="/usr/lib/indicator-datetime/indicator-datetime-ser") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.15" (uid=0 pid=1534 comm="/usr/sbin/console-kit-daemon --no-daemon ")

Don't know if this helps.

Hi guys!

I hope this post could help...

I have two laptop: one which never has the bug yet and another which has it very often (but not always).

The laptop which never has the bug runs Ubuntu 12.04 installed from the i386 desktop beta 2 iso. (But I'm willing to install whatever Ubuntu 12.04 build you want on it)

The laptop which has the bug runs Ubuntu 12.04 installed from the i386 desktop release iso. (But I'm willing to install whatever Ubuntu 12.04 build you want on it)

I ran "sudo apt-get update -y" and "sudo apt-get upgrade -y" everyday on each laptop since their initial setups.

Ask me whatever you want about my laptops. I can post any log content, file content, command output or hardware specs you want. Just ask it, I will answer it as fast as possible...

Have a nice day!

Michael Terry (mterry) wrote :

Hello! I think I have a fix for this. See https://code.launchpad.net/~mterry/unity-greeter/986967/+merge/104622 for the techy explanation of why this happens.

But if you want to test the fix or just are interested in fixing it soon, please try this ppa: https://launchpad.net/~mterry/+archive/ppa2

Jimmy Merrild Krag (beruic) wrote :

Just out of curiosity: People who experience this, have you disabled the login sound?

Phil Davidov (davidovp69) wrote :

I also experienced this bug after upgrading to 12.04 from 10.04.

After chaning settings using Ubuntu Tweak, I could not login using LightDM at all. Switched back to GDM and was able to login & debug the issue.

Yes, I had DISALBED the login sound using Ubuntu Tweak. After re-enabling the login sound, I switched back to LightDM and was able to login perfectly. This appears to have something to do with the login sound and/or timing upon login.

AGAIN, re-enabling the login sound appears to correct this issue.

Changed in lightdm (Ubuntu):
status: Confirmed → In Progress
Changed in lightdm (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
Phil Davidov (davidovp69) wrote :

Michael, tried the updated unity-greeter patch from your PPA (#17 above), but upon disabling the 'login sound' I was again unable to login using LightDM/unity-greeter. Seems to be more than just the alpha issue.

-Phil

Ian Dickinson (i-j-dickinson) wrote :

Michael,
Your unity-greeter patch didn't solve the problem for me. I am not able to log in at all at the moment. In my case, as well as turning off the login sound with Ubuntu Tweak, I set the 'use the current desktop as background' option (boy do I regret that now!). Relevant section of my x-0-greeter.log is:

    [+0.80s] DEBUG: background.vala:116: Render of background /usr/share/backgrounds/Early_Blossom_by_Dh0r.jpg complete
    [+0.87s] DEBUG: background.vala:67: Making background /home/ian/Dropbox/computer-setup/backgrounds/P1040013.jpg at 1920x1200
    [+0.90s] DEBUG: background.vala:144: Error loading background: Failed to open file '/home/ian/Dropbox/computer-setup/backgrounds/P1040013.jpg': Permission denied
    [+0.91s] DEBUG: background.vala:116: Render of background /home/ian/Dropbox/computer-setup/backgrounds/P1040013.jpg complete
    [+0.91s] CRITICAL: background_loader_create_pattern: assertion `image != NULL' failed
    [+1.05s] DEBUG: Setting keyboard layout to 'gb'
    [+1.34s] DEBUG: indicator-sound: new_volume_slider_widget
    [+1.35s] DEBUG: indicator-sound: new_voip_slider_widget
    [+16.53s] DEBUG: Providing response to display manager
    [+16.53s] DEBUG: Wrote 30 bytes to daemon
    [+16.55s] DEBUG: Read 8 bytes from daemon
    [+16.55s] DEBUG: Read 15 bytes from daemon
    [+16.55s] DEBUG: Authentication complete for user ian with return code 0
    [+16.55s] DEBUG: unity-greeter.vala:438: MIKE: login complete
    [+16.55s] DEBUG: unity-greeter.vala:441: MIKE: not test mode; alpha is 0.001312
    [+16.55s] DEBUG: unity-greeter.vala:447: MIKE: waiting on alpha

If I knew which config file the background was specified in, I'd try resetting it to the default. Any suggestions?

Thanks,
Ian

Sebastien Bacher (seb128) wrote :

there might be several issues there...

Sebastien Bacher (seb128) wrote :

@Phil, @Ian: what version did you install? test1 has only debug statement and no fixes, test2 is the fixed version but it didn't build yet on amd64

Phil Davidov (davidovp69) wrote :

Sebastien, I only tried test1. I'll try test2 as soon as its built for amd64 and report back.

Ian Dickinson (i-j-dickinson) wrote :

I'll also need to wait for the amd64 version.

Hi guys!

Thanks Michael. Today, before installing your patch, my laptop has the bug a lot of time... But, now that I installed your patch, I achieved 20 login / logout in a row without any problem. Then, I achieved 10 shutdown / startup / login in a row without any problem. Before installing your patch this would be strictly impossible. So, I personnally consider this bug as solved.

GOOD JOB MICHAEL !!!

Sorry,

I forgot to specify: my laptop is an Intel Core i3 M 330, so I really tested the patch.

Phil Davidov (davidovp69) wrote :

Sebastien/Michael,

I went ahead and built Michael's test2 for amd64 from source and I can confirm that it DOES FIX the login hang issue with 'login sound' disabled. I also tested with different combinations of custom login background images & login sound on/off and everything appears to be working.

-Phil

Michael Terry (mterry) wrote :

This bug was fixed in the package unity-greeter - 0.2.8-0ubuntu2

---------------
unity-greeter (0.2.8-0ubuntu2) quantal; urgency=low

  * debian/patches/recognize-kde-plasma.patch:
    - Recognize the "kde-plasma" session as "kde" so it gets a properly
      branded icon in the greeter. LP: #986339
  * debian/patches/show-changed-default-badge.patch:
    - When the default session is changed in lightdm.conf, don't still
      show the Ubuntu badge. LP: #978428
  * debian/patches/fix-hung-logging-in.patch:
    - Sometimes users will get stuck on a "Logging in..." screen. This
      fixes that by ensuring that we don't wait for a background to fade
      in that never will. LP: #986967
 -- Michael Terry <email address hidden> Fri, 20 Apr 2012 14:51:06 -0400

affects: lightdm → unity-greeter
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
status: In Progress → Fix Released
Michael Terry (mterry) wrote :

There are enough positive feedbacks here that I pushed to quantal and precise-proposed.

Ian Dickinson (i-j-dickinson) wrote :

Michael - just to confirm after yesterday, your fix has resolved the problem for me as well. Many thanks!

Hello Ansible, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Ansible (bburdette) wrote :

Thanks Martin! I'm afraid I jumped ship back on 04-29 with a fresh install, which has been working perfectly.

Phil Davidov (davidovp69) wrote :

Tested from precise-proposed. Everything working great.

Michael Terry (mterry) on 2012-05-08
tags: added: verification-done
removed: verification-needed
David Haddon (dave373) wrote :

I have been having this problem since installing beta1. Seemed kind of random.. if it hung, do a reboot or restart lightdm and try again.. Over the last week, it seeded that I needed to restart/reboot more often...

I have just added the precise-proposed to apt/sources.list and the login worked first go.. (yay!!)

I'll report any issues....

Nils (loewen-nils) wrote :

After trying several proposed fixes last night, I was only able to login using ctr+alt+F1, logging in via console and then "sudo gdm" to get to a working login screen.
Even after applying all the most recent patches this AM (EST) and permitting and installing NVDIA-current PPA I still have the same problem.

I, too, disabled the annoying drum for when the login screen shows up several days ago (don't recall how I did that though).

Greeter.log attached

Thanks!

Nils (loewen-nils) wrote :

computer: Lenovo X201 (2010), 12.04 64 bit

Jerry Kaczynski (jaroslaw-k) wrote :

In my case the source of the problem was quite strange.
I have installed a piece of software that recommended sourcing its configuration script in /etc/profile. Unfortunately I have typed the path incorrectly without noticing it.
Next attempt to login after this modification hung on 'Logging in...' message, as described in earlier posts.
After logging in via console I have noticed bash complaining about incorrect path, so I have corrected typing mistake in /etc/profile.
Next login was OK.
So it looks like in my case it was timing issue due to error in profile.

Nils (loewen-nils) wrote :

Sorry, Michael, this is fantastic. You're PPA #2 fix did solve my problem.

sacha@ubuntu (sacha-b77) wrote :

Hello!

When shall we use this fix via update in "main repos" in Precise?

Thank's!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.8-0ubuntu1.1

---------------
unity-greeter (0.2.8-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/recognize-kde-plasma.patch:
    - Recognize the "kde-plasma" session as "kde" so it gets a properly
      branded icon in the greeter. LP: #986339
  * debian/patches/show-changed-default-badge.patch:
    - When the default session is changed in lightdm.conf, don't still
      show the Ubuntu badge. LP: #978428
  * debian/patches/fix-hung-logging-in.patch:
    - Sometimes users will get stuck on a "Logging in..." screen. This
      fixes that by ensuring that we don't wait for a background to fade
      in that never will. LP: #986967
 -- Michael Terry <email address hidden> Fri, 20 Apr 2012 14:51:06 -0400

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
Kane York (kanepyork) on 2012-05-16
Changed in unity-greeter:
status: New → Fix Released
Changed in unity-greeter (Ubuntu):
assignee: Michael Terry (mterry) → muhd izudin (muhdizudin96)
Hồng Quân (ng-hong-quan) wrote :

I'm using unity-greeter_12.10.4-0ubuntu5. I'm stuck at "Logging in...".
/var/log/lightdm/x-0.log shows no error/warning.

Hồng Quân (ng-hong-quan) wrote :

For my case, the "log in" screen freezes for a while after password, then log in successfully.
The delay exist when I have some programs set in "Startup Applications".

Hello! I have tested edubuntu amd64 (3508440d9b40fcf3159d5e50505cc63d *raring-dvd-amd64.iso), to installing on Virtualbox.

I confirmed this bug! On x-0.log displayed this error "Errors from xkbcomp are not fatal to the X server" (view file attached)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/986967

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions