Screen brightness does not persist over reboots

Reported by Ivan Katanović on 2012-04-05
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Undecided
Unassigned
ubuntu-nexus7
Medium
Unassigned
gnome-settings-daemon (Ubuntu)
Medium
Unassigned
ubuntu-defaults-nexus7 (Ubuntu)
Undecided
Unassigned

Bug Description

The brightness of laptop panel is set to minimum instead to maximum when system starts. In Natty and older Ubuntu versions it was set to minimum during boot, and wold go to maximum just before login screen. In Onerick and Precise it just stays at minimum until changed manually to higher values. Laptop is connected to power.
 I have Nvidia G105M GPU. On laptop with Intel graphics and Onerick I can't reproduce this.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-22-generic 3.2.0-22.35
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mile 1998 F.... pulseaudio
CheckboxSubmission: 9448ae01985a062cb9f7d6705930e25a
CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
Date: Thu Apr 5 15:31:51 2012
HibernationDevice: RESUME=UUID=4dfa8c64-5b19-422d-be25-6053b9b44eab
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20111004)
MachineType: Acer Extensa 5635G
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=67f9c537-e53e-444a-98d0-12afd884e79e ro quiet splash pcie_aspm=force vt.handoff=7
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-01-07 (88 days ago)
dmi.bios.date: 12/21/2009
dmi.bios.vendor: Phoenix
dmi.bios.version: V1.3311
dmi.board.name: BA50-MV
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrV1.3311:bd12/21/2009:svnAcer:pnExtensa5635G:pvrNotApplicable:rvnAcer:rnBA50-MV:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Extensa 5635G
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer
---
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
DistroRelease: Ubuntu 12.10
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
NonfreeKernelModules: nvidia
Package: gnome-settings-daemon 3.4.2-0ubuntu14
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Tags: quantal running-unity
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: Upgraded to quantal on 2012-08-28 (40 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed

I've just installed Kubuntu Precise and can't reproduce this bug (brightness sets to maximum while Kde is loading).
Maybe it's lightdm since it's introducet in Onerick?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc1-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I've tested with 3.4rc1 and the bug isn't fixed (although nvidia proprietary driver did't work). But as I said, with Kubuntu Precise I don't have this bug so maybe this isn't kernel bug?

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Seth Forshee (sforshee) wrote :

This probably isn't a kernel issue. Backlight drivers generally only change the brightness when told to do so by userspace, although sometimes system firmware plays a role as well.

But based on the described behavior, I suspect that it was userspace setting the brightness value when the login screen appeared. gnome-settings-daemon is what will actually be applying the brightness settings, so I'm going to reassign the Linux task to that.

affects: linux (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Confirmed
affects: lightdm → unity-greeter

still happens in quantal

apport information

tags: added: apport-collected quantal running-unity
description: updated

apport information

tags: added: mobile nexus7

So this bug is more about the brightness level not being saved upon a reboot, therefore marking as confirmed for nexus7 as I have reproduced this.

Changed in ubuntu-nexus7:
status: New → Confirmed
Chris Wayne (cwayne18) on 2012-11-09
summary: - Brightnes of laptop panel is set to minimum when system starts
+ Brightness of laptop panel is set to minimum when system starts
Chris Wayne (cwayne18) on 2012-11-13
summary: - Brightness of laptop panel is set to minimum when system starts
+ Screen brightness does not persist over reboots
Changed in ubuntu-nexus7:
importance: Undecided → Medium
Matt Fischer (mfisch) wrote :

There's a Gnome bug about this filed against gnome-applets in 2009 with no activity:

https://bugzilla.gnome.org/show_bug.cgi?id=577978

Sean Feole (sfeole) wrote :

Still an issue in 13.04 , raring.

Alex Chiang (achiang) on 2013-01-28
tags: added: sensors
Srdjan Grubor (srdjan-grubor) wrote :

On ubuntu-nexus7, I don't think this bug applies as the user reports are caused by /usr/bin/luxd dynamically setting the brightness based on the light sensor input. I'm adding more info to Nexus 7 bug report (https://bugs.launchpad.net/ubuntu-nexus7/+bug/1075473)

Oliver Grawert (ogra) wrote :

this bug pre-dates the inclusion of luxd, luxd is just an interim solution while the function is added to gnome-settings-daemon properly (with a checkbox to allow manual vs auto-setting of the backlight)

fixes to luxd are indeed welcome in the interim ...

tags: added: raring

I have a laptop Asus K45A. Just installed Ubuntu 13.04 daily 2013-02-16. And after every reboot, the screen brightness is set to maximum instead of keep the way I'd configured it before the reboot. Really annoying.

Oliver Grawert (ogra) wrote :

a new ubuntu-defaults-nexus7 with luxd removed was uploaded ... please check if the issue still persists on the recent nexus7 images

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Invalid
Changed in unity-greeter:
status: New → Invalid
Changed in ubuntu-defaults-nexus7 (Ubuntu):
status: New → Incomplete
Changed in ubuntu-nexus7:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-defaults-nexus7 - 0.54

---------------
ubuntu-defaults-nexus7 (0.54) raring; urgency=low

  * drop luxd (LP: #974260 ), (LP: #1077096) (LP: #1126836)
 -- Oliver Grawert <email address hidden> Thu, 14 Mar 2013 10:12:10 +0100

Changed in ubuntu-defaults-nexus7 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.