Onscreen Keyboard cannot be used to input password in unity-greeter

Bug #878184 reported by Francesco Fumanti on 2011-10-19
176
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Medium
Unassigned
unity-greeter (Ubuntu)
High
Robert Ancell
Precise
High
Robert Ancell

Bug Description

LP: #851565 was fixed for onboard 0.95. However, there is now a new version of Onboard in oneiric proposed, where the fix does not work anymore.

I was told that the problem might be that the new release has harmonized the capitalisation of Onboard and now uses Onboard instead of onboard for the window title.

Related branches

affects: ubuntu → unity-greeter (Ubuntu)
Robert Ancell (robert-ancell) wrote :

Could you check if this works in unity-greeter 0.2.0 (in Ubuntu 12.04)? Thanks.

Changed in unity-greeter:
status: New → Incomplete
Changed in unity-greeter (Ubuntu):
status: New → Incomplete
Changed in unity-greeter:
importance: Undecided → Medium
Changed in unity-greeter (Ubuntu):
importance: Undecided → Medium
Francesco Fumanti (frafu) wrote :

This was not anymore an issue for me for some time (I even forgot about it in the meantime). But after the update of unity-greeter to 0.2.0 today, the issue is back.

I now reenabled auto-login to work around the issue. I am running the precise development version.

Francesco Fumanti (frafu) wrote :

Version 0.2.0-0ubuntu4 in precise still has the problem.

cdwolf (charlespoetwolf) wrote :

I got marked duplicate, didn't realize it was already here. But yeah, effects me on 12.04 alpha. (Testing on extra tablet)

marmuta (marmuta) wrote :

Same here, unity-greeter 0.2.0-0ubuntu4, Ubuntu 12.04.
When onboard is shown, neither typing with the osk nor with a hardware keyboard has any effect.

Kwonjin Jeong (gram25gwh) wrote :

Version 0.2.1-0ubuntu1 in precise also has the problem.

summary: - Onscreen Keyboard cannot be used to input password
+ Onscreen Keyboard cannot be used to input password in unity-greeter
tags: added: a11y
Jan Simon (jan-simon) wrote :

Still an issue in precise and 0.2.4

Changed in unity-greeter:
status: Incomplete → Confirmed
Changed in unity-greeter (Ubuntu):
status: Incomplete → Confirmed

This problem persists even with the newer version (0.2.4-0ubuntu1) of unity-greeter. My "precise" machine was updated until Feb, 24th 11UT.

I noted that it worked for me during the alpha1 stage but stopped working after some point at alpha2. And for now, after using the virtual keyboard, the cursor inside the field that we type the password just disappears (it stops blinking, no visual "ready/wait signal" for input).

If we do not use onboard inside lightdm, the field works as it should.

David López (david-lopez-upct) wrote :

The cursor dissapears for me too. Moreover, I also noticed that if 'Onscreen keyboard' is selected in lightdm then the 'physical' keyboard doesn't seem to work, I press keys in my usb keyboard but nothing seems to happen.

This bug makes ubuntu precise unusable without a physical keyboard (unless autologin in on). In my opinion it is not a medium importance bug, it's critical or high.

tags: added: rls-mgr-p-tracking
Kevin Soviero (ksoviero) wrote :

This bug still exists as of Beta 1... Please fix this before final release. Please.

Changed in unity-greeter (Ubuntu):
importance: Medium → High
tags: added: rls-p-tracking
imayoda (rateava) wrote :

i'm on armel tablet (12.04) and onboard comparition on assistive tecnology request in lightdm, just makes dissapear the prompt in the password field.. once onboard is put down, prompt re-becomes available in the field.

Jean-Guy Nolet (lusu-tanis) wrote :

Got the same problem on my i7 rig running Precise Beta 1 fully updated as of March 19 2012. It was a nice feature when doing reboot for a rig that does not have or need a keyboard. The workaround is to enable auto login but a bit of googling show that this bug been poping out on more than a few releases. :(

Martin Pitt (pitti) wrote :

Assigning to Robert, he said on the merge proposal to merge this next week.

Changed in unity-greeter (Ubuntu):
status: Confirmed → In Progress
Changed in unity-greeter:
status: Confirmed → In Progress
Changed in unity-greeter (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in unity-greeter:
status: In Progress → Fix Committed
Mark Bokil (mark-bokil) wrote :

Just installed beta 2. Bug is confirmed. I had to plug in a keyboard to login. On-screen failed.

Michael Terry (mterry) on 2012-04-03
Changed in unity-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.7-0ubuntu1

---------------
unity-greeter (0.2.7-0ubuntu1) precise; urgency=low

  * New upstream bug-fix release
    - "Pressing escape key on lightdm greeter restarts xserver"
      (LP: #962932)
    - "unity-greeter crashed with SIGSEGV in background_loader_ready_cb"
      (LP: #946674)
    - "Onscreen Keyboard cannot be used to input password in
      unity-greeter" (LP: #878184)
 -- Michael Terry <email address hidden> Tue, 03 Apr 2012 15:50:50 -0400

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Released

The version 0.2.7-0ubuntu1 worked like a charm. :). Thank you.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/878184

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers