Returning to greeter and authenticating again does not return to the existing session

Reported by Andy Rogers on 2011-08-27
190
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Light Display Manager
High
Unassigned
Unity Greeter
Undecided
Unassigned

Bug Description

Either when choose a user from the indiciator-session menu or choosing "Switch from xxxxx...", when you return to the lightdm unity greeter menu, when you type in the user password of the user you want to login aswell, lightdm will not log into the selected 2nd user whilst still logged in on your original login.

Also when you press enter, the password box disappears but nothing else happens.

If you try log back in as your original self, you can't as the password box has gone from the chosen user in lightdm.

Eventually you can get back to your original login as lightdm seems to have crashed out.

Hernando Torque (htorque) wrote :

I confirm this with both the Unity greeter and the LightDM GTK greeter.

Changed in lightdm:
status: New → Confirmed
summary: - Does not allow multiple logins
+ Unity-Greeter / LightDM Does not allow multiple logins

Closing the greeter component of this bug, as it's reported to affect multiple greeters.

Changed in unity-greeter:
status: New → Invalid
Robert Ancell (robert-ancell) wrote :

Could you please attach the logs from /var/cache/lightdm after this problem occurs? Thanks.

Changed in lightdm:
importance: Undecided → High
status: Confirmed → Incomplete

Am 31.08.2011 09:39, schrieb Robert Ancell:
> Could you please attach the logs from /var/cache/lightdm after this
> problem occurs? Thanks.
>
> ** Changed in: lightdm
> Importance: Undecided => High
>
> ** Changed in: lightdm
> Status: Confirmed => Incomplete
>
sorry, but as mentioned earlier lightdm was unusable on Natty. Therefore
I've replaced it with lxdm.
KR Frank

Andy Rogers (andy-rogers) wrote :

Frank/Robert

I have looked in my /var/cache/lightdm folder and do not have any log type files, all is presemt is a dmrc folder which only contains .dmrc files for the people who have logged in with lightdm.

I dont have anything that looks like the files which Hernando has attached to post 5 https://bugs.launchpad.net/lightdm/+bug/835310/comments/5

Can you give me some pointers on this please, do I need to enable a debug mode somehow?

Thanks

Andy

Hernando Torque (htorque) wrote :

Everyone, the logs to attach are in /var/log/lightdm.

Andy Rogers (andy-rogers) wrote :

Log files attached as requested

Changed in lightdm:
status: Incomplete → New
summary: - Unity-Greeter / LightDM Does not allow multiple logins
+ Returning to greeter and authenticating again does not return to the
+ existing session
Changed in lightdm:
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

Andy, your logs showed you logged in as "administrator", returned to the greeter but failed to authenticate correctly as "administrator" then you tried the test account. What happened after entering the password for administrator?

There was as fix recently in bug 783598 where PAM could display some information without a prompt and lightdm wouldn't handle this. Is there anything special about the administrator account / does it do anything more complex than username/password in another display manager (e.g. GDM)?

This may also be related to bug 851612 where lightdm requests to switch back to the previous session but it doesn't work for some reason.

Robert Ancell (robert-ancell) wrote :

Screenshot in duplicate bug 841351

foxy123 (foxy) wrote :

I've got exactly same problem.

Andy Rogers (andy-rogers) wrote :

Robert

Further to your reply on the 22nd Sept, my administrator is just a normal type of account which can sudo etc.
This works fine with GDM, and does not have any extra processing which iam aware of.

I have replicated this issue again today, with first logging in as administrator, then trying to log in as another "test" user and got the same results.

My log files are attached, you will see that I tried to log in with test. I entered my password and then it did noting and the password box disappears again like originally posted in this bug.

Andy Rogers (andy-rogers) wrote :

I have also re-tested this again with different non sudo account's and the same behavior still happens as reported.

With this being such a high bug, iam surprised to see not much activity happening in regards to fixing this especially since lightdm will be a major focal point by replacing GDM in 11.10, and I can see many more people once Oneiric has been released coming across this issue.

raguanu (ragu+ananth) wrote :

Because of this problem I could not use switch user at all.
Is there a good work around?

Ted (ainisb) wrote :

I'm in the same boat here. This is a major bug but it probably affects not everyone, at least I couldn't find many people complaining on ubuntuforums. This could be an issue only for upgraded systems plus some specific (strange) configuration.

Can someone confirm if they did a fresh install of Oneiric and still experience this problem?

foxy123 (foxy) wrote :

I installed Oneiric on my daughter's Asus 1015PX yesterday and multiple login works fine there. I'm going to reinstall Ubuntu on my laptop to see if it's a upgrade issue.

Ted (ainisb) wrote :

Found a temporary fix- the problem goes away if you switch back to gdm login manager.

sudo dpkg-reconfigure lightdm

foxy123 (foxy) wrote :

OK, I popped in oneiric CD, chose the option upgrade from 11.10 to 11.10 and went through the installation process. Now switching between accounts works. Some other bugs also got fixed. So I guess the upgrade did not go well but upgrading from a CD fixes it.

gianluca (amato) wrote :

I think the problem is with PAM, in particular with the package libpam-smbpass. I tried with a clean installation of 11.10, and fast user switching was working ok, but after installing libpam-smbpass it stopped working, exhibiting the same behaviors described above. I may add that lightdm is crashing with the following messages in dmesg:

[ 147.709200] lightdm[1920]: segfault at 0 ip (null) sp 00007f4d965e9c78 error 14 in lightdm[400000+27000]
[ 147.709889] init: lightdm main process (922) killed by SEGV signal

Removing libpam-smbpass restored the correct behavior. Note that switching to the guest account (which does not require authentication) always works, both with and without libpam-smbpass.

Ted (ainisb) wrote :

I configm that removing libpam-smbpass fixes the problem.

I confirm it too. Removing libpam-smbpass fixes the problem.

2011/10/18 Ted <email address hidden>:
> I configm that removing  libpam-smbpass fixes the problem.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (841351).
> https://bugs.launchpad.net/bugs/835310
>
> Title:
>  Returning to greeter and authenticating again does not return to the
>  existing session
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lightdm/+bug/835310/+subscriptions
>

bobemoe (launchpag-jhodges) wrote :

Confirmed too. Although I did need a reboot after removing libpam-smbpass.

ClaudeD (claude-d) wrote :

Removing libpam-smbpass partially resolve the problem : I can switch to another user but when I logout the other user and reenter my password to go back to my original session, my screen freeze.

Ted (ainisb) wrote :

Cannot confirm behavior experienced by ClaudeD. That must be a different bug.
For me after removing libpam-smbpass everything works fine, can log in to multiple users and switch between them without any problems.

Jason Gaston (roguegaston) wrote :

I am seeing the same problem as ClaudeD. I went to remove libpam-smbpass and found that it is not installed on my system. Yet, when switching back to my original session, my screen freezes and I have to 'hard' shutdown my system.

foxy123 (foxy) wrote :

so what are repercussions of removing libpam-smbpass?

ClaudeD (claude-d) wrote :

Removing libpam-smbpass enabled me to switch to another user (before that I couldn't). But unfortunatly, I can't switch back.

raguanu (ragu+ananth) wrote :

Removing libpam-smbpass allowed me to switch user. I didn't need a reboot.
echoing foxy123's question. What do I miss due to the absence of libpam-smbpass?

ClaudeD (claude-d) wrote :

As I understand it, libpam-smbpass is used to sync linux passwords with samba passwords. If you never change your password or don't create new users then I don't think this has negative effects. Otherwise you'll have to sync manually with smbpasswd.

gianluca (amato) wrote :

Just to complete ClaudeD explanation, Samba is a software which allows you to share network volumes with other computers (both Linux and Windows). For technical reasons, samba should keep a separate copy of the user passwords. As ClaudeD said, libpam-smbpass keeps the two copies in sync.

I did can login only installing the GDM, then now I can work, but not with ligthdm

x-0-greeter Log

x-0.log

x-1.log

gianluca (amato) wrote :

I think it has been fixed in Quantal (or before). It could be a good idea to close the bug.

I can confirm it's fixed for quantal in my machine.

gianluca (amato) wrote :

Marked as fixed since I got a positive reply to me inquiry.

Changed in unity-greeter:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers