indicator-sound-service crashed with SIGSEGV

Bug #864732 reported by Daidais on 2011-10-02
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Low
Conor Curran
Unity Foundations
Low
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Ken VanDine

Bug Description

After dist-upgrade and Reboot in Ubuntu 2D

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-sound 0.7.8-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CheckboxSubmission: 0b7ad6de0cb7ddb9a678588e9f177ae8
CheckboxSystem: b62ae224500b03a9fc2c9b6caf3feb14
Date: Sun Oct 2 16:54:05 2011
Disassembly: => 0x1901c3: Cannot access memory at address 0x1901c3
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
SegvAnalysis:
 Segfault happened at: 0x1901c3: Cannot access memory at address 0x1901c3
 PC (0x001901c3) ok
 SP (0xbfb12a00) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: indicator-sound
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: indicator-sound-service crashed with SIGSEGV
UpgradeStatus: Upgraded to oneiric on 2011-10-02 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1651): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed
 (nautilus:1651): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Daidais (denis-favreau) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 _vala_array_length (array=0x0) at music-player-bridge.c:893
 music_player_bridge_determine_key (desktop_or_interface=0x8051189 "\307D$\004") at music-player-bridge.c:793
 music_player_bridge_client_has_become_available (self=0x1, desktop=0xbfb12bc4 "\225:\261\277", dbus_name=0xbfb12bcc "\306:\261\277\326:\261\277\064;\261\277\205;\261\277\220;\261\277\312;\261\277\345;\261\277\003<\261\277g<\261\277\215<\261\277\332<\261\277\347<\261\277\023=\261\277,=\261\277==\261\277]=\261\277\263=\261\277\322=\261\277\344=\261\277F>\261\277Z>\261\277\223>\261\277\240>\261\277\335>\261\277\373>\261\277\023?\261\277%?\261\277\071?\261\277J?\261\277t?\261\277\250?\261\277\273?\261\277", use_playlists=12509172) at music-player-bridge.c:449

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
status: New → In Progress
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Changed in indicator-sound:
milestone: none → 0.7.10
importance: Undecided → Low
Conor Curran (cjcurran) on 2011-10-26
Changed in unity-foundations:
milestone: none → oneiric-backlog
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-sound:
status: In Progress → Fix Committed
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.7.9.1-0ubuntu1

---------------
indicator-sound (0.7.9.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-sound-service crashed with SIGABRT in raise() (LP: #840986)
    - don't let the menu grow wide enough to push off the screen (LP: #873006)
    - bump the limit for number of playlists to 20 (LP: #835384)
    - indicator-sound-service crashed with SIGSEGV (LP: #864732)
    - Music player icon is not top-aligned (LP: #874454)
  * debian/control
    - build with valac-0.14
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 09:45:22 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-sound (Ubuntu Oneiric):
importance: Undecided → Medium
status: New → Confirmed
milestone: none → oneiric-updates
assignee: nobody → Ken VanDine (ken-vandine)

Hello Daidais, or anyone else affected,

Accepted indicator-sound into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

I cannot reproduce the crash but I've been testing the package for a few days already and did not noticed any regression with it, marking this as verification-done so it can go into updates, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.7.9-0ubuntu2

---------------
indicator-sound (0.7.9-0ubuntu2) oneiric-proposed; urgency=low

  * src/pulseaudio-mgr.c
    - indicator-sound-service crashed with SIGABRT in raise() (LP: #840986)
  * src/music-player-bridge.{vala,c}
    - indicator-sound-service crashed with SIGSEGV (LP: #864732)
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 10:12:36 -0400

Changed in indicator-sound (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers