indicator-sound-service crashed with SIGABRT in raise()

Bug #840986 reported by Barneedhar on 2011-09-04
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran
Unity Foundations
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Ken VanDine

Bug Description

I plugged in my headphone and tried to unmute the sound. And then the indicator-sound crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-sound 0.7.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Sun Sep 4 20:53:23 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 pa_operation_unref () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
 ?? ()
 ?? ()
Title: indicator-sound-service crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Barneedhar (barneedhar) wrote :
visibility: private → public

StacktraceTop:
 pa_operation_unref (o=0x0) at pulse/operation.c:68
 pm_update_mic_gain (source_index=<optimized out>, new_gain=...) at /build/buildd/indicator-sound-0.7.6.1/./src/pulseaudio-mgr.c:195
 handle_event (mi=<optimized out>, name=<optimized out>, value=<optimized out>, timestamp=<optimized out>) at /build/buildd/indicator-sound-0.7.6.1/./src/voip-input-menu-item.c:128
 dbusmenu_menuitem_handle_event (mi=0x2084010, name=0x7fcd68001460 "update", variant=0x7fcd68003c40, timestamp=0) at /build/buildd/libdbusmenu-0.4.93/./libdbusmenu-glib/menuitem.c:1707
 event_local_handler (user_data=0x7fcd68005270) at /build/buildd/libdbusmenu-0.4.93/./libdbusmenu-glib/server.c:1528

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Barneedhar (barneedhar) on 2011-09-23
Changed in indicator-sound (Ubuntu):
status: Confirmed → New
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2011-10-20
Changed in indicator-sound:
status: New → Confirmed
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Conor Curran (cjcurran) wrote :

This seems like this could have been caused by a period of Oneric's dev cycle that I seem to remember when Ubuntu's pulse was a little unstable. That would cause the pulse_context to disppear but still the i-sound-service should be able to cope with that ... hrmm,.

Are people still experiencing this ?

Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
status: Confirmed → In Progress
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
milestone: none → 0.7.10
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2011-10-26
Changed in unity-foundations:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
milestone: none → oneiric-backlog
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.7.9.1-0ubuntu1

---------------
indicator-sound (0.7.9.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - indicator-sound-service crashed with SIGABRT in raise() (LP: #840986)
    - don't let the menu grow wide enough to push off the screen (LP: #873006)
    - bump the limit for number of playlists to 20 (LP: #835384)
    - indicator-sound-service crashed with SIGSEGV (LP: #864732)
    - Music player icon is not top-aligned (LP: #874454)
  * debian/control
    - build with valac-0.14
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 09:45:22 -0400

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in indicator-sound (Ubuntu Oneiric):
milestone: none → oneiric-updates
assignee: nobody → Ken VanDine (ken-vandine)
status: New → Confirmed
importance: Undecided → Medium

Hello Barneedhar, or anyone else affected,

Accepted indicator-sound into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Barneedhar (barneedhar) wrote :

Lately, I am not experiencing this bug. Nonetheless, I will still test out the proposed package for indicator-sound and would let you know how it goes. Thanks!

Pedro Villavicencio (pedro) wrote :

I cannot reproduce the crash but I've been testing the package for a few days already and did not noticed any regression with it, marking this as verification-done so it can go into updates, thanks all.

tags: added: hw-specifc
tags: added: verification-done
removed: hw-specifc verification-needed
Barneedhar (barneedhar) wrote :

I think this bug has been fixed. I am not experiencing the bug anymore. Thanks for your time!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.7.9-0ubuntu2

---------------
indicator-sound (0.7.9-0ubuntu2) oneiric-proposed; urgency=low

  * src/pulseaudio-mgr.c
    - indicator-sound-service crashed with SIGABRT in raise() (LP: #840986)
  * src/music-player-bridge.{vala,c}
    - indicator-sound-service crashed with SIGSEGV (LP: #864732)
 -- Ken VanDine <email address hidden> Fri, 28 Oct 2011 10:12:36 -0400

Changed in indicator-sound (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers