indicator-applications leaks memory

Reported by Hernando Torque on 2011-08-20
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Application Indicators
High
Ted Gould
Unity Foundations
High
Ted Gould
indicator-power
Undecided
Unassigned
indicator-application (Ubuntu)
High
Ken VanDine
Oneiric
High
Ken VanDine
indicator-power (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

While monitoring some processes to find another leak, I found indicator-applications to constantly use more (resident) memory over time (see screenshot). Over 10 hours of the system idling, the process gained 23MB which is kind of unacceptable on long running systems (given that stays linear while the system is in use - I'm checking that today).

Will add valgrind information shortly.

Using indicator-application 0.3.92-0ubuntu1 on up-to-date Oneiric.

Hernando Torque (htorque) wrote :
description: updated
tags: added: oneiric
description: updated
Hernando Torque (htorque) wrote :

Attaching valgrind log of running ~one hour.

Hernando Torque (htorque) wrote :

Note, that the system was idling during that time.

Jean-Baptiste Lallement (jibel) wrote :

I can confirm the leak with the application indicator.

The graph enclosed shows the evolution of private memory usage of this indicator over time.
It shows that memory loss is around 1.6MB per hour, which matches the value found by the reporter.

Changed in indicator-application (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Sebastien Bacher (seb128) wrote :

sorry I confused bugs

Changed in indicator-power (Ubuntu Oneiric):
assignee: nobody → Javier Jardón (jjardon)
importance: Undecided → High
status: New → Confirmed
assignee: Javier Jardón (jjardon) → nobody
status: Confirmed → Invalid
Changed in indicator-power:
status: New → Invalid
David Barth (dbarth) wrote :

Thanks for the assesment Hernando.

Changed in indicator-application:
assignee: nobody → Ted Gould (ted)
Changed in indicator-application (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ted Gould (ted)
milestone: none → ubuntu-11.10-beta-2
Changed in indicator-application:
importance: Undecided → High
David Barth (dbarth) on 2011-08-30
Changed in unity-foundations:
milestone: none → oneiric-backlog
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
status: New → Triaged
Ted Gould (ted) on 2011-08-30
Changed in unity-foundations:
milestone: oneiric-backlog → oneiric-beta-2
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Ted Gould (ted) on 2011-09-14
Changed in indicator-application:
status: New → In Progress
Changed in unity-foundations:
status: Triaged → In Progress
Changed in indicator-application (Ubuntu Oneiric):
assignee: Ted Gould (ted) → nobody

[OT, from #ayatana 2011/09/01]
Trevinho and it seems that unity-panel-service itself is working well 15:52
Trevinho according to valgrind 15:52
Trevinho it seems something more related to the indicators 15:52
Trevinho and libappmenu seems the one 15:53
tedg Trevinho, Heresy I say! 15:53
* tedg sends the Spanish inquisition! 15:53
[/OT]

Sorry, about this! :)
However I'll try your branch as soon as I can!

Michael Terry (mterry) on 2011-09-16
Changed in indicator-application (Ubuntu Oneiric):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

Oh, crap. Didn't see Neil's branch before making my own. :-/ I still like mine because it also sets more fields and fixes a missed free in finalize. But no biggy.

Changed in indicator-application (Ubuntu Oneiric):
assignee: Michael Terry (mterry) → nobody
Ted Gould (ted) on 2011-09-16
Changed in indicator-application:
status: In Progress → Fix Committed
Changed in unity-foundations:
status: In Progress → Fix Committed
Changed in indicator-application:
milestone: none → 0.3.93
Martin Pitt (pitti) wrote :

Not a release blocker for beta-2, but let's make sure this gets into the final release. Fixed upstream, setting to "in progress".

Changed in indicator-application (Ubuntu Oneiric):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
status: Confirmed → In Progress
assignee: nobody → Ken VanDine (ken-vandine)
Changed in indicator-application (Ubuntu Oneiric):
status: In Progress → Fix Committed
Ted Gould (ted) on 2011-09-28
Changed in indicator-application:
milestone: 0.3.93 → 0.4.0
Ted Gould (ted) on 2011-09-28
Changed in indicator-application:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.4.0-0ubuntu1

---------------
indicator-application (0.4.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    * Fix memory leak (LP: #829961)
 -- Ted Gould <email address hidden> Wed, 28 Sep 2011 10:02:11 -0500

Changed in indicator-application (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Ted Gould (ted) on 2012-09-10
Changed in unity-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers