you have to release alt for alt + F10 working

Bug #943223 reported by Didier Roche on 2012-02-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
Unity Distro Priority
Medium
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

With unity 5.6 RC:

- press alt, keep it pressed
- press F10, release it
-> see the menu isn't opened until alt is released

This seems weird in using it :)

Related branches

Didier Roche (didrocks) on 2012-02-29
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
milestone: none → 5.6.0
Changed in unity (Ubuntu):
importance: Undecided → Medium
Daniel van Vugt (vanvugt) wrote :

I will have a look at this bug. It sounds like a simple problem.

I notice in oneiric (and compiz-core) that Alt+F10 is the key combo to maximize a window. Has that been overridden/changed in precise? What is Alt+F10 expected to do in precise?

Or do you mean to use F10 to access the panel menu, and it's delayed by using Alt?

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-core:
milestone: none → 0.9.7.2
status: New → In Progress
importance: Undecided → Medium

On Thu 01 Mar 2012 17:43:07 NZDT, Daniel van Vugt wrote:
> I will have a look at this bug. It sounds like a simple problem.
>
> I notice in oneiric (and compiz-core) that Alt+F10 is the key combo to
> maximize a window. Has that been overridden/changed in precise? What is
> Alt+F10 expected to do in precise?

It should open the file menu (I believe).

> Or do you mean to use F10 to access the panel menu, and it's delayed by
> using Alt?

I think the expected behaviour is that if you hold alt and tap F10 the
menu should open straight away, not wait for the alt release.

Daniel van Vugt (vanvugt) wrote :

Are you saying that Alt+F10 (the compiz-core binding for maximize) has been removed in precise, or that you expect listeners for F10 to be triggered when Alt+F10 is pressed? Or both?...

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3035

Changed in compiz-core:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Daniel van Vugt (vanvugt) wrote :

This bug was fixed in the package compiz - 1:0.9.7.0+bzr3035-0ubuntu1

---------------
compiz (1:0.9.7.0+bzr3035-0ubuntu1) precise; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix gtk-window-decorator crash upon demaximizing a window (LP: #930071)
    - Fix core keybindings (LP: #930412)
    - Fixes compiz crash with SIGSEGV on shutdown (LP: #931283)
    - Plugins can't tell the difference between a key-tap and modifier
      key-release (LP: #925293)
    - compiz-core r3001 (and 3002) ftbfs (LP: #933226)
    - Semi-maximized windows have no shadow or frame (LP: #924736)
    - Untranslated strings in gtk-window-decorator (LP: #780505)
    - Initialize the _NET_WM_STATE_FOCUSED (LP: #932087)
    - [regression] Customized shortcuts don't work (LP: #931927)
    - Window stacking problem (LP: #936675)
    - Quickly demaximized windows can receive maximized window decorations if
      they were initially maximized (LP: #936778)
    - Maximized windows do not get shadows at all (LP: #936774)
    - [regression] Launcher, top panel and keyboard un-responsive after using
      any Super-x shortcut (LP: #934058)
    - No draggable border if mutter isn't installed (LP: #936781)
    - Fix compiz crash with SIGSEGV in XDefineCursor() (LP: #936487)
    - Fixes memory leak at DecorWindow::updateSwitcher() (LP: #940115)
    - Unresolved symbols in plugins cause compiz to exit (LP: #938478)
    - Fix compiz spending about 51% of its CPU time in CompRegion
      construction/destruction (LP: #940139)
    - Fix Conditional jump or move depends on uninitialised value(s) in
      decor_match_pixmap (LP: #940066)
    - Fix 'show desktop' behaviour (LP: #871801)
    - Tweak algorithm used to cast shadows on maximized windows (LP: #936784)
    - "Svg" and "Png" should be "SVG and "PNG" (LP: #942890)
    - Fix invalid memory usage after free() in DecorWindow (LP: #943116)
    - Fix alt + F10 (LP: #943223)
  * Removed cherry-picked patches
  * debian/patches/fix_944631.patch:
    - Always replay the keyboard if something was grabbed and didn't trigger
      an action and don't trigger actions which aren't added accidentally
      (LP: #943612) (LP: #944631)
  * debian/patches/fix_923683.patch:
    - Backports a patch which prevents the shift race condition

  [ Didier Roche ]
  * debian/patches/fix_alt_pressing.patch:
    - Patch from ddv to fix all the regressions with the alt key fix and other
      (LP: #943851, #945373)
    - Fix Quicklist are not showing if right-clicking a launcher icon in Expo
      mode if triggered by Super + S (LP: #944979)
  * debian/patches/fix_806255.patch:
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
  * debian/patches/fix_943194.patch:
    - second part for the alt key fix (LP: #943194)
  * debian/patches/additional_alt_tapping_fix.patch:
    - again another alt tapping related fix for some regressions from the
      previous branch. Taken from "tapping-panacea" upstream branch.
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 10:22:10 +0100

Changed in compiz (Ubuntu):
status: New → Fix Released
no longer affects: unity
Changed in unity (Ubuntu):
status: Triaged → Invalid
Łukasz Zemczak (sil2100) wrote :

I still seem to get this bug on compiz 1:0.9.7.0+bzr3035-0ubuntu1.

Didier Roche (didrocks) wrote :

reverted, didn't fix it, indeed

Changed in compiz-core:
status: Fix Committed → Confirmed
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Didier Roche (didrocks) wrote :

(the status is reverted)

Łukasz Zemczak (sil2100) wrote :

It seems to be correctly handled by compiz (the triggerPress() is fired at the right moment, the corresponding action as well). It looks to me like a race condition in handling the alt + F10 and the hold-alt 'make the menu appear on the panel'. Looking into this.

Changed in compiz-core:
status: Confirmed → Invalid
Changed in unity:
status: New → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: Invalid → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
importance: Undecided → Medium
Daniel Hahler (blueyed) wrote :

I just wanted to point out that Alt-F10 is severely broken, up to the point where you have to restart/replace unity from VT1 because it gets stuck in the app indicator (e.g. after Alt-F10 then just F10 or Alt-F10 again to figure out why it won't maximize).

I assume that it gets fixed in the next uploads/release(s) and just wanted to notify you about this.

Changed in compiz-core:
milestone: 0.9.7.2 → none
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2161

Changed in unity:
status: In Progress → Fix Committed
milestone: none → 5.8.0
no longer affects: compiz-core
no longer affects: compiz (Ubuntu)
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers