Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches between Lenses and 'TAB' by itself moves the focus between categories

Reported by John Lea on 2011-11-17
90
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Andrea Azzarone
Unity Distro Priority
Undecided
Unassigned
unity-2d
High
Albert Astals Cid
unity-2d (Ubuntu)
High
Unassigned
Precise
High
Bartosz Kosiorek
unity (Ubuntu)
High
Andrea Azzarone
Precise
Undecided
Unassigned

Bug Description

Test case:
1. Open the dash
   -> "CTRL + TAB" and "CTRL + PAGEDOWN" should switch the user between lenses, in a left to right order
   -> "CTRL + SHIFT + TAB" and "CTRL + PAGEUP" should switch the user between lenses, in a right to left order.
   -> TAB should jump the keyboard focus between the search result category headers and (if the search filters are open) between the "All" button at the top of each search filter category header.
   -> If no item on the dash is currently in focus, pressing TAB should focus the top category header.
   -> If a item is already focused, pressing TAB should focus the next category header below.
   -> If the item focused is either in the last search result category header, or (if the search filters are open), a button under the last search filter category header, pressing TAB should jump the focus back to the first search result category header.
   -> If the search filters are open and the item in the last search result category header is selected, pressing TAB should focus the "All" button to the right of the top search filter category header.

===

Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches between Lenses and 'TAB' by itself moves the focus between categories.

Requested change:
- When the Dash is open, "CTRL + TAB" and "CTRL + PAGEDOWN" should switch the user between lenses, in a left to right order.
- When the Dash is open, "CTRL + SHIFT + TAB" and "CTRL + PAGEUP" should switch the user between lenses, in a right to left order.
- When the Dash is open, TAB should jump the keyboard focus between the search result category headers and (if the search filters are open) between the "All" button at the top of each search filter category header.
- If no item on the dash is currently in focus, pressing TAB should focus the top category header.
- If a item is already focused, pressing TAB should focus the next category header below.
- If the item focused is either in the last search result category header, or (if the search filters are open), a button under the last search filter category header, pressing TAB should jump the focus back to the first search result category header.
- If the search filters are open and the item in the last search result category header is selected, pressing TAB should focus the "All" button to the right of the top search filter category header.

* when implementing this bug, also review bug https://bugs.launchpad.net/ayatana-design/+bug/844033 *

Related branches

lp:~tiagosh/unity-2d/bugfix-891565
Rejected for merging into lp:unity-2d
Albert Astals Cid: Disapprove on 2013-11-29
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-10-15
jenkins (community): Disapprove (continuous-integration) on 2012-05-31
Lohith D Shivamurthy (community): Needs Fixing on 2011-12-21
lp:~andyrock/unity/megasuper-keynav
Merged into lp:unity at revision 1998
John Lea: Approve (design) on 2012-02-21
Tim Penhey (community): Approve on 2012-02-21
John Lea (johnlea) on 2011-11-17
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: udp

We have an issue that ctrl-pgup/dn is used for switching tabs in some
places, and ctrl-tab in others. We need to resolve that for consistency
across all applications that offer tabs.

Mark

Tim Penhey (thumper) wrote :

In both firefox and chromium (apps most people use lots of tabs in) the use of ctrl-pgup/down is used to move around tabs.

I'd be much happier for us to use those keybindings than ctrl-tab/ctrl-shift-tab (you have to be able to go back too).

Changed in unity:
importance: Undecided → High

Agreed, Tim. But one last thought; what about Super-PgUp/Dn, for
consistency with the "app/window/tab starts with Super" meme?

Super+PgDn can not be pressed with one hand...

Em 17-11-2011 19:29, Mark Shuttleworth escreveu:
> Agreed, Tim. But one last thought; what about Super-PgUp/Dn, for
> consistency with the "app/window/tab starts with Super" meme?
>

Mark Shuttleworth (sabdfl) wrote :

As it happens, on my keyboard at least, the Ctrl which is
one-hand-distance from PgUp and PgDn doesn't work in that way. So
switching tabs is a two-hand combo for me currently, I don't know if
that's specific to my keyboard or not.

Mark

John Lea (johnlea) wrote :

Chromium, Firefox & Thunderbird all support both CTRL + TAB as well as CTRL + PAGEUP and PAGEDOWN. I was leaning towards CTRL + TAB because in a unscientific straw poll this seemed to be the most frequently requested option, and also some laptops (e.g. those from Apple) do not have PAGEUP and PAGEDOWN keys. To compare ourselves to the competition, Apple use CTRL + TAB in Safari on OS X, and on Windows both CTRL + TAB and CTRL + PAGEUP and PAGEDOWN are supported.

 As long as there is no conflict with other functionality we could support both (in the same manner as Windows), as it is likely that different sets of users will be already used to one or the other of the options, and this is the approach already taken by our main applications.

description: updated
Omer Akram (om26er) on 2011-11-18
Changed in unity (Ubuntu):
importance: Undecided → High
Tim Penhey (thumper) on 2011-11-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Gerry Boland (gerboland) on 2011-11-23
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → High
Changed in unity-2d (Ubuntu):
importance: Undecided → High
John Lea (johnlea) on 2011-11-24
description: updated
Tim Penhey (thumper) on 2011-11-24
tags: added: keybinding
Tim Penhey (thumper) on 2011-12-05
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
status: Confirmed → In Progress
description: updated
Omer Akram (om26er) on 2011-12-12
Changed in unity:
milestone: backlog → 5.2.0
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Didier Roche (didrocks) on 2012-01-20
Changed in unity-distro-priority:
status: New → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
milestone: 5.2.0 → 5.4.0
Didier Roche (didrocks) on 2012-02-14
Changed in unity:
milestone: 5.4.0 → 5.6.0
Greg Merchan (gregory-merchan) wrote :

I've been frustrated a number of times expecting tab completion to work in the search field.

The CUA-inspired scheme we once discussed for GNOME was that there was a sort of hierarchy of modifier key bindings. I forget to what extent we went with it. Here are a few examples:

Session level - Ctrl+Alt+key
Ctrl+Alt+Backspace - kill the X server
Ctrl+Alt+Delete - log out, shutdown, etc., like Windows.
Ctrl+Alt+L - lock screen
Ctrl+Alt+D - show desktop

Window level - Alt+key
Alt+Tab - switch between windows
Alt+F4 - close window
Alt+F9 - minimize window

In-window level - Ctrl+key
Ctrl+Tab - switch between tabs
Ctrl+F4 - close tab or child window
Ctrl+F9 - minimize child window or hide tab

This was before the logo key was ubiquitous and commonly mapped to Super, which would take the place of Ctrl+Alt.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick (soapduk) wrote :

With regards to the comments (#4 & 5) about being able to do the switching with one hand, eg CTRL+PG UP/DN or CTRL+TAB, it appears the latest 12.04 beta updates don't yet include the ability to do this, ie with the right hand CTRL keys.

Didier Roche (didrocks) on 2012-03-14
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Gerry Boland (gerboland) on 2012-03-14
Changed in unity-2d:
milestone: none → 5.8
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
John Lea (johnlea) on 2012-04-05
description: updated
Albert Astals Cid (aacid) wrote :

For Unity2D the changing lens part (Ctrl+Tab, Ctrl+Shift+TAb, etc) has been merged with https://code.launchpad.net/~aacid/unity-2d/addshortcutstochangelens the in-lens Tab navigation is still WIP

Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-20
tags: added: reviewedbydesignp
Changed in ayatana-design:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
tags: removed: reviewedbydesignp
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity (Ubuntu Precise):
status: New → Fix Released
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
status: Fix Committed → Fix Released

Hello John, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity-2d (Ubuntu Precise):
assignee: nobody → Bartosz Kosiorek (gang65)
importance: Undecided → High
tags: added: verification-donedistro-priority
removed: distro-priority verification-needed
tags: added: distro-priority verification-done
removed: verification-donedistro-priority
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.12.0-0ubuntu1

---------------
unity-2d (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in ref() (LP: #968046)
    - [hud] First entry always activated with keyboard navigation
      (LP: #980899)
    - unity-2d-shell crashes on autoscrolling on launcher tile removal
      (LP: #988239)
    - unity-2d-shell crashes when using with a NX server (LP: #983942)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - [spread] When multiple windows of an app are open, clicking on one
      doesn't bring it to the foreground (LP: #917334)
    - [HUD][multi-monitor] HUD should be expanded to the left if used on a
      screen without launcher (LP: #979927)
    - unity-2d scope un-url-escapes values from its model (LP: #986175)
    - [places] tab key does nothing (LP: #891565)
    - HUD is silent to screen readers (LP: #949445)
    - launcher background coloring does not get reset when using enter to
      activate/start a program (LP: #965079)
    - [multi-monitor] [launcher] Drag & drop application to launcher on
      primary screen, other launchers not updated (LP: #966239)
    - HUD gets activated by Thinkpad USB Keyboard's back and forward buttons
      (LP: #968840)
    - Unity 2D doesn't load 24 bit icons (LP: #977262)
    - Four finger tap does not open the Dash (LP: #978659)
    - No icon in launcher entry, after installing software (LP: #980640)
    - Menu items displayed incorrectly when window streched over multiples
      monitors (LP: #987215)
    - [unity-2d-panel] The close button (potentially the others too) can
      toggled even when they are not visible anymore (LP: #924264)
    - When closing the Dash with the [x] panel button the last windows is not
      focused and doesn't allow to use window controls. (LP: #945459)
    - [launcher] item hint flickers when hovering between launcher edge and
      item (LP: #948383)
    - Missaligned progress bar (LP: #980609)
    - Launcher tile tooltip appears in wrong screen in RTL multimonitor setups
      (LP: #984080)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 09:32:40 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-09-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: removed: udp
Didier Roche (didrocks) on 2012-12-11
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers