Launcher - Dragging a Launcher icon to the Trash should remove the icon

Bug #676466 reported by John Lea on 2010-11-17
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
Unassigned
Unity
Fix Released
Medium
Didier Roche
unity design (obsolete project)
Fix Released
Critical
Unassigned
unity-2d
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Dragging a Launcher icon to the Trash should remove the icon.

Description:

Currently, the only way to remove a launcher icon is to drag it away from the launcher. This needs to change so that to remove a icon from the launcher you drag and drop it in the Trash.

Change request:

1) Remove the "X" that appears when the icon is dragged away from the Launcher (see attached screenshot)

3) Remove the ability to icons to be removed through dragging and dropping onto the right hand side of the screen.

2) Enable icons to be removed by dragging and dropping on top of the Trash can. If the application is running when this action is performed the application should also quit.

Related branches

John Lea (johnlea) wrote :
Changed in unity-design:
status: New → Confirmed
John Lea (johnlea) on 2010-11-17
tags: added: udn-launcher
John Lea (johnlea) on 2010-11-18
tags: added: udt
Changed in unity-design:
status: Confirmed → Triaged
importance: Undecided → Critical
status: Triaged → Fix Released
John Lea (johnlea) on 2010-11-19
Changed in ayatana-design:
status: New → Fix Released
importance: Undecided → Critical
John Lea (johnlea) on 2010-11-19
Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in unity-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2010-12-02
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2010-12-02
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
tags: added: backlog
Paul Sladen (sladen) wrote :

Dumb question: what happens if the launcher icon that is dropped on the Trash corresponds to a still running? Would it:

 a. Terminate the application?
 b. Remove the persistent launcher, but allow the icon to remain while running?
 c. Do nothing
 d. Do nothing and warn the user (eg. visually by not allowing it be dropped or showing a no-entry sign)

On 03/12/10 15:51, Paul Sladen wrote:
> b. Remove the persistent launcher, but allow the icon to remain while running?

Unpin the launcher, which unfortunately *looks* like a noop until the
app quits. If we had a refinement of the visual treatment for running
apps which are not pinned, this would at least allow us to signal the
change.

Mark

John Lea (johnlea) on 2011-01-06
description: updated
Changed in unity-2d:
status: New → Confirmed
milestone: none → 3.4
importance: Undecided → Medium
assignee: nobody → Ugo Riboni (uriboni)
Changed in unity-2d:
status: Confirmed → Triaged
Changed in unity-2d:
milestone: 3.4 → 3.6
Changed in unity-2d:
assignee: Ugo Riboni (uriboni) → nobody
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity-2d:
milestone: 3.6 → none
Mark Shuttleworth (sabdfl) wrote :

Similarly here - why drop this?

Florian Boucault (fboucault) wrote :

@Mark: same explanation as the other bug. It will not make it for feature freeze and will be re-scheduled very soon.

Changed in unity-2d:
assignee: Olivier Tilloy (osomon) → nobody
milestone: none → 3.8
tags: added: delta-with-3d
Changed in unity-2d:
milestone: 3.8 → 3.10
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
assignee: Jason Smith (jassmith) → Alex Launi (alexlauni)
Changed in unity-2d:
milestone: 3.10 → none
Didier Roche (didrocks) on 2011-03-23
Changed in unity:
assignee: Alex Launi (alexlauni) → Didier Roche (didrocks)
milestone: none → 3.8
status: Triaged → Fix Committed
milestone: 3.8 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
John Lea (johnlea) on 2011-03-30
tags: added: reviewedbydesign
removed: udt
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Triaged
Aritchie (aritchie) wrote :

Hmm, well I take it from reading some of the duplicates that it might sometime before this is implemented in unity-2d because of the current "internal plumbing". Well, it is what it is. Maybe it should be just left to just using the context menu?

Changed in unity-2d:
status: Triaged → Invalid
Changed in unity-2d (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments