Corrupted calibre after searching for Book from the lens

Bug #882163 reported by Ngassam Nkwenga on 2011-10-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity Books Lens
Critical
David Callé

Bug Description

I saw your your post on G+ so I tested the lens(calibre) again and I can't have any result when activating the Calibre filter. after this I launched Calibre and it reported that Library Database where Corrupted. I asked Calibre to fix the Database. Is there any other file I need to have it working correctly ?

David Callé (davidc3) wrote :

Hello Ngassam, thanks for the report.

This is strange.

Does Calibre reports the Library DB being corrupted after each time you try the lens?
Does the Calibre filter works after Calibre fixed the db?

Could you please paste here the output of the following command in a terminal?
cat ~/.config/calibre/global.py | grep library_path

Changed in unity-books-lens:
importance: Undecided → High
assignee: nobody → David Callé (davidc3)

Don't worry for ma Database, I have a copy.

here is what I did :

1- I update my sources-list by adding your PPA and then I make an upgrade. (
Calibre not started of course)
2- I installed the Books lens.
3- I log out and log in again.
4- I launched the Book lens and activated the Calibre Filter and searched
for a random item I know I have on my Calibre Librairy and nothing appened
here, no resulte. The other Filter worked well ( but I did not make a deep
test)
5- I closed the Dash and Launched Calibre , and it is here where I received
the message saying that the Calibre Database where corrupted. It proposed an
option to Fix saying it might last a while when the Collection is huge .
6- As of yet , it is still trying to repair the Database. May be I will
have to for it to finish before launching the Lens again.

here is the output you requested :

  *library_path = u'/home/cyrildz/Librairie calibre'*

Ngassam Nkwenga (cyrildz) wrote :

I attached here a pic .

Ngassam Nkwenga (cyrildz) wrote :

I stopped the Repairing tool since it last too long , I launched Calibre again, it shows the same message , from this I see that Database is locked. here are the details :

Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/gui2/main.py", line 215, in initialize_db
    db = LibraryDatabase2(self.library_path)
  File "/usr/lib/calibre/calibre/library/database2.py", line 212, in __init__
    self.initialize_dynamic()
  File "/usr/lib/calibre/calibre/library/database2.py", line 328, in initialize_dynamic
    '''.format(_('News')))
  File "/usr/lib/calibre/calibre/library/sqlite.py", line 308, in run
    raise DatabaseException(*res)
DatabaseException: database is locked
 RemoteTraceback (most recent call last):
   File "/usr/lib/calibre/calibre/library/sqlite.py", line 268, in run
     ok, res = True, bfunc(*args, **kwargs)
 OperationalError: database is locked

David Callé (davidc3) wrote :

I'm trying to reproduce the problem without success, I don't see this db corruption in other machines.

One way to help me solve it would be to send me the metadata.db file located in "/home/cyrildz/Librairie calibre" but, as it contains the name of all your books, you might see a privacy issue. In that case, I would try another way.

My mail : <email address hidden>

Ngassam Nkwenga (cyrildz) wrote :

No it would not be any privacy issue, but I deleted yesterday as I said, I had a copy.
I create a new Library and added to it only one book and there was no probleme with corrupted Data, but I could not find this book from the Lens.
I tried again with a back up Library from an Extern Harddrive and the same probleme appear again.
I send you the database

David Callé (davidc3) on 2011-10-27
Changed in unity-books-lens:
status: New → Confirmed
status: Confirmed → In Progress
importance: High → Critical
Ngassam Nkwenga (cyrildz) wrote :

Thanks a lot, yet is the Lens running without any corruption :
But I noticed some little bug :

* after any query I have to change to another filter and switch back to the previews one in order to have the search results being printed.

*searching for some words doesn't give any results : here for exemple "C++"
*The maximum number of item showed from a search result from the Google Filter is 10. I think it should be more , given the reputation of the searched term.

Many thanks for the work you have done :)

David Callé (davidc3) wrote :

* Do you have any of this lens installed : reddit, askubuntu, webhistory? I'm tracking a bug that could be related to these.

* Confirmed. Would you mind filling another bug specific to this?

* This sadly is a Google limitation. There is a workaround I will try soon.

Changed in unity-books-lens:
status: In Progress → Fix Committed
David Callé (davidc3) on 2011-11-07
Changed in unity-books-lens:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers