Trademarked assets

Reported by John Pugh on 2013-04-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity Asset Pool
Undecided
Unassigned
kdenetwork (Ubuntu)
Critical
Dimitri John Ledkov
Quantal
Undecided
Unassigned
Raring
Critical
Dimitri John Ledkov
ktp-common-internals (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
lubuntu-artwork (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
oxygen-icons (Ubuntu)
High
Dimitri John Ledkov
Quantal
Undecided
Unassigned
Raring
High
Dimitri John Ledkov
ubiquity-slideshow-ubuntu (Ubuntu)
High
Stéphane Graber
Quantal
Undecided
Unassigned
Raring
High
Stéphane Graber
ubuntukylin-default-settings (Ubuntu)
Critical
Colin Watson
Quantal
Undecided
Unassigned
Raring
Critical
Colin Watson
unity-asset-pool (Ubuntu)
High
Unassigned
Quantal
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

Microsoft has requested that the skype.png be removed from this package.

Investigating it, it seems that we even didn't use that icon on the system. The launcher icon was already presenting the skype icon in the microsoft deb package. So we didn't use that one.

Didier Roche (didrocks) on 2013-04-03
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-asset-pool at revision 76, scheduled for release in unity-asset-pool, milestone Unknown

Changed in unity-asset-pool:
status: New → Fix Committed
Didier Roche (didrocks) wrote :

checking it, the file was in the account-plugins before ending up in unity-asset-pool and none of them shipped the skype icon in quantal, so the change isn't needed here.

Changed in unity-asset-pool (Ubuntu Quantal):
status: New → Invalid
description: updated
Sebastien Bacher (seb128) wrote :

looking to raring we have some other instances in the archive, include the ubiquity slideshow in main, it was suggested it would be good to clean those as well:
/usr/share/ubiquity-slideshow/slides/icons/skype.png ubiquity-slideshow-lubuntu, ubiquity-slideshow-ubuntu

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

This is part of the installer and got shipped on the pressed quantal CDs and are not going to be re-released, as there is no point releases in raring.

Changed in ubiquity-slideshow-ubuntu (Ubuntu Quantal):
status: New → Won't Fix
Changed in ubiquity-slideshow-ubuntu (Ubuntu Raring):
milestone: none → ubuntu-13.04
status: Confirmed → Fix Committed
assignee: nobody → Stéphane Graber (stgraber)
Changed in unity-asset-pool (Ubuntu Raring):
importance: Undecided → High
status: New → Fix Committed
Changed in ubiquity-slideshow-ubuntu (Ubuntu Raring):
status: Fix Committed → In Progress
status: In Progress → Fix Committed
no longer affects: ubiquity-slideshow-ubuntu
Dimitri John Ledkov (xnox) wrote :

Lubuntu artwork contains:
./usr/share/icons/lubuntu/apps/48/skype.svg
./usr/share/icons/lubuntu/apps/24/skype.svg
./usr/share/icons/lubuntu/apps/16/skype.svg
./usr/share/icons/lubuntu/apps/22/skype.svg

Please remove them.

Changed in lubuntu-artwork (Ubuntu Quantal):
status: New → Invalid
Changed in lubuntu-artwork (Ubuntu Raring):
status: New → Confirmed
Alan Pope ㋛ (popey) wrote :

kopete contains:-

/protocols/skype/icons/ox16-app-skype_protocol.png
/protocols/skype/icons/ox22-app-skype_protocol.png
/protocols/skype/icons/ox32-app-skype_protocol.png
/protocols/skype/icons/ox48-app-skype_protocol.png
/protocols/skype/icons/ox128-app-skype_protocol.png

Rafael Laguna (rafaellaguna) wrote :

It's being removed from Lubuntu artwork (and any other external download)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 69

---------------
ubiquity-slideshow-ubuntu (69) raring; urgency=low

  [ Dmitrijs Ledkovs ]
  * Drop references to Skype™ and its logo. (LP: #1163504)

  [ Stéphane Graber ]
  * Update translations from Launchpad.
  * Update PO templates after Skype string change.
 -- Stephane Graber <email address hidden> Fri, 12 Apr 2013 14:50:28 +0200

Changed in ubiquity-slideshow-ubuntu (Ubuntu Raring):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lubuntu-artwork - 0.38.1

---------------
lubuntu-artwork (0.38.1) raring; urgency=low

  * usr/share/icons/lubuntu/
   - Remove Skype content (LP: #1163504)
 -- Julien Lavergne <email address hidden> Sat, 13 Apr 2013 07:54:59 +0200

Changed in lubuntu-artwork (Ubuntu Raring):
status: Confirmed → Fix Released
David Pitkin (dpitkin) wrote :

The skype icon still shows up on packages.ubuntu.com, is this fix released?

http://packages.ubuntu.com/raring/all/unity-asset-pool/filelist

Colin Watson (cjwatson) on 2013-04-24
affects: kopete (Ubuntu Quantal) → kdenetwork (Ubuntu Quantal)
Colin Watson (cjwatson) on 2013-04-24
Changed in ubuntukylin-default-settings (Ubuntu Quantal):
status: New → Invalid
Colin Watson (cjwatson) on 2013-04-24
Changed in ubuntukylin-default-settings (Ubuntu Raring):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Critical
milestone: none → ubuntu-13.04
status: New → In Progress
Changed in kdenetwork (Ubuntu Raring):
assignee: nobody → Dmitrijs Ledkovs (xnox)
importance: Undecided → Critical
status: New → In Progress
Changed in kdenetwork (Ubuntu Quantal):
status: New → Won't Fix
Changed in oxygen-icons (Ubuntu Quantal):
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-asset-pool - 0.8.24daily13.04.24-0ubuntu1

---------------
unity-asset-pool (0.8.24daily13.04.24-0ubuntu1) raring; urgency=low

  * Remove skype icon (LP: #1163504)
  * Automatic snapshot from revision 76
 -- Didier Roche <email address hidden> Wed, 24 Apr 2013 16:56:06 +0200

Changed in unity-asset-pool (Ubuntu Raring):
status: Fix Committed → Fix Released
David Pitkin (dpitkin) wrote :

The Skype.png icon being introduced in this package along with the other trademarked icons causes a break in Skype 4.2 which is about to be released since it can not update its own icon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-default-settings - 1.0.4.1

---------------
ubuntukylin-default-settings (1.0.4.1) raring; urgency=low

  * Remove Skype icons (LP: #1163504).
 -- Colin Watson <email address hidden> Wed, 24 Apr 2013 16:24:57 +0100

Changed in ubuntukylin-default-settings (Ubuntu Raring):
status: In Progress → Fix Released
Changed in oxygen-icons (Ubuntu Raring):
assignee: nobody → Dmitrijs Ledkovs (xnox)
importance: Undecided → High
status: New → Triaged
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ktp-common-internals - 0.6.1dfsg1-0ubuntu1

---------------
ktp-common-internals (0.6.1dfsg1-0ubuntu1) raring; urgency=low

  * Remove Skype icons LP: #1163504
 -- Jonathan Riddell <email address hidden> Wed, 24 Apr 2013 17:37:29 +0100

Changed in ktp-common-internals (Ubuntu Raring):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oxygen-icons - 4:4.10.2+dfsg-0ubuntu1

---------------
oxygen-icons (4:4.10.2+dfsg-0ubuntu1) raring; urgency=low

  * Repackage to remove Skype™ icons. (LP: #1163504)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 24 Apr 2013 17:33:40 +0100

Changed in oxygen-icons (Ubuntu Raring):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kdenetwork - 4:4.10.2+dfsg-0ubuntu1

---------------
kdenetwork (4:4.10.2+dfsg-0ubuntu1) raring; urgency=low

  * Do not install Skype™ plugin. (LP: #1163504)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 24 Apr 2013 16:02:14 +0100

Changed in kdenetwork (Ubuntu Raring):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ktp-common-internals (Ubuntu Quantal):
status: New → Confirmed
Changed in ktp-common-internals (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers