Reenable closing apps from HUD

Bug #1269409 reported by Thomas Strehl on 2014-01-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Pete Woods
Unity Action API
Undecided
Pete Woods
Unity HUD
Fix Released
Undecided
Pete Woods
camera-app
Fix Released
Undecided
Pete Woods
camera-app (Ubuntu)
Undecided
Unassigned
hud (Ubuntu)
Undecided
Pete Woods
ubuntu-ui-toolkit (Ubuntu)
Undecided
Pete Woods
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

 Readd the closing functionality to HUD.

Related branches

Thomas Strehl (strehl-t) wrote :

Albert: Pete will ping you once we have the backend functionality back.

Pete Woods (pete-woods) wrote :

The remaining task is to patch the Ubuntu SDK to listen to the new "quit" signal from the Unity ActionManager. And, of course, testing.

Changed in hud:
status: New → In Progress
Albert Astals Cid (aacid) wrote :

Added the unity8 branch that should in theory work once all the plumbing is done.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:hud at revision 364, scheduled for release in hud, milestone Unknown

Changed in hud:
status: In Progress → Fix Committed
Pete Woods (pete-woods) on 2014-01-29
Changed in unity-action-api:
assignee: nobody → Pete Woods (pete-woods)
Pete Woods (pete-woods) on 2014-01-30
Changed in unity8:
assignee: nobody → Albert Astals Cid (aacid)
Changed in ubuntu-ui-toolkit:
assignee: nobody → Pete Woods (pete-woods)
status: New → In Progress
Changed in unity-action-api:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-action-api at revision 32, scheduled for release in unity-action-api, milestone Unknown

Changed in unity-action-api:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hud - 13.10.1+14.04.20140206-0ubuntu1

---------------
hud (13.10.1+14.04.20140206-0ubuntu1) trusty; urgency=low

  [ Pete Woods ]
  * Re-enable quit action in HUD client library. (LP: #1269409)
  * Extra checks for null DBusMenuCollector

  [ Marcus Tomlinson ]
  * Cache size of QtGActionGroup in m_size rather and re-calculating it
    on every Size() call. (LP: #1276225)
 -- Ubuntu daily release <email address hidden> Thu, 06 Feb 2014 11:58:43 +0000

Changed in hud (Ubuntu):
status: New → Fix Released
Pete Woods (pete-woods) on 2014-02-10
Changed in camera-app:
status: New → In Progress
Changed in hud (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Pete Woods (pete-woods) on 2014-02-10
Changed in camera-app:
assignee: nobody → Pete Woods (pete-woods)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision 935, scheduled for release in ubuntu-ui-toolkit, milestone february-2014

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Pete Woods (pete-woods) on 2014-02-14
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Pete Woods (pete-woods)
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20140212-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20140212-0ubuntu1) trusty; urgency=low

  [ Andrew Hayzen ]
  * Fixed text not aligned at vertical centre if the listitem height has
    changed dynamically. Fixed no removeItemAnimation if the listitem
    height has been set. (LP: #1263688, #1263682)

  [ CI bot ]
  * Trunk as is, for CI Train release.

  [ William Hua ]
  * Also update LANGUAGE when setLanguage is called for dynamic
    translation. (LP: #1263163). (LP: #1263163)

  [ Timo Jyrinki ]
  * A qtdeclarative5-private-dev packaging change adding a dependency on
    libqt5v8-5-private-dev has been backported to all Ubuntu versions
    now, so this workaround can now be dropped - building both against
    Qt 5.2 and 5.0.2 works.
  * Add #include for QDebug to fix Qt 5.2 build.

  [ Christian Dywan ]
  * Split build and install steps in debian/rules.
  * Use integer Date constructor in date picker tests for Qt 5.2.
  * Run unit_x11 test cases via Xvfb and address failures. (LP:
    #1258017, #1237812, #1242646)
  * Don't redirect output of the input file in itself.
  * Don't try to deploy non-existing qml and js files. (LP: #1259228)
  * Assert textField focus, button visibility and pressed after tapping
    clear.
  * Split documentation for previously group properties. (LP: #1266842)
  * Suppress errors to work-around font error messages. (LP: #1256999)
  * ListItems.Empty's default property needs to be data not children.
    (LP: #1190509)

  [ Pete Woods ]
  * Handle the unity-action-api quit signal. (LP: #1269409)

  [ Zsombor Egri ]
  * Date picker component. Provides full date and month only picking
    functionality.
  * DatePicker test case fix, setting the minimum limit to value that is
    earlier than the date value set. (LP: #1266515)
  * Fixing state restoration when nested dynamic component properties
    are restored. (LP: #1267039)
  * Removing obsolete functionality from QuickUtils. (LP: #1266707)
  * StateSaver failure with Repeater fixed. Indirectly fixes StateSaver
    with ListView and GridView. (LP: #1267900)
  * TabBar test case failure fix for Qt5.2. (LP: #1256930)
  * InverseMouseArea API test removed, being a duplicate of the other
    InverseMouseArea tests. Connecting to th eproper enabledChanged
    signal in InverseMouseArea resolves the warning in Qt5.2 stating
    enabledChanged was overwritten in QQuickMouseArea. (LP: #1266707)
  * Panel implementation for DatePicker. Presents the DatePicker either
    in a panel covering the OSK area or in a Popover, depending on the
    form factor and presence of input method provider.
  * Layout tests now wait for the currentLayout change completion. (LP:
    #1266707)
  * Extra QQmlEngine instance removed from plugin, which seemed to cause
    some race conditions with Qt5.2. As result UbuntuColors got
    transferred from context property into singleton object, Theme's
    palette creation delayed till its first access. (LP: #1266707)
  * DateUtils test failure fix. (LP: #1273893)

  [ Florian Boucault ]
  * Ubuntu UI Toolkit Gallery: reimplemented in a cleaner way the
    respo...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Pete Woods (pete-woods) on 2014-02-21
Changed in unity-action-api:
status: Fix Committed → Fix Released
Changed in hud:
status: Fix Committed → Fix Released
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in unity8:
status: New → In Progress
Albert Astals Cid (aacid) wrote :

We have removed the HUD from unity8 as of today so for now it doesn't make sense.

Changed in unity8:
assignee: Albert Astals Cid (aacid) → nobody
status: In Progress → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 2.9.1+14.04.20140331-0ubuntu1

---------------
camera-app (2.9.1+14.04.20140331-0ubuntu1) trusty; urgency=low

  [ Bill Filler ]
  * updated framework version
  * change check for desktopMode to use platform name rather than env
    var

  [ Pete Woods ]
  * Handle the HUD quit signal This change is only necessary for apps
    that don't use the UITK MainView (LP: #1269409)
 -- Ubuntu daily release <email address hidden> Mon, 31 Mar 2014 16:39:21 +0000

Changed in camera-app (Ubuntu):
status: New → Fix Released
Changed in camera-app:
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers