Issue when ejecting busy device from the Unity 2D Shell

Bug #997786 reported by Aurélien RIVIERE on 2012-05-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Plug an external device (e.g. USB stick)
2. Make it busy (e.g. go to it in a terminal)
3. Try to safe eject the device
   -> Verify the volume is busy dialog appears
   -> Verify there is no "Unity 2d Shell" tile in the launcher

[Regression Potential]
In the almost-impossible scenario the fix might prevent things that should show in the Launcher from showing. But since it's a very easy check, that's impossible to do.

Original description:

Ubuntu 12.10 64bits
Unity 2D 5.12

Insert a USB stick and make it busy (I opened a mp3 with RhythmBox (and the device was still busy after it was read but that'll be another bug)).
Ask Unity 2D to Eject the key. A popup appears for a confirmation.
Confirm, the popup is destroyed but respawn.
Cancel, the popup is destroyed but the Unity-2D-Shell icon appears in the Launcher.
Ask Unity-2D-Shell for quiting the launcher Unity-2D-Shell, Unity-2D-Shell quits and gnome-session doesn't relaunch it.
When I said quit, I meant the Launcher window was destroyed but the process remained active, and I needed to kill the process for gnome-session relaunch unity-2d-shell process.

I launched Unity-2D-Shell in a terminal and I get this when trying to umount the key :

unity-2d-shell: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-shell: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-shell: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-shell: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-shell: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-shell: [WARNING] GLib-GObject: invalid (NULL) pointer instance
unity-2d-shell: [CRITICAL] GLib-GObject: g_signal_handler_disconnect: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
unity-2d-shell: [CRITICAL] GLib-GObject: g_object_weak_unref: assertion `G_IS_OBJECT (object)' failed

Related branches

Albert Astals Cid (aacid) wrote :

Adding unity since it has the same problem that pressing "force eject" does nothing and the dialog loops forever.

Albert Astals Cid (aacid) wrote :

Removed unity, since the "force eject" does nothing is orthogonal to the problem that one can quit the shell from the launcher as described in this bug

no longer affects: unity
Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
milestone: none → 5.14
status: New → In Progress
Albert Astals Cid (aacid) wrote :

Fixed the fact that Unity-2d-shell appeared in the launcher and you could quit it. The fact that force ejecting a busy device does not work is not Unity-2d fault but somewhere in GIO, as it also happens in regular Unity. I suggest to open a new bug about it.

Changed in unity-2d:
status: In Progress → Fix Committed
description: updated
Gerry Boland (gerboland) on 2012-05-30
Changed in unity-2d:
milestone: 5.14 → 5.12.1
importance: Undecided → Medium
description: updated
Changed in unity-2d:
milestone: 5.12.1 → 5.14
Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d:
assignee: Albert Astals Cid (aacid) → nobody

Hello Aurélien, or anyone else affected,

Accepted unity-2d into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-2d/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-2d (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Tested the fix, the devices dialog appears correctly.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.14.0-0ubuntu1

---------------
unity-2d (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release (LP: #1060262):
    - [Launcher] [Multi-monitor] Removing a non running app tile from a
      launcher should remove it from all (LP: #988739)
    - Panel Titlebar double click is emitted for any mouse button (LP: #736491)
    - Launcher does not hide if shown while dragging a file (LP: #1002308)
    - icon isn't reset when clearing the search query (LP: #973225)
    - Issue when ejecting busy device from the Unity 2D Shell (LP: #997786)
    - Sticky edges don't work in RTL (LP: #984092)
    - pips are not correctly updated when plugin in a second monitor
      (LP: #1003943)
    - [dash] Unable to maximize (LP: #918648)
    - all panels have same window focus on multiple monitors unity2d
      (LP: #930147)
    - Dash will not open files under Greek folders (LP: #1002710)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - [panel] Invisible items in systray (LP: #703389)
    - [panel] Ignores "enabled" property on top-level menus (LP: #850017)
  * Reverted some quantal-specific commits which are no longer relevant
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 30 Oct 2012 09:59:49 +0100

Changed in unity-2d (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers