Launcher - When Launcher already has keyboard focus, Alt-F1 doesn't exit focus

Bug #885304 reported by Lohith D Shivamurthy on 2011-11-02
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
Low
Brandon Schaefer
Unity Distro Priority
Undecided
Unassigned
unity-2d
Low
Lohith D Shivamurthy
unity (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

How to repro:
1) Press Alt-F1 - Launcher is revealed, highlight(focus)ing the Dash Button.
2) Press Down Arrow - The next item in the launcher gets keyboard focus.
3) Press Alt-F1 again

Expected:
Pressing Alt-F1 again at any point should exit the Launcher keyboard navigation mode.

Actual:
Successive Alt-F1 key presses are ignored.

Related branches

Revision history for this message
Gerry Boland (gerboland) wrote :

Adding design to get clarification on behaviour.

tags: added: a11y
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
John Lea (johnlea) on 2011-11-03
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
Revision history for this message
Lohith D Shivamurthy (dyams) wrote :

@JohnLea
<<should exit the Launcher keyboard navigation mode.>>
Is the expected output is to toggle the keyboard focus on Alt-F1?
If not?
After second Alt-F1 how will the user gain the keyboard focus for launcher again?

Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
Changed in unity-2d:
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Bilal Shahid (s9iper1) wrote :

i confirm this issue in unity with oneiric i am able to reproduce this issue and one more this when we press alt+f1 then launcher appear and didn't hide while pressing esc, or clicking on the focused window, one more thing launcher feature dosen't work well for example like if we put the mouse to the last (down) of the launcher it automatically dosen't scroll down but when we scroll down on touchpad than it goes down mean scroll downward and after 1 mint or 2mint it become normal.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Revision history for this message
Gerry Boland (gerboland) wrote :

In conversation with John Lea, the matter is clarified as follows:

Pressing Alt+F1 will take keyboard focus from the active application, summon Launcher (if not visible already) and give it focus, which must always highlight the BFB button first.

Pressing Alt+F1 with the Launcher focussed will make it give away focus (back to application it stole it from). Launcher will slide out of view should it be obstructing a window, or remain on screen is not (as is usual behaviour).

Alt+F1 is essentially a toggle giving/releasing focus to the Launcher.

Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → In Progress
Gerry Boland (gerboland) on 2011-11-24
Changed in unity-2d:
importance: Medium → Low
John Lea (johnlea) on 2012-01-19
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
milestone: none → backlog
Didier Roche (didrocks) on 2012-01-20
Changed in unity:
milestone: backlog → 5.2.0
Changed in unity-distro-priority:
status: New → Fix Committed
Didier Roche (didrocks) on 2012-01-20
summary: - [launcher] When Launcher already has keyboard focus, Alt-F1 doesn't give
- focus to Dash Button
+ [launcher] When Launcher already has keyboard focus, Alt-F1 doesn't exit
+ focus
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: [launcher] When Launcher already has keyboard focus, Alt-F1 doesn't exit focus

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Gerry Boland (gerboland) on 2012-01-20
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
milestone: 5.2.0 → 5.4.0
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Tim Penhey (thumper) on 2012-02-13
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Tim Penhey (thumper) on 2012-02-16
Changed in unity:
milestone: 5.4.0 → 5.6.0
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Medium → Critical
summary: - [launcher] When Launcher already has keyboard focus, Alt-F1 doesn't exit
+ Launcher - When Launcher already has keyboard focus, Alt-F1 doesn't exit
focus
Revision history for this message
Doug McMahon (mc3man) wrote :

If this is considered a bug in unity (3d) then the likely possibility would be 'while holding Alt pressing F1 doesn't toggle keyboard focus on the launcher

Otherwise if the launcher already has keyboard focus, (Alt+F1, Alt released), then as soon as Alt is re- touched focus is removed , either going to Hud (tap) or last opened window/Desktop (press

Unless , 'when launcher already has keyboard focus tapping or pressing Alt should not remove focus'?

Revision history for this message
Omer Akram (om26er) wrote :

In precise now the situation looks different. Pressing alt-f1 and then just pressing alt would just exit from navigation.. (another bugs fixing this one :p)

Omer Akram (om26er) on 2012-02-21
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Changed in unity:
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2012-03-22
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-16
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-17
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers