panel 2D uses wrong width on multi monitor setup

Bug #880698 reported by Daniel Nyström on 2011-10-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Michał Sawicz
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

It seems like Unity 2D panel sets the width of the panel on non-first monitors according to the first monitor resolution, as illustrated in the attached screenshot.

It's four monitors with the following resolutions (starting from left):

1680x1050 - 1920x1080 - 1280x1024 - 1280x1024

NOTE! I'm using Xmonad as window manager and Xinerama (hence no randr) to enable four monitors on two Nvidia GPUs. But "Unity-2d-panel" is ignored by the window manager according to http://www.haskell.org/haskellwiki/Xmonad/Using_xmonad_in_Unity_2D.

Related branches

Daniel Nyström (speakman) wrote :
Riccardo Murri (rmurri) wrote :

I'm seeing the same bug, and I'm regularly using xrandr with two monitors: the laptop one and an external VGA monitor. Likely Xinerama is not relevant here.

Riccardo Murri (rmurri) wrote :

I'm attaching a patch that fixes the problem for me; it applies cleanly to BZR revno 750 (latest, at the time of writing) in the 4.0 series.

Might work for the 5.0/trunk series as well -- the code does not look much different in the affected areas.

Changed in unity-2d:
importance: Undecided → High
Daniel Nyström (speakman) wrote :

Shouldn't status be set Confirmed as well?

Daniel Nyström (speakman) wrote :

I've just tested the patch. It applies cleanly with current release (4.12.0-0ubuntu1.1) and works beatifully! Thanks for the submit!

Changed in unity-2d:
status: New → Confirmed
summary: - panel 2D uses wrong width on multi monitor setup (Xinerama)
+ panel 2D uses wrong width on multi monitor setup
tags: added: patch
Daniel Nyström (speakman) wrote :

Riccardo: Do you mind push a branch with the patch applied and request a merge?

Gerry Boland (gerboland) wrote :

Hey,
some work was done on this in revision 799 but was reverted as it caused more bugs. Thank you for the patch Riccardo, we will consider it closely.
-G

Hi Daniel, all,

2011/12/13 Daniel Nyström <email address hidden>:
> Riccardo: Do you mind push a branch with the patch applied and
> request a merge?
>

Just done.

Thanks,
Riccardo

Lohith D Shivamurthy (dyams) wrote :

Hey Daniel, Do you get this issue every time? Or Does it appear for any particular scenario? I just wonder how to reproduce this one.

Christoph Trassl (chtrassl) wrote :

I am having the same issue as Daniel, I also use the xmonad/unity-2d-panel setup Daniel linked to.

Although Gerry mentioned that Riccardo's patch triggered more bugs, I applied the patch (fuzzy) to revision 834 today and it still fixes our screen-width problem.

I would like to see this fixed in 12.04 final. What can I do to bring this forward? A new patch? What kind of problems were caused by Riccardo's patch in 799?

Christoph Trassl (chtrassl) wrote :

I tried another patch variant without using any additional events.

Unity2dPanel is instantiated by PanelManager, which knows about the screen each panel should go. I added the screen number to the Unity2dPanel constructor. In order to keep old behaviour it is only used once. Calling updateGeometry later on still uses desktop->screenGeometry(q).

At least in my xmonad setup i have to restart unity-2d-panel anyways when i change the screen layout.

The patched branch is here: lp:~chtrassl/unity-2d/fix-for-bug-880698

Changed in unity-2d:
status: Confirmed → Fix Committed
Christoph Trassl (chtrassl) wrote :

I can confirm that this bug is fixed for me with the screeninfo-merger, tested rev902.

Changed in unity-2d:
milestone: none → 5.4
assignee: nobody → Michał Sawicz (saviq)
Didier Roche (didrocks) on 2012-02-17
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers