Win Key can not be disabled in Unity-2d

Bug #873580 reported by Alex Wolfson on 2011-10-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Canonical Platform QA Team
unity-2d
High
Alberto Mardegan
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Summary: Win Key is not completely disabled in oneiric build on Unity-2d
Steps to reproduce:
On Unity 2d

1) Press <Super> + Any combination that works, especially numbers and "s".
Expected result: Nothing Changes
Actual result: <Super> + Combination works, as if <Super> is enabled, but shortcuts are not shown in a launcher

I tested oneiric only but looks like natty also has the same problem

Related branches

Alex Wolfson (awolfson) wrote :

https://code.launchpad.net/~unity-2d-team/unity-2d/launcher-conditional-super-key

has a commit

561. By Ugo Riboni on 2011-05-06
    Make all super key behavious conditional to a gconf key

This is when conversion to dconf happened:
-----------------------------------------------------------------------

unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)

 -- Didier Roche <email address hidden> Thu, 28 Jul 2011 12:05:38 +0200

On the SUT those settings are correct:
-------------------------------------------------------------------

gsettings get com.canonical.Unity2d.Launcher super-key-enable
false

Some tech info from Ugo highlighting a scope of the problem:
-----------------------------------------------------------------------------------------------------
I can give you some pointers on where to look in the code to start figuring out how to fix this issue. This is based on the natty version of the code I'm using for another project but I don't think there were many drastical changes to this part.

To see how to check if the dconf key is set or not, see for example the code in launcher/app/launcherview.cpp in the method updateSuperKeyMonitoring

To disable Super+Number you need to add this check in LauncherView::forwardNumericHotkey (just return immediately from the method if the check for the key say it's superkey is disabled)

Super+D is not related to unity-2d, I think it's controlled by metacity and respects the gconf key /apps/metacity/global_keybindings/show_desktop

For the other shortcuts that activate the various places (or lenses as they are called now): each place specify its own shortcut.
You can change (or remove them) in /usr/share/unity/places/ in the various .place files you find there.
(this last big may have changed in oneiric)

Changed in oem-priority:
importance: Undecided → High
description: updated
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Alberto Mardegan (mardy) on 2011-10-14
Changed in unity-2d:
status: New → In Progress
assignee: nobody → Alberto Mardegan (mardy)
Changed in unity-2d:
status: In Progress → Fix Committed
milestone: none → 4.14
importance: Undecided → High
Alex Wolfson (awolfson) wrote :

Alberto, Florian - Thanks a lot!
When 4.14 milestone is going to be released?

tags: added: sru
tags: added: sru-needed
removed: sru
Alex Wolfson (awolfson) wrote :

I just built it,using top of bzr and can confirm that it is indeed fixed

Changed in oem-priority:
status: New → Fix Committed
Changed in unity-2d:
milestone: 4.14 → 5.2
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers