unity-2d-launcher crashed with SIGSEGV in QScriptValue::engine()

Bug #855168 reported by maife michael da silva ferreira on 2011-09-20
This bug affects 10 people
Affects Status Importance Assigned to Milestone
unity-2d (Ubuntu)

Bug Description


ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Tue Sep 20 20:27:22 2011
ExecutablePath: /usr/bin/unity-2d-launcher
ProcCmdline: unity-2d-launcher
 PATH=(custom, no user)
 Segfault happened at: 0x2851334 <_ZNK12QScriptValue6engineEv+4>: mov (%eax),%eax
 PC (0x02851334) ok
 source "(%eax)" (0x726f273d) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-2d
 QScriptValue::engine() const () from /usr/lib/i386-linux-gnu/libQtScript.so.4
 ?? () from /usr/lib/i386-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/i386-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/i386-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/i386-linux-gnu/libQtDeclarative.so.4
Title: unity-2d-launcher crashed with SIGSEGV in QScriptValue::engine()
UpgradeStatus: Upgraded to oneiric on 2011-09-17 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

 data (this=0x726f273d) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:140
 qGetPtrHelper<QExplicitlySharedDataPointer<QScriptValuePrivate> > (p=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:2343
 d_func (this=0x726f273d) at api/qscriptvalue.h:211
 QScriptValue::engine (this=0x726f273d) at api/qscriptvalue.cpp:1824
 QDeclarativeObjectScriptClass::newQObject (this=0x9526978, object=0x9cff870, type=136) at qml/qdeclarativeobjectscriptclass.cpp:122

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Critical
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
importance: Medium → Critical
madbiologist (me-again) wrote :

Official support for Ubuntu 11.04 "Natty Narwhal" has ended. If this error is still occurring on Ubuntu 14.10 "Utopic Unicorn" please run ubuntu-bug to file a new bug report so that we can get a fresh set of log files and system information.

Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers