Unity-2d no panel after cancel logout due to not responding app

Bug #849379 reported by Colin Law on 2011-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Gerry Boland
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

If an attempt is made to logout with an application not responding then a message is displayed indicating this, with an option to cancel the logout. If cancel is pressed then one is stuck with no top panel.
The problem is not seen on Unity-3D

As of this date this can be replicated easily by starting tomboy then attempting to logout, as it has a bug which causes it to not respond when attempting to log out.

Related branches

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
milestone: none → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Gerry Boland (gerboland) on 2011-09-19
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Colin Law (colin-law) wrote :

I am still seeing a very similar issue, though possibly it is a different bug.
Using Unity-2d from ppa 4.14-0ubuntu1~bzr777.
To replicate:
Open LibreOffice and type something in, do not save.
Initiate a logout.
LibreOffice pops up a save or discard dialog and a warning appears that there is an app still running, with an option to cancel.
Select Cancel (on either dialog) and the panel and launcher do not re-appear.

For the record, to recover from this, Ctrl+Alt+Delete allows the logout to continue.

Gerry Boland (gerboland) wrote :

@Colin: please set the bug to reopened if you think this bug isn't fixed.

I'm doing bookwork setting this bug to Fix Released right now. It's not a slight on you :)

Changed in unity-2d:
status: Fix Committed → Fix Released
Colin Law (colin-law) on 2011-11-14
Changed in unity-2d:
status: Fix Released → Incomplete
Colin Law (colin-law) wrote :

I can no longer replicate this in 11.10 or 12.04 Beta so setting to Fix Released.

Changed in unity-2d:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers