unity-2d-panel segfault switching between single and dual screens

Bug #848944 reported by Colin Law on 2011-09-13
496
This bug affects 83 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Michał Sawicz
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Using unity-2d from daily ppa version 4.8-0ubuntu1~bzr716 if I start with two screens, unplug one and plug it back in immediately after it switches to single screen but before the panel has been redrawn then sometimes I end up with no panel at all. dmesg shows the output below (this may be the result of several screen switches as it took a few goes to get it to fail). Let me know if there is anything else that may be useful. I do not know whether this is a new symptom or whether it is to do with recent upgrades.

[ 743.876856] show_signal_msg: 18 callbacks suppressed
[ 743.876863] unity-2d-panel[3544]: segfault at f845ffa5 ip 056a6f08 sp bfd649ac error 5 in libc-2.13.so[5638000+176000]
[ 828.417599] unity-2d-panel[4104]: segfault at d107c335 ip 00528f08 sp bfddeb3c error 5 in libc-2.13.so[4ba000+176000]
[ 886.935720] unity-2d-panel[4218]: segfault at 39f51415 ip 076bcf08 sp bf87ebbc error 4 in libc-2.13.so[764e000+176000]
[ 888.844492] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 8
[ 888.844497] Raw EDID:
[ 888.844501] <3>00 ff ff ff ff ff ff 00 41 0c 11 c0 81 94 06 00 ........A.......
[ 888.844504] <3>26 0f 01 03 1f 22 1b 78 ee 1f f5 a4 57 47 9d 24 &....".x....WG.$
[ 888.844507] <3>13 50 54 bf ef 80 81 80 01 01 01 01 01 01 01 01 .PT.............
[ 888.844510] <3>01 01 01 01 01 01 30 2a 00 98 51 00 2a 40 30 70 ......0*..Q.*@0p
[ 888.844513] <3>13 00 52 0e 11 00 00 1e 00 00 00 ff 00 20 42 5a ..R.......... BZ
[ 888.844515] <3>20 20 34 33 31 32 3b 33 0a 20 00 00 00 fc 00 50 4312;3. .....P
[ 888.844518] <3>68 69 6c 69 70 73 20 31 37 30 43 0a 00 00 00 fd hilips 170C.....
[ 888.844521] <3>00 38 4c 1e 53 0e 00 0a 20 20 20 20 20 20 00 df .8L.S... ..
[ 888.844523]
[ 928.892683] unity-2d-panel[4552]: segfault at 894da1cd ip 00456f08 sp bfc4923c error 4 in libc-2.13.so[3e8000+176000]
[ 1002.704998] unity-2d-panel[4724]: segfault at 8996304d ip 07d53f08 sp bfe44eec error 4 in libc-2.13.so[7ce5000+176000]
[ 1028.542372] unity-2d-panel[4862]: segfault at d123be8f ip 006c4f17 sp bf9186ac error 5 in libc-2.13.so[656000+176000]
[ 1167.316188] unity-2d-panel[5055]: segfault at c8b8848d ip 00506f08 sp bfa738ac error 5 in libc-2.13.so[498000+176000]
[ 1193.381080] unity-2d-panel[5113]: segfault at e98ebcbd ip 06119f08 sp bfd10fac error 5 in libc-2.13.so[60ab000+176000]
[ 1323.593331] unity-2d-panel[5405]: segfault at 8038a1d5 ip 0041af08 sp bf8a8fac error 4 in libc-2.13.so[3ac000+176000]
[ 1359.473681] unity-2d-panel[5599]: segfault at ca1e97ad ip 06e22f08 sp bf86647c error 5 in libc-2.13.so[6db4000+176000]

Related branches

Can't you install debug symbols, please?

However I'm wondering if this is a duplicate of bug #846836

Colin Law (colin-law) wrote :

Having done some more testing it seems that it not timing related as I first thought. It happens maybe one time in five when I unplug the second screen.
Can you tell me how to install debug symbols please, I am using the daily build ppa and don't see a -dbg package.

Colin Law (colin-law) wrote :

Removing the suggestion that this is a duplicate of bug #846836 as I am now using unity-2d 4.8.0-0ubuntu1 and still see the problem. I have reverted to the standard repository so that I have debug symbols and when I unplug the second screen I see, in dmesg
unity-2d-panel[9053]: segfault at 20b1e57d ip 00582f08 sp bf98209c error 4 in libc-2.13.so[514000+176000]
I will install debug symbols and report the result.

Colin Law (colin-law) wrote :

Does this help? I appear to have managed to get a backtrace (the first time I have done this). I am not sure whether it contains what is needed. Let me know if I need to do more.

Changed in unity-2d:
importance: Undecided → Critical
Changed in unity-2d:
milestone: none → 4.10
Changed in unity-2d:
assignee: nobody → Michał Sawicz (saviq)
Changed in unity-2d:
status: New → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.