Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run command' screen

Bug #847486 reported by Péter Trombitás on 2011-09-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Gerry Boland
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Oneiric in VirtualBox, so these might cause the problem, but it still exsist. If I want to run a command, I usually press Alt+F2. But I don't get the 'Run command' screen every times. I get the Dash with no category selected (see the screenshot I submitted). Sometimes everything just works fine.
The problem occured in Unity 2D since that's the only one that runs on my laptop. But it might also be a problem in normal Unity.

Related branches

Omer Akram (om26er) on 2011-09-15
affects: unity → unity-2d
Changed in unity-2d:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 4.10
Gerry Boland (gerboland) on 2011-09-16
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
status: Confirmed → In Progress
Gerry Boland (gerboland) on 2011-09-16
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → nobody
Gerry Boland (gerboland) on 2011-09-16
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Eugene San (eugenesan) wrote :

Issue still exists in 4.12.0-0ubuntu1

Usually first time alt-f2 pressed, second time it works.

Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers