[dash] DropShadow on "See X more results" can cause visual errors on scroll

Bug #843820 reported by Gerry Boland on 2011-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Gerry Boland
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

I see visual distortion from the DropShadow on the "See X more results" text when I place the mouse cursor over this text, and use the mouse wheel to scroll. See screenshot.

Steps to Repro
1. Open Dash, select "Media Apps"
2. Place your mouse over the "See X more results" text of the group header. It will get a nice white DropShadow.
3. Use the mouse wheel to scroll, keeping the mouse cursor from moving.

Possible Result:
I can obtain visual distortion from the DropShadowed text. Depends on the items above & below, in case something paints over it or not. See screenshot.

Related branches

Gerry Boland (gerboland) wrote :
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → In Progress
Changed in unity-2d:
milestone: none → 4.6
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers