unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD

Bug #831868 reported by Jean-Baptiste Lallement on 2011-08-23
260
This bug affects 31 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Unassigned
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

Oneiric Desktop amd64.

Crashed during a live session.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-launcher 4.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.13-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CasperVersion: 1.279
Date: Tue Aug 23 09:25:47 2011
ExecutablePath: /usr/bin/unity-2d-launcher
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110823)
ProcCmdline: unity-2d-launcher
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f6e0911a295: cmp 0x28(%rbx),%rdi
 PC (0x7f6e0911a295) ok
 source "0x28(%rbx)" (0x00000211) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-2d
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtDeclarative.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
Title: unity-2d-launcher crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Jean-Baptiste Lallement (jibel) wrote :
visibility: private → public

StacktraceTop:
 QDeclarativePropertyCache::property (engine=<optimized out>, obj=0x2805bd0, name=@0x7fff63ce3148, local=...) at qml/qdeclarativepropertycache.cpp:398
 QDeclarativeObjectScriptClass::queryProperty (this=0x1f6ef40, obj=<optimized out>, name=@0x7fff63ce3148, flags=<optimized out>, evalContext=0x0, hints=...) at qml/qdeclarativeobjectscriptclass.cpp:167
 QDeclarativeObjectScriptClass::queryProperty (this=0x1f6ef40, object=<optimized out>, name=@0x7fff63ce3148, flags=<optimized out>) at qml/qdeclarativeobjectscriptclass.cpp:147
 QScript::DeclarativeObjectDelegate::getOwnPropertySlot (this=0x2a1a890, object=0x7f6df969ef00, exec=0x7f6df970c108, propertyName=..., slot=...) at bridge/qscriptdeclarativeobject.cpp:74
 fastGetOwnPropertySlot (slot=..., propertyName=..., exec=0x7f6df970c108, this=0x7f6df969ef00) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSObject.h:382

Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
Martin Pitt (pitti) on 2011-08-23
tags: removed: need-amd64-retrace
Changed in unity-2d:
importance: Undecided → Critical
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
milestone: none → 4.4
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
milestone: 4.10 → none
Changed in unity-2d (Ubuntu):
importance: Medium → Critical

Bug #814749 has a much more complete stacktrace.
Bug #755907 indicates that the bug is fairly old (it exists at least since 2011-04-10).

summary: - unity-2d-launcher crashed with SIGSEGV
+ unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
Florian Boucault (fboucault) wrote :

Bug #801161 has an interesting description of the circumstances of the crash.

Changed in unity-2d:
milestone: none → 4.10
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
milestone: 4.10 → 4.12
Michał Sawicz (saviq) wrote :

I can't reproduce this or any of the duplicates installed or live (today's daily, both i386 and amd64) in a VM, will try again natively. If anyone else can still reproduce, pray tell!

Dmitry Shachnev (mitya57) wrote :

Bug 853313 says that there was no logout/settings indicator («power cog») at the time of crash.
Now I remember that there was lack of it in my case too. (But I'm not sure if it's related to this crash).

The apport-retraced stack trace in duplicate bug 801161 doesn't look (to me) very much like the apport-retraced stack trace here. Are they perhaps not really the same bug?

Changed in unity-2d:
milestone: 4.12 → 4.14
Gerry Boland (gerboland) wrote :

Can anyone still reproduce this bug? If so, please say.

Changed in unity-2d:
milestone: 4.14 → 5.2

I can't reproduce this crash anymore and there's no recent duplicate. I'm closing this report.

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.