[panel] indicators are shifted offscreen to the right

Bug #827673 reported by Aritchie on 2011-08-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Ugo Riboni

Bug Description

Ok guys, it did not start doing this until after I installed the 3.8.16-0ubuntu1~bzr673 (unity-2d) and 0.2.3~bzr54 (libqtdee2) update. It happens after I put the mouse over the panel to bring up the menu and then remove the mouse from the panel to bring the title back. The icon is still there, it just gets shifted to the right off screen. This is Ubuntu 11.04. It gets worse with further usage.

Related branches

Aritchie (aritchie) wrote :
Aritchie (aritchie) wrote :

Here is another screen shot.

Aritchie (aritchie) wrote :

I forgot to mention this is the version of compiz I am using:

1:0.9.4+bzr20110606-0ubuntu1~natty2 (compiz-core)

Aritchie (aritchie) wrote :

Have conducted some more tests. So far it seems like it only exhibits this behavior when the window is maximized.

Aritchie (aritchie) wrote :

I used Firefox 5 and Thunderbird 6 for testing.

Aritchie (aritchie) wrote :

Hmm, interesting. I tested it with Terminal, Banshee and Nautilus and it does not exhibit this behavior at all. So far only with Firefox 5 and Thunderbird 6.

Aritchie (aritchie) wrote :

Well I have tested some more apps - Text Editor, Ubuntu One, Ubuntu Software Center and they all work fine. It looks like it is just Firefox 5 and Tbird 6 that does this when you maximize their windows.

Also with Chrome 13.0.782.112

Olivier Tilloy (osomon) wrote :

I can also observe this issue. This is since I upgraded this morning from 3.8.16-0ubuntu1~bzr672 to 3.8.16-0ubuntu1~bzr673, so the revision that caused this regression is easy enough to spot…

I don’t see the icons being shifted more than they initially are, that is the situation doesn’t get worse with time or user interaction.

summary: - Panel icon shift
+ [panel] indicators are shifted offscreen to the right
Changed in unity-2d:
status: New → Confirmed
Ugo Riboni (uriboni) on 2011-08-17
Changed in unity-2d:
assignee: nobody → Ugo Riboni (uriboni)
status: Confirmed → In Progress
Ugo Riboni (uriboni) on 2011-08-17
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
milestone: none → 4.2
importance: Undecided → High
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers