[panel] application menus do not appear on first hover after dismissal

Bug #825262 reported by Alberto Mardegan on 2011-08-12
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Alberto Mardegan

Bug Description

Reproduced in Oneiric:

- Open any application which has a menu (e.g., Terminal)
- Open any of the application menus
- Move the mouse pointer outside of the menu (not on the panel, just downwards for instance)
- Press the mouse button => the menu is dismissed
- Move the mouse pointer to the application title in the panel

Expected outcome: the menu bar is shown
Actual outcome: the menu bar is not shown (the panel still displays the application title).

Note: if you move the mouse pointer outside of the panel and in again, the menu bar is shown.

I believe that the root cause might be the same one as of bug 825060.

Related branches

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Aurélien Gâteau (agateau)
milestone: none → 4.2
Alberto Mardegan (mardy) on 2011-08-23
Changed in unity-2d:
assignee: Aurélien Gâteau (agateau) → Alberto Mardegan (mardy)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers