Dash - If mouse highlights one icon in grid, keyboard navigation highlights another, so there are 2 highlighted icons

Bug #817436 reported by Gerry Boland on 2011-07-28
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Andrea Azzarone
unity-2d
Medium
Unassigned
unity (Ubuntu)
Undecided
Andrea Azzarone
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

As of commit 651.

Steps to Reproduce
--------------------------------
1. Open the Dash App Lens (or any other Dash Lens)
2. Use the cursor keys to select a app
3. Move the mouse pointer over a different app

Current incorrect result
-------------------------------
- Two app icons are highlighted. This is confusing.
- With one icon selected with the keyboard, you can move the mouse to highlight other icons.

Desired Correct Result
-------------------------------
- Only one icon at a time should be highlighted.
- Moving the pointer over a icon changes the focus, so a user can move the focus first with the pointer, and then continue moving the focus using the cursor arrow keys.

Related branches

Gerry Boland (gerboland) wrote :
Changed in unity-2d:
importance: Undecided → Low
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)

After some research I discovery that: the buttom background used to state "hovered" and "selected" is the same, and because of that you see more than one button selected, but the real situation is that only one button is selected the other one has the sate of "hovered".

I saw 3 options here to solve the problem:

1 - Not draw the background when the mouse is over the button (in hovered state).
2 - Create a new image/effect to be used when the button is in "hovered" state
3 - Change the state of button to selected when move the mouse over the button (I do not like this option)

Michał Sawicz (saviq) wrote :

I can see two possible approaches:
* remove the "hovered" highlight for keyboard navigation and remove "selected" for pointer navigation (i.e. mouse moved onto another selection) is used;
* make keyboard navigation start from last mouse hover;

I'd vote for the latter, as that's consistent with the rest of the desktop - whenever you e.g. enter a menu entry, the selection is set to that entry, keyboard navigation starts from there and subsequent mouse enters (not hovers, mind you, although I'm not sure that's on purpose) again change the selection.

Michał Sawicz (saviq) on 2011-10-18
tags: added: needs-design
John Lea (johnlea) on 2011-10-19
description: updated
tags: added: udp
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
description: updated
description: updated
Changed in unity:
status: New → Confirmed
milestone: none → backlog
summary: - [dash] If mouse highlights one icon in grid, keyboard navigation
+ Dash - If mouse highlights one icon in grid, keyboard navigation
highlights another, so there are 2 highlighted icons
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
status: New → Confirmed
Mirco Müller (macslow) on 2011-11-01
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
John Lea (johnlea) on 2011-11-01
Changed in ayatana-design:
status: Triaged → Fix Committed
Andrea Azzarone (azzar1) wrote :

@John

« - Only one icon at a time should be highlighted.
 - Moving the pointer over a icon changes the focus, so a user can move the focus first with the pointer, and then continue moving the focus using the cursor arrow keys.
»

When this should happen? When we're already in keyboard navigation state?

John Lea (johnlea) wrote :

@andyrock;

This should happen at any time. New pointer movement moves the focus to the pointer's current location, and new cursor key presses move the focus from it's current position (irrespective of whether the focus arrived at it's current position as a result of keyboard navigation or pointer movement). So there should be no 'keyboard navigation' or 'pointer navigation' state, a user should be able to mix and match the two.

Does that answer your question?

Andrea Azzarone (azzar1) wrote :

@johnlea

So this is the same behaviour of gtk menus...

By the way according to me it's a bad idea to use it because in Unity Dash we have a text entry, and with a text entry a user expects that Key Right/Left move the cursor in the text entry (if the text entry has the focus of course).

Andrea Azzarone (azzar1) on 2012-02-19
Changed in unity:
assignee: Gord Allott (gordallott) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: backlog → 5.6.0
Andrea Azzarone (azzar1) on 2012-02-20
Changed in unity:
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
importance: Low → Medium
milestone: none → 5.6
Andrea Azzarone (azzar1) on 2012-02-21
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Changed in unity-2d:
assignee: Renato Araujo Oliveira Filho (renatofilho) → nobody
Didier Roche (didrocks) on 2012-04-27
Changed in unity-2d:
milestone: 5.12 → 5.14
Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
Andrea Azzarone (azzar1) on 2012-07-11
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
John Lea (johnlea) on 2012-07-11
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesign reviewedbydesignp
removed: udp
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers