[launcher] contextual menus are not spoken by the Orca screen reader

Bug #817416 reported by Florian Boucault on 2011-07-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Michał Sawicz
qt4-x11 (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:

0. Launch unity-2d-launcher with QT_ACCESSIBILITY=1 and the orca screen reader
1. Press Alt+F1; it should focus the first item of the launcher
2. Select an item that has many contextual menu entries
3. Press right arrow key; the contextual menu should open
4. Press down arrow key multiple times

Expected result:

The menu entries are spoken to you.

Current result:

Orca keeps repeating the name of the application.

Changed in unity-2d:
importance: Undecided → Medium
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Medium → High
milestone: none → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) wrote :

I've filed a bug in Qt that I think is the cause of this https://bugreports.qt.nokia.com/browse/QTBUG-21578

Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
milestone: 4.10 → 4.12
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-09-26
affects: unity-2d (Ubuntu) → qt4-x11 (Ubuntu)
Michał Sawicz (saviq) on 2011-09-26
Changed in unity-2d:
status: In Progress → Invalid
Didier Roche (didrocks) on 2011-09-26
Changed in unity-2d:
status: Invalid → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qt4-x11 - 4:4.7.4-0ubuntu4

---------------
qt4-x11 (4:4.7.4-0ubuntu4) oneiric; urgency=low

  [ Felix Geyer ]
  * Move documentation building to override_dh_auto_install where
    dh_listpackages works as expected with dpkg-buildpackage. (LP: #857377)

  [ Didier Roche ]
  * debian/patches/fix_accessible_menu.diff:
    - Contextual QMenu accessible now (LP: #817416)
  * debian/patches/kubuntu_94_xinput_valuators_fix.diff:
    - wacom stylus jumps with latest xserver-xorg-core (LP: #799202)
 -- Didier Roche <email address hidden> Mon, 26 Sep 2011 09:28:36 +0200

Changed in qt4-x11 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers