[dash] preferred applications are not stored in GConf anylonger

Reported by Michael Moroni on 2011-07-03
50
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
High
Neil J. Patel
unity-2d
Critical
Florian Boucault
unity-2d (Ubuntu)
Critical
Florian Boucault
Oneiric
Critical
Florian Boucault
unity (Ubuntu)
High
Neil J. Patel
Oneiric
High
Neil J. Patel

Bug Description

Preferred applications are not stored in GConf anymore. Instead they are stored in ~/.local/share/applications/mimeapps.list. There is a GLib API to access it:

http://developer.gnome.org/gio/stable/GAppInfo.html#g-app-info-get-default-for-type

Example in Python:
import gio
gio.app_info_get_default_for_type("x-scheme-handler/mailto", False)

The types for default applications are defined in gnome-control-center's function info_panel_setup_default_apps in panels/info/cc-info-panel.c

The 4 types we are interested in are:
- web browser: x-scheme-handler/http
- mail client: x-scheme-handler/mailto
- music player: audio/x-vorbis+ogg
- photo manager: image/jpeg

Only the first 2 are defined and used in Natty:

Natty and Oneiric
x-scheme-handler/http
x-scheme-handler/mailto

Oneiric only
audio/x-vorbis+ogg
image/jpeg

Michael Moroni (airon90) wrote :
description: updated
tags: added: oneiric
Changed in unity-2d:
importance: Undecided → High
summary: - Unity 2D doesn't honour my preferences about preferred applications
+ [dash] preferred applications have migrated to dconf
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 3.8.12
importance: High → Critical
Changed in unity-2d (Ubuntu Oneiric):
importance: Undecided → Critical
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
status: Confirmed → In Progress
summary: - [dash] preferred applications have migrated to dconf
+ [dash] preferred applications are not stored in GConf anylonger
description: updated
Florian Boucault (fboucault) wrote :

Preliminary implementation works but monitoring changes fails because of what seems to be a bug in gio (see FIXME in GioDefaultApplication)

David Barth (dbarth) on 2011-07-20
Changed in unity:
milestone: none → 4.4.0
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
status: New → Triaged
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu Oneiric):
status: New → Triaged
Didier Roche (didrocks) on 2011-07-20
Changed in unity-2d (Ubuntu Oneiric):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
David Barth (dbarth) on 2011-07-22
Changed in unity-2d (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Florian Boucault (fboucault)
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → oneiric-alpha-3
Changed in unity-2d (Ubuntu Oneiric):
milestone: none → oneiric-alpha-3
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu Oneiric):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Martin Pitt (pitti) on 2011-08-26
Changed in unity (Ubuntu Oneiric):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
David Barth (dbarth) on 2011-08-26
Changed in unity:
milestone: 4.8.0 → 4.12.0
Neil J. Patel (njpatel) on 2011-08-31
Changed in unity:
status: Triaged → Fix Committed
Omer Akram (om26er) on 2011-09-01
Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.12.0-0ubuntu1

---------------
unity (4.12.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - P3: [natty] Cannot click on indicators (LP: #819202)
    - Icons not visible in the launcher or alt-tab switcher (LP: #833905)
    - [dash] Search field in Unity can not support iBus (LP: #663776)
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - SysTray icons have a white square background in Unity. (LP: #823407)
    - new dash does not fit a normal netbook screen (LP: #825370)
    - Dash picks random weird colors (yellow, green), fonts invisible (with
      blur en- or disabled) (LP: #828363)
    - Music Lens doesn't display items until you search (LP: #824892)
    - Dash - Adjustments to stateful behaviour (LP: #838667)
    - Dragging from dash to launcher still doesn't work (LP: #824833)
    - Click on 'More Apps' et al closes the dash (LP: #824842)
    - cannot paste into dash (particularly relevant for alt+f2) (LP: #736222)
    - Ctrl X doesn't cut selected text in Dash search field (LP: #737731)
    - Ctrl+C doesn't copy selected text in Dash search field (LP: #737732)
    - The indicators shows a big white square when systray whitelisted
      (LP: #822672)
    - ARM FTBFS fix (LP: #834576)
  * debian/control:
    - build on latest nux
  * debian/rules:
    - bump shlibs
 -- Didier Roche <email address hidden> Thu, 01 Sep 2011 17:33:06 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.