[panel] F10 shortcut with dual screens shows menus on both screens

Bug #777995 reported by Colin Law on 2011-05-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Using unity-2d 3.8.4.1-0ubuntu2~bzr558 from daily build ppa on Ubuntu 11.04 on a PC with dual monitors (in extended desktop mode), F10 shows dropdown menus on both screens.

Olivier Tilloy (osomon) on 2011-05-06
summary: - F10 shortcut with dual screens shows menus on both screens
+ [panel] F10 shortcut with dual screens shows menus on both screens
Changed in unity-2d:
status: New → Confirmed
tags: added: accessibility shortcuts
Changed in unity-2d:
importance: Undecided → Medium
tags: added: a11y
removed: accessibility
Colin Law (colin-law) wrote :

Also Alt-letter combinations such as Alt-F to show File menu does the same thing (menu shown on both screens). Is this the same bug?

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 4.4
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity-2d:
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) wrote :

I can't reproduce that here, @Colin can you confirm that it's still happening for you?

Colin Law (colin-law) wrote :

No I cannot reproduce this any more. However I do see other problems with F10. I have not looked to see whether these are already reported as separate bugs.
1. The only app I can find that F10 works for is Firefox. With Nautilus and gedit for example F10 does nothing (it works on Unity-3D).
2. With FF in dual screen mode F10 pops up the menu but the first time it pops up it is usually half way down the screen on the left hand side. Sometimes this recovers after a couple of goes. Clicking off to a different app and back to FF seems to cause the problem to re-appear.

Michał Sawicz (saviq) wrote :

Yeah, so, 1. is most probably bug #849732, 2. is not limited to dual screen. Thanks!

Changed in unity-2d:
assignee: Michał Sawicz (saviq) → nobody
Michał Sawicz (saviq) wrote :

I just reported bug #853766, @Colin please subscribe to it and mark it that it affects you, too.

Michał Sawicz (saviq) on 2011-09-19
Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers