[panel] F10 shortcut does not show application menu

Bug #777993 reported by Colin Law on 2011-05-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Aurélien Gâteau
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Using unity-2d 3.8.4.1-0ubuntu2~bzr558 from daily build ppa on Ubuntu 11.04, If an application menu is not already visible when F10 is hit, the main menu is not shown. Only the dropdown from the first item on the main menu is shown.
In addition, even if the menu is shown before hitting F10, right arrow (for example) shows the next dropdown but selects the top item on that dropdown so another right arrow does nothing (or moves into the next submenu if there is one). Perhaps this should be a separate bug.

Related branches

Olivier Tilloy (osomon) on 2011-05-06
summary: - F10 shortcut does not show application menu
+ [panel] F10 shortcut does not show application menu
Changed in unity-2d:
status: New → Confirmed
tags: added: shortcuts
tags: added: accessibility
Changed in unity-2d:
importance: Undecided → High
tags: added: a11y
removed: accessibility
tags: added: delta-with-3d
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
milestone: none → 3.8.12
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → Aurélien Gâteau (agateau)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Colin Law (colin-law) wrote :

How quickly after a bug goes to Fix Released should I see the fix in the daily ppa (Natty)? I updated at 0800 UTC 30th July and got version 3.8.12-0ubuntu1~bzr657 but I am not seeing this bug fixed. In fact since this I am using the Daily Build ppa should I not see the fix after the next build following Fix Committed?

Colin Law (colin-law) wrote :

I am still not seeing this working, it appears to be unchanged from the original bug report though the fix was released 4 days ago and there have been several updates since then. Am I just too impatient? If so then apologies for the noise.
Using Unity-2d 3.8.12-0ubuntu1~bzr658

Gerry Boland (gerboland) wrote :

Hey Colin,
you're not impatient, it's great to see people looking out for these usability issues.

Unfortunately the fix applies only to the daily PPA for Oneiric. It's not in Natty due to fix using parts of GTK3, which Natty doesn't support. I'm not sure how we'll approach this yet.

Colin Law (colin-law) wrote :

Is the status Fix Released correct in that case? Does it need a separate status for Natty? Otherwise it appears as if it is all done and dusted.

Florian Boucault (fboucault) wrote :

@Colin: I don't really know how to handle that without a massive amount of work: from now on most bug fixes will/might not be backported to the natty PPA. It would be awesome to be able to say in an automatic way: this version (branch) has the bug fix but not this one.

Colin Law (colin-law) wrote :

Would it be possible to at least add a note when the fix is committed that it is not being fixed for Natty? It would be better if it were possible to have a Unity-2d (Natty) project (or whatever the right word is) in Launchpad so the status could be set to Fix Released for Unity-2d and Won't Fix for Unity-2d (Natty). If that is indeed the situation.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers