Keyboard shortcut - Make Unity keyboard shortcuts configurable

Bug #775434 reported by László Monda on 2011-05-02
242
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Unassigned
7.2
High
Unassigned
unity-2d
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Currently Unity provides about two dozen keyboard shortcuts which are completely hardcoded.

It is essenetial from a productivity standpoint for the user to be able to configure any of those. It was possible with Metacity / Compiz through the Keyboard Shortcuts window. The same interface could be used for Unity for updating its configuration and possibly featuring few Unity-specific keybindings.

------------------------

Desired resolution:

- All the unity keyboard shortcuts (defined in the following document, https://docs.google.com/a/canonical.com/document/d/1jqeKtIJwqLtl58Wk_fqjr9Rrgxn9zsouCYOo-cZsLSE/edit?hl=en_GB ) should be present and configurable using the 'Keyboard/Shortcuts' panel in 'System Settings'
- Any keyboard shortcuts that are not supported by Unity should be removed.

Review the following keyboard shortcut bugs before fixing this bug:
- F10 shortcut is used to show menu and this is wrong (bug #878492)
- Ctrl Alt Del doesn't do what most people typing it would expect (bug #890747)
- Unity window placement shortcuts require a numpad (bug #751050)
- Add keyboard shortcut hint overlay that is displayed when a user presses and holds the Super key (bug #855532)
- The grid keybindings are behaving inconsistently (bug #878820)
- Make Unity keyboard shortcuts configurable (bug #775434)
- Shortcuts need to updated as part of the 12.04 upgrade (bug #891757)
- Unity should also use Super-L to lock screen by default (bug #830709)
- Improvements to Launcher reveal when Super is pressed behaviour (bug #905342)

Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
Alex Launi (alexlauni) on 2011-05-02
Changed in unity:
status: New → Invalid
status: Invalid → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
tags: added: needs-design
sirovsky (david-sirovsky) wrote :

Totally agree, and it is not simply a "nice-to-have" feature.

For example, it is simply impossible to work with a Windows Guest OS as a virtual Machine (e.g. in VirtualBox),
all Win-Key Windows OS key-combinations are hijacked by Unity!

Though it seems to be configurable in compizconfig-settings-manager ("Key to Show the Launcher") - changing it does not seem to have any effect.

Chad Furman (chadthefurman) wrote :

Certainly not a "wish-list" feature. Removing customizations removes desireability. If I have a keyboard shortcut set a certain way on a work machine, and then have to adjust to a "hard-coded" keybinding on my home machine, it decreases productivity.

Dmitry Kann (yktooo) wrote :

I have no idea why it was considered Incomplete, set it to Confirmed.
Fully agree that hardcoded shortcuts is a very poor practice.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed

@yktooo; was set to incomplete as it had not yet been reviewed by design. Bug has now been reviewed and status set accordingly ;-)

summary: - Make Unity keyboard shortcuts configurable
+ Keyboard shotcut - Make Unity keyboard shortcuts configurable
description: updated
tags: added: udp
removed: needs-design
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
importance: Wishlist → Undecided
milestone: none → backlog
John Lea (johnlea) on 2011-12-12
description: updated
Omer Akram (om26er) on 2011-12-12
Changed in unity:
importance: Undecided → Medium
importance: Medium → High
Changed in unity (Ubuntu):
importance: Wishlist → High
John Lea (johnlea) on 2011-12-12
tags: added: keybinding
description: updated
John Lea (johnlea) on 2011-12-13
description: updated
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - Make Unity keyboard shortcuts configurable
+ Keyboard shortcut - Make Unity keyboard shortcuts configurable
John Lea (johnlea) on 2011-12-16
description: updated
Tim Penhey (thumper) on 2012-02-07
Changed in ayatana-design:
status: Triaged → Fix Committed
Tim Penhey (thumper) on 2012-02-07
Changed in unity:
status: Confirmed → Triaged
importance: High → Medium

I have to say this seems to be a pretty significant problem, and it's a bit discouraging not to have seen this change already:

- For users with a non-standard number of fingers (or decreased flexibility, or other relevant condition), this is an accessibility issue; it's the difference between having this feature be useful and having the shortcuts being irrelevant.

- For users with uncommon types of keyboard, or an extra layer between the hardware and OS (such as a virtual machine, mentioned above), this is not a wishlist feature. It's a portability issue.

- Keyboard shortcut customizability is present in most other desktop environments for Linux. So it should not be in any sense a surprise that some people would want to be able to change these.

Gerry Boland (gerboland) on 2012-05-07
Changed in unity-2d:
status: New → Triaged
Changed in unity-2d (Ubuntu):
status: New → Triaged
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-12
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Medium → High
no longer affects: unity-2d (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
MC Return (mc-return) wrote :

I got the fix for "The grid keybindings are behaving inconsistently (bug #878820)" now :)

Rob King (jking) wrote :

There's also the issue that not all keyboards have a Windows or Super key - the classic IBM 101 key layout for example. You can still buy keyboards (USB keyboards!) with this layout. Not being able to remap the launcher/dash keyboard shortcut basically means I don't use it and don't get any of the benefits.

Hans Ginzel (hans-matfyz) wrote :

Is there a way to check if the keyboard has Super and Menu key? Yes, consider keyboards without them.

Stephen M. Webb (bregma) on 2013-11-01
Changed in unity-2d (Ubuntu):
status: Confirmed → Won't Fix
Changed in unity-2d:
status: Triaged → Won't Fix
Changed in unity:
milestone: none → 7.2.0
description: updated
Marcos Alano (mhalano) wrote :

Any news about this bug?

Stephen M. Webb (bregma) on 2014-04-15
Changed in unity:
milestone: 7.2.0 → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Download full text (3.8 KiB)

KSM

As someone who has just changed from Mac OS X to Ubuntu I want to add two or three words to this issue. First of all Mac OS X gets it right in a lot of places and each modifier key has its own "domain":
- ctrl: Controls the cursor movements in text fields (ctrl-a: beginning of line, ctrl-e end of line, etc.)
- alt: Alternative Option: this sometimes gives access to alternative commands especially in menus by mouse or shortcut.
- cmd: Command via keyboard. This key is bigger than the others and it should be used for the Meta key in Emacs on OS X)

left and right alt and ctrl are the same just like shift one the left and the right is the same (except for Games, of course, because often they need to keep the physical / spatial layout constant across several keyboard layout for different languages.

Now I do not expect Ubuntu (Unity, Dash, Metacity and my favourite applications) to work exactly they same - but they do work the same as their BSD based counterpart when it comes to predefining a lot of desktop and window handling shortcuts. This is where Mac OS X gets it wrong: its dashboard has its own key and /show all windows/ (like super-w in Ubuntu which works great except for drag&drop operations) has its own key but then there are dozens of other predefined modifier-key combinations that I as a user suddenly can't use in my favourite application.

With Linux based systems like Ubuntu we suddenly see a lot of layers when it comes to keyboard events: keyboard, kernel, windowing system with window system core and window manager, toolkit, application
Each and every of these layers probably does its job very well but the same keyboard shortcut does not always produce the same results for me (This might be related to another bug report where Metacity does something with the keyboard shortcuts in lists). Especially but not only when working with working horses like Blender (just a guess) and Emacs (really bad experience here) it becomes annoying to see desktop features shadow application features. You can call that Keyboard Shortcut Madness or KSM

Now I know about xmodmap but when I checked last time (in a Virtual Machine) the Dash on the left side of the screen didn't even care about it which means this: it behaves like a game and seems to listen on raw keycodes which can't be remapped by xmodmap. That is a no no for something that should allow the user to get the job done: imagine your favourite cart race game can only be won when you put the breaks on cmd or alt?

Apart from to many keyboard shortcuts of my compiz based desktop game (yes it's really flashy) there is that other annoying issue where left and right alt behave differently. This might be an heritage from the original PC keyboard but this makes me a two finger typer who presses the modifier and shortcut key on the same side of the keyboard: in Emacs I have to Meta-X (which you need all of the time to "run" a command by name) with my left thumb on left alt and my middle finger on X. I knew how to play the guitar so my left hand is used to these spider exercises but when I want to enter "@" it's the same on the other side because. You do deliver keyboard maps for italian, english a...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions