[Packaging] Unity 2D should be easily installable via USC

Reported by Joe Simpson on 2011-04-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Unassigned
app-install-data-ubuntu (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

I think Unity 2D should be easily installable via the Ubuntu Software Centre, instead of having to google for how to do it.

The process should be Ubuntu Software Centre -> Search "Unity" -> Click Unity 2D (one package, not multiple that don't work) -> Install

TEST CASE:
1) Open Software Center
2) In the search box (top right of the window), type "unity"

Expected result: the search results show only the following packages: "unity" and "unity-2d"

Current result: the search results don’t show unity-2d (it is hidden in the additional technical items), instead they contain "unity-2d-places", "unity-2d-panel" and "unity-2d-launcher".

Aritchie (aritchie) wrote :

I agree. I recently reinstalled 11.04 on my laptop and had to resort to using the terminal to install unity-2d. I don't know why it is listed as 3 packages in the Software Center - Unity-2d Launcher, Unity-2d Places and Unity-2d Spread.

Olivier Tilloy (osomon) wrote :

You guys are absolutely right, when searching "Unity" in S-C, the only result related to the 2D version should be the unity-2d meta-package.
Currently the packages listed are: unity-2d-places, unity-2d-panel, unity-2d-launcher.
The other packages related appear when revealing the "technical items".

Changed in unity-2d:
importance: Undecided → High
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

By default S-C only shows packages categorized as applications.
We either need to make sure that only 'unity-2d' qualifies as such, or we need to find another way to have all the other packages hidden by default.

Michael Vogt (mvo) on 2011-05-03
Changed in app-install-data-ubuntu (Ubuntu):
status: New → Fix Committed
Changed in app-install-data-ubuntu (Ubuntu Natty):
status: New → In Progress
importance: Undecided → Medium
Changed in app-install-data-ubuntu (Ubuntu):
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

Marking "In Progress" as Michael has done the necessary modifications in app-install-data, this will require an SRU. Thanks Michael!

Changed in unity-2d:
milestone: none → 3.10
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2011-05-03
description: updated

Accepted app-install-data-ubuntu into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in app-install-data-ubuntu (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Olivier Tilloy (osomon) wrote :

I installed app-install-data 0.11.04.7.4 from natty-proposed and I can confirm that it fixes the issue. When searching "unity" in S-C, the only two results by default are now "unity" and "unity-2d", as expected.

Changed in unity-2d:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2011-05-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package app-install-data-ubuntu - 0.11.04.7.4

---------------
app-install-data-ubuntu (0.11.04.7.4) natty-proposed; urgency=low

  * menu-data-additional/unity-2d-meta.desktop:
    - add unity-2d meta package (LP: #773399)
  * menu-data/unity-2d-*.desktop:
    - removed, use the meta-package instead (LP: #773399)
  * merged branch:
     lp:~jbicha/app-install-data-ubuntu/cleanup-firefox-extensions
    to clean no longer available xul extensions (LP: #747760)
  * menu-data-additional/icedtea-plugin.desktop:
    - point to icetea-plugin instead of transitional icetea6-plugin
  * menu-data/libreoffice-startcenter.desktop:
    - fix component mismatch
  * menu-data-xul-extensions/mozgest.desktop:
    - remove no longer available extension
  * menu-data/jeex.desktop, menu-data/scribus-ng.desktop:
    - remove duplicated X-AppInstall-* entries (part of the upstream
      desktop file)
  * menu-data/conkeror.desktop:
    - remove no longer available package
  * menu-data/cairo-dock.desktop:
    - install full cairo-dock instead of cairo-dock-core (LP: #714194)
 -- Michael Vogt <email address hidden> Tue, 03 May 2011 11:55:51 +0200

Changed in app-install-data-ubuntu (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in app-install-data-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2011-05-05
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d:
milestone: 3.10 → 3.8.6
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers