[launcher] Launcher doesn’t autohide after an application requested attention

Bug #763116 reported by Aritchie on 2011-04-16
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Olivier Tilloy

Bug Description

I did not find this reported but maybe it has. I have noticed that when I have the Text Editor already running and click on a file from within nautilus - the file loads in the already opened Text Editor and the launcher gets stuck. I have to than restart the launcher via xkill to get it to hide again. Can anyone else reproduce this? I am using build bzr539 on Ubuntu beta 1.

Related branches

Aritchie (aritchie) wrote :

Hmm, now I just noticed after starting Evolution today that the launcher got stuck. Interesting.

Aritchie (aritchie) wrote :

Hmm, I am starting to see a pattern here. I had firefox 4 running with a page already showing. I also had empathy running. I went into the empathy menu -> Help -> About which brought up the about box and when I clicked on the web link in the empathy about box and it opened the empathy website in a new tab in firefox; the launcher showed up and locked into place - could not hide it anymore. Once again I had to run xkill to restart the launcher.

Aritchie (aritchie) wrote :

Hmm, I now started the text editor in super user mode and loaded a file from /usr/share/unity-2d/places folder and it casued the launcher to lock in place. It is getting weird.

Olivier Tilloy (osomon) wrote :

This is a regression introduced by revision 539. Thanks for noticing and for the swift bug report Adam!

What happens is that when an application requests attention ("urgent"), two separate handlers (onApplicationBecameUrgent in Launcher.qml and urgentAnimation.onRunningChanged in LauncherList.qml) call beginForceVisible() on the launcher. But only one of them calls the corresponding endForceVisible(). Since begin…() has been called more times than end…(), the launcher is stuck in a forced visible mode.

summary: - Text Editor and the launcher
+ [launcher] Launcher doesn’t autohide after an application requested
+ attention
Changed in unity-2d:
importance: Undecided → High
milestone: none → 3.8.4
status: New → Confirmed
Changed in unity-2d:
importance: High → Critical
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2011-04-18
Changed in unity-2d:
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2011-04-18
Changed in unity-2d:
status: In Progress → Fix Committed
Aritchie (aritchie) wrote :

Hmm, sorry about that last one - I was looking at some features here and launchpad and must have hit something I was not supposed to. Is there anyway to delete that last bobble?

Changed in unity-2d:
status: Fix Committed → Fix Released
Olivier Tilloy (osomon) on 2011-04-18
Changed in unity-2d:
status: Fix Released → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers