Panel and launcher are blank and non-functional when /usr is a symlink

Bug #757288 reported by Matthias Benkard on 2011-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Low
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

REPORT: Until yesterday, my system's /usr was a symlink pointing to something similar to /zstore/root/usr. I noticed that the launcher failed to load correctly with an error claiming that (as far as I remember) “/zstore/root//unity-2d/launcher.qml” could not be loaded. Replacing the symlink with a proper mount point made the problem go away.

SPECULATION: It seems to me that the implementation of isRunningInstalled() in config.h.in might be the culprit here, as it's not clear to me that QCoreApplication::applicationDirPath() yields the seemingly expected string “/usr/bin” when /usr is actually /zstore/root/usr.

IRRELEVANT RAMBLING: Unity 2D works great for me for now, though. (It really is great stuff!) This is my personal computer, after all, so I can mess around with mount points and bind-mounting and everything. Lucky me! :)

Related branches

Olivier Tilloy (osomon) wrote :

From my tests, QCoreApplication::applicationDirPath() resolves the symbolic links if any in the path.
A more clever comparison needs to be implemented, probably using QDir::canonicalPath().

Changed in unity-2d:
importance: Undecided → Low
status: New → Confirmed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
milestone: none → 5.4
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-02-17
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.4.0-0ubuntu1

---------------
unity-2d (5.4.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - unity-2d-launcher crashed with SIGABRT in qt_message_output()
      (LP: #854634)
    - Useless scroll arrows in Unity 2D global menus (LP: #913237)
    - [workspace switcher] Does not activate since bzr revision 900
      (LP: #928398)
    - On unity 2d when using Hebrew localization launcher won't load if you
      move cursor all the way to the right (LP: #877292)
    - panel 2D uses wrong width on multi monitor setup (LP: #880698)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - [dash] User can move dash around with ALT+LeftClick+Move (LP: #827838)
    - [launcher] UI does not distinguish between windows on this workspace and
      others (LP: #883172)
    - Panel and launcher are blank and non-functional when /usr is a symlink
      (LP: #757288)
    - Launcher - change to 'locked out' by default (LP: #928153)
  * debian/control:
    - Build-dep on latest nux (ABI break)
  * debian/*install, debian/control:
    - transition unity-2d-launcher and unity-2d-places to unity-2d-shell
    - breaks against older gnome-session (as components links changed)
 -- Didier Roche <email address hidden> Fri, 17 Feb 2012 14:21:45 +0100

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers