[dash] Cannot have KDE4 applications as shortcuts on home screen

Bug #750081 reported by Olivier Tilloy on 2011-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
High
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

The home screen of the dash uses the preferences set by gnome-default-applications-properties to show the preferred applications shortcuts. It infers the desktop file from the basename of the executable (e.g. /usr/bin/firefox → firefox.desktop).
Unfortunately this doesn’t work for KDE4 applications, which desktop files are located in /usr/share/applications/kde4/, and are consequently not found (the name of the desktop file parameter should be prefixed by "kde4-" for them to be found).

Olivier Tilloy (osomon) on 2011-04-04
description: updated
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → High
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Florian Boucault (fboucault) wrote :

Will be fixed by fix for bug #805063

Changed in unity-2d:
milestone: none → 3.8.12
assignee: nobody → Florian Boucault (fboucault)
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers