[dash] search field default text not cleared immediately when using chinese input method

Bug #745246 reported by Bill Filler on 2011-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

If you enable Chinese Input method (ibus) and use it's UI to enter chinese characters into the dash's search field, the default text (i.e. "search applications") is not cleared. The Chinese characters are entered on top of that text so you see both. The default text is not cleared until you hit enter.

Expected Behavior:
we need to clear the default string whenever characters are entered, regardless if they are entered via keyboard, input method, or copy/paste.

Steps to reproduce:
In Language Support Dialog:
 * Tab 1: Install Chinese/Simplified translations, input methods, and fonts
 * Tab 1: Apply System-Wide button
 * Tab 1: Select iBus in Keyboard Input Method System combo.
 * Tab2 (named "Regional Formats" in en _US"): Select Chinese and Apply.
 * Reboot/Relogin
 * Ctrl + Space enables /disables iBus
* enable ibus and select search field
* use ibus to enter characters
* see chinese characters in search field on top of "search applications"

Related branches

Bill Filler (bfiller) on 2011-03-29
Changed in unity-2d:
milestone: none → 3.10
assignee: nobody → Florian Boucault (fboucault)
importance: Undecided → Critical
Changed in unity-2d:
milestone: 3.10 → 3.8.2
Changed in unity-2d:
status: New → In Progress
Florian Boucault (fboucault) wrote :

After investigation I could not find any existing API in QML's TextInput that would indicate reliably to us that the user is currently choosing characters with iBus.

Florian Boucault (fboucault) wrote :

lp:~fboucault/unity-2d/hide_search_hint_upon_typing contains a workaround for the issue but it is unfortunately not reliable.

Florian Boucault (fboucault) wrote :

None of the trick/workarounds I tried seem to do any good. The fundamental issue is that there is no QML API that informs us of the iBus method being currently used.
In order to solve that, one would ideally add such API to the TextInput QML element (http://doc.qt.nokia.com/4.7.1/qml-textinput.html).

Changed in unity-2d:
status: In Progress → Confirmed
milestone: 3.8.2 → 3.10
Bill Filler (bfiller) wrote :

We should consider patching qt to expose the property we need.

tags: added: i18n
Kyle Nitzsche (knitzsche) wrote :

This bug still exists in unity-2d 3.8.2-0ubuntu2~bzr544.

Note that it is only evident in the Applications and Files and Folders (places, aka lenses). It is NOT present in the home place (because that search box contains no text to start with).

Perhaps a workaround is to remove the default text from the search boxes in Applications and in Files and Folders, thus bringing them into harmony with Home and removing the problem.

summary: - [dash] search field default text not cleared when using chinese input
- method
+ [dash] search field default text not cleared immediately when using
+ chinese input method
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-07-04
Changed in unity-2d:
milestone: 3.8.10 → 3.8.12
Florian Boucault (fboucault) wrote :

A new API has been introduced in Qt Quick 1.1 contained in Qt 4.7.4 and soon available in Oneiric:

http://doc.qt.nokia.com/4.7-snapshot/qml-textinput.html#inputMethodComposing-prop

Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
milestone: 3.8.12 → 3.8.14
Didier Roche (didrocks) on 2011-08-01
Changed in unity-2d:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-08-11
Changed in unity-2d:
milestone: 4.0 → 4.2
Changed in unity-2d:
milestone: 4.2 → 4.4
Didier Roche (didrocks) on 2011-09-01
Changed in unity-2d:
milestone: 4.4 → 4.6
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
milestone: 4.6 → 4.8
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.8.0-0ubuntu1

---------------
unity-2d (4.8.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - [window management] Alt tab does not switch to the desired application
      but instead set the urgency flag on the window (LP: #735205)
    - [dash] search field default text not cleared immediately when using
      chinese input method (LP: #745246)
    - [dash] Apps lens shows no result by default (LP: #834571)
    - unity-2d-panel crashed with SIGSEGV in
      IndicatorsWidget::onEntryRemoved() (LP: #846836)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Repeated indicators in unity-2d panel when second screen added
      (LP: #846441)
    - [dash] Lens navigation bar (buttons on lower edge of dash window) is
      accessible (LP: #826560)
    - [dash] Category filters is sorted according to their english names, even
      when another language is used (LP: #838023)
 -- Didier Roche <email address hidden> Thu, 15 Sep 2011 11:43:52 +0200

Changed in unity-2d (Ubuntu):
status: In Progress → Fix Released
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers