[spread] clicking launcher with open windows not working correctly across workspaces

Bug #745077 reported by Bill Filler on 2011-03-29
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ugo Riboni

Bug Description

The behavior to display window previews for an application with multiple windows is not working correctly across workspaces and is not consistent with unity-3d.

Here is the scenario:
1) open 2 terminals on workspace 1
2) open 1 terminal on workspace 2
3) open another application on workspace 3

Expected behavior:
- regardless of active workspace, clicking the terminal icon in launcher should show spread of ALL open terminal windows across workspaces (i.e. should show 3 terminals in above example). This is how unity-3d works in Natty.

Current behavior:
- our behavior is different and dependent on active workspace
- if workspace 1 is active, clicking the the laucher icon shows spread of just 2 terminals in that workspace. clicking launcher again cancels the spread
- if workspace 2 is active, clicking the launcher icon for terminal promotes the terminal in that workspace and does nothing else
- if workspace 3 or 4 is active clicking the launcher icon for terminal switches to workspace 1 promoting first terminal. clicking again shows spread of 2 windows in workspace 1.

We should simplify and be consistent with unity 3d.

Related branches

Florian Boucault: Approve on 2011-04-07
Bill Filler (bfiller) on 2011-03-29
Changed in unity-2d:
milestone: none → 3.10
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → Critical
Bill Filler (bfiller) wrote :

Sorry, one correction. In unity-3d if active workspace doesn't contain any terminals before is as follows:
- first click on launcher takes you to last active workspace that has a terminal and brings terminal to focus
- second click on launcher does a spread of ALL terminal windows

Florian Boucault (fboucault) wrote :

Our behaviour is the one intended by the design.

Changed in unity-2d:
status: New → Incomplete
Changed in unity-2d:
status: Incomplete → Confirmed
milestone: 3.10 → 3.8.2
Changed in unity-2d:
status: Confirmed → Triaged
status: Triaged → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers