[launcher] nautilus windows are not matched with the home icon

Bug #739454 reported by Olivier Tilloy on 2011-03-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-2d
High
Florian Boucault

Bug Description

To reproduce: click the 'home' icon in the launcher, nautilus opens up.

Expected result: the nautilus window is matched to the 'home' icon, the active arrow indicator is shown next to it.

Actual result: a new icon (the default 'file manager' icon) appears in the launcher and is matched with the nautilus window.

Olivier Tilloy (osomon) on 2011-03-21
description: updated
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
status: New → Confirmed
Aritchie (aritchie) wrote :

I was just playing with that last night. I changed the desktop file in the favorites list from nautilus.desktop to nautilus-home.desktop and got the same result. This was running unity-2d on maverick.

Changed in unity-2d:
milestone: none → 3.8
importance: Undecided → High
Olivier Tilloy (osomon) wrote :

When running the latest plain unity, for any nautilus window opened, bamf returns "nautilus-home.desktop" for the application’s destkop file.
When running the latest unity-2d, it returns "nautilus.desktop".

This was tested in the same conditions on both configurations, using bamf’s dbus API.

Changed in unity-2d:
status: Confirmed → In Progress
Olivier Tilloy (osomon) wrote :

I compared the contents of the file "/usr/share/applications/bamf.index", which bamf uses to match applications with desktop files, between unity and unity-2d, and they differ very little, but not on nautilus-related entries (neither in order nor in contents).

Here are the nautilus-related entries:

nautilus-autorun-software.desktop nautilus-autorun-software %u
nautilus-browser.desktop nautilus --no-desktop --browser %U
nautilus-computer.desktop nautilus --no-desktop computer:
nautilus-file-management-properties.desktop nautilus-file-management-properties
nautilus-folder-handler.desktop nautilus --no-desktop %U
nautilus-home.desktop nautilus --no-desktop
nautilus.desktop nautilus

Olivier Tilloy (osomon) wrote :

In unity, if I kill bamfdaemon, I can observe two interesting things:

 1) bamfdaemon is not automatically restarted, and as a consequence the launcher is completely unable to match new windows
 2) after manually restarting bamfdaemon, new nautilus windows are matched against "nautilus.desktop", that’s the same behaviour as in unity-2d

There must be something going on with when/how bamfdaemon is started in the first place.

Olivier Tilloy (osomon) wrote :

Another interesting observation: in a unity live session, if I remove the nautilus home icon from the favorites (uncheck "Keep In Launcher"), then log out and log in again, new nautilus windows will be matched against "nautilus.desktop", not "nautilus-home.desktop".

So it looks like the way the list of favorites is built when the launcher is started influences how bamf matches applications to desktop files.

Changed in unity-2d:
milestone: 3.8 → 3.10

Going to /usr/share/applications/ and launching either Home Folder or/and File Manager then closing only one of the windows, the rest of the windows related to nautilus will close as well.
This bug behaves the same way in Gnome using "Classic" so it's probably not a Unity-2d bug.

Hope this helps :)

I tried opening folders in a separate window under Gnome (Classic) and Unity-2d, and it does the same thing... Nautilus quits all the windows at the same time.

wait, I removed the Ayatana Overlay Scrollbars and now nautilus works as usual... Sorry about this.

Aritchie (aritchie) wrote :

After installing the 03-25 build - I went into gconf-editor and changed the favorites list to read nautilus.desktop to nautilus-home.desktop just to observe what would happen. It is rather interesting. :) After I restarted the launcher - sure enough the Home icon was ther instead of the file manager icon. Here is what happened after I clicked it. It indeed opened up my home folder but instead of putting another icon on the launcher as in the previous build - it changed the home icon back to the file manger icon and changed the background of the color to a silverish color. Very interesting. This was the 0.4 maverick build by the way.

Aritchie (aritchie) wrote :

Just to elaborate on it further. I have attached a before and after screenshot. As I said before this phenomenon started after updating with the latest build on 03-25-2011. This first one is the before launch.

Aritchie (aritchie) wrote :

...and this is the after launch screenshot.

Aritchie (aritchie) wrote :

It's different. :D

Olivier Tilloy (osomon) wrote :

Thanks for the report Aritchie. The issue you are describing is a slightly different one, already tracked by bug #741160.

Changed in unity-2d:
milestone: 3.10 → 3.8.2
Olivier Tilloy (osomon) wrote :

There’s a lot going on in the unity space around this issue (see for example bug #721121). Let’s wait for the dust to settle before re-assessing what needs to be fixed and how.

Changed in unity-2d:
status: In Progress → Confirmed
Changed in unity-2d:
milestone: 3.8.2 → 3.10
Aritchie (aritchie) wrote :

Yeah, I downloaded a slew of updates today and I like the new user-home icon. It is just too bad that there is something underneath the hood that keeps wanting to change the icon on the launcher back to that file manager icon.

Changed in unity-2d:
milestone: 3.10 → 3.8.4
Olivier Tilloy (osomon) wrote :

This was apparently fixed by a recent update to bamf.

Changed in unity-2d:
status: Confirmed → Fix Released
Olivier Tilloy (osomon) wrote :

Note that the icon being replaced by the default nautilus icon whenever it is launched is a different issue, tracked by bug #741160.

Changed in unity-2d:
status: Fix Released → In Progress
assignee: Olivier Tilloy (osomon) → Florian Boucault (fboucault)
Olivier Tilloy (osomon) on 2011-04-18
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers