clicking on top panel should raise maximized windows

Reported by Tom Jaeger on 2011-03-09
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity-2d
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
1. Start a maximized application
2. Start a unmaximized (restored) application
3. Focus the unmaximized (restored) application
4. Left-click the panel titlebar
   -> The maximized application should get focused and moved to the top

[Regression Potential]
Potentially clicking the panel with the mouse button can stop working or work incorrectly.

Original description:

This bug is very similar to bug #703411 and should be able to be fixed in much the same way. This issue comes up when raise-on-click is deactivated, in which case it is impossible to raise a maximized window that is not already on top. Clicking on the top panel should raise the window, just like middle-clicking lowers it. The fix should be reasonably simple; please let me know if I should provide a patch.

Related branches

lp:~thjaeger/unity/raise-maximized
Rejected for merging into lp:unity
Neil J. Patel (community): Approve on 2011-06-02
Jason Smith (community): Approve on 2011-06-02
Jorge O. Castro (jorge) wrote :

Hi Tom, a patch would be great, but here are instructions on how to submit a merge proposal (which is the preferred way to submit code to Unity) http://unity.ubuntu.com/getinvolved/

Thanks and good luck!

Changed in unity:
status: New → Confirmed
tags: added: bitesize
Tom Jaeger (thjaeger) wrote :

Thanks, I've made a patch and asked for a review. The fix turns out to be less useful than I anticipated since it requires the window that is to be raised to have focus, so raising the window will often still require two clicks.

Changed in unity-2d:
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
tags: added: delta-with-3d
Omer Akram (om26er) wrote :

This bug, I believe was fixed with a branch from Dylan.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Albert Astals Cid (aacid)
milestone: none → 5.14
Changed in unity-2d:
status: In Progress → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-05-30
Changed in unity (Ubuntu Precise):
status: New → Fix Released
Gerry Boland (gerboland) on 2012-05-30
Changed in unity-2d:
milestone: 5.14 → 5.12.1
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu Precise):
status: New → Confirmed
Changed in unity-2d:
milestone: 5.12.1 → 5.14
Changed in unity-2d:
milestone: 5.14 → none
status: Fix Committed → In Progress
Albert Astals Cid (aacid) wrote :

unassign from me, it seems that this is not SRU-able for 12.04 and unity-2d has been killed for 12.10 so not much more I can do

Changed in unity-2d:
assignee: Albert Astals Cid (aacid) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers